Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039516
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2018-10-23 16:302018-12-11 20:22
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q1
StatusclosedFix in branchFixed in SCM revisionf5adc2a709a6
ProjectionnoneETAnoneTarget Version
OSAnyDatabasePostgreSQLJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039516: PG 10: false local changes positive after restoring PG 9.3 dump

DescriptionHaving a PostgreSQL 10 or 11 database created from a dump obtained from 9.3, updata.database incorrectly detects local changes in DB structure.

Workarround: execute 1st update with -Dforce=true parameter.
Steps To Reproduce1. Install Openbravo (at least 18Q1) in PostgreSQL 9.3 (ie. Openbravo Appliance 14.04)
2. Do a pg_dump
3. Restore that pg_dump in a PostgreSQL 10 or 11
4. Run ant update.database
  -> ERROR: local changes detected
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00395203.0PR18Q4 closedalostale PG 10: false local changes positive after restoring PG 9.3 dump 
depends on backport 00395213.0PR18Q3.2 closedalostale PG 10: false local changes positive after restoring PG 9.3 dump 
depends on backport 00395223.0PR18Q2.3 closedalostale PG 10: false local changes positive after restoring PG 9.3 dump 
blocks feature request 0036911 closedalostale support PostgreSQL 10 

-  Notes
(0107544)
hgbot (developer)
2018-10-24 10:31

Repository: erp/devel/pi
Changeset: f5adc2a709a639f4aa1717ba3aed94e6273061f0
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Oct 24 10:31:04 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f5adc2a709a639f4aa1717ba3aed94e6273061f0 [^]

fixed bug 39516: false local changes positive restoring PG 9.3 dump on PG 10

  After restoring in PG 10 a DB dump taken in PG 9.3, first update.database run
  incorrectly detects local changes.

  This was caused by many new functions added in PG 10 to trigram extension, those
  functions were unnecessarily included in the model checksum used to check if
  there are local changes.

  Now those functions are excluded: as dbsm only supports plsql functions, we now
  filter out all the ones implemented by binary code, which is how typically
  extension functions are implemented.

---
M src-db/database/model/prescript-PostgreSql.sql
---
(0107545)
alostale (developer)
2018-10-24 10:32

Note: this fix to take effect needs to be applied in old DB and execute update.database there at least once before taking the dump.
(0107635)
caristu (developer)
2018-10-29 11:24

Reviewed
(0108440)
hudsonbot (developer)
2018-12-11 20:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/470e3cd384c5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-10-23 16:30 alostale New Issue
2018-10-23 16:30 alostale Assigned To => platform
2018-10-23 16:30 alostale Modules => Core
2018-10-23 16:30 alostale Triggers an Emergency Pack => No
2018-10-23 16:32 alostale Assigned To platform => alostale
2018-10-24 10:19 alostale Relationship added blocks 0036911
2018-10-24 10:21 alostale Review Assigned To => caristu
2018-10-24 10:22 alostale Status new => scheduled
2018-10-24 10:31 hgbot Checkin
2018-10-24 10:31 hgbot Note Added: 0107544
2018-10-24 10:31 hgbot Status scheduled => resolved
2018-10-24 10:31 hgbot Resolution open => fixed
2018-10-24 10:31 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f5adc2a709a639f4aa1717ba3aed94e6273061f0 [^]
2018-10-24 10:32 alostale Note Added: 0107545
2018-10-29 11:24 caristu Note Added: 0107635
2018-10-29 11:24 caristu Status resolved => closed
2018-10-29 11:24 caristu Fixed in Version => 3.0PR19Q1
2018-12-11 20:22 hudsonbot Checkin
2018-12-11 20:22 hudsonbot Note Added: 0108440


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker