Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039487
TypeCategorySeverityReproducibilityDate SubmittedLast Update
design defect[Openbravo ERP] A. Platformminorhave not tried2018-10-19 08:122020-01-31 08:34
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionc2c80c697b3e
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version10+
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039487: can't serve SOAP webservices compiled with JDK10+

DescriptionSOAP webservices served from Openbravo that are implemented by Java compiled with JDK10+ fail with HTTP error 500 caused by Exception - java.lang.IllegalStateException: Error looking for paramter names in bytecode: unexpected bytes in file.
Steps To ReproduceUsing JDK10+:

1. Enable SOAP server [1]
2. Create a SOAP webservice having at least one method with at least one parameter
3. Deploy it to Tomcat: ant installWebservice
4. Try to use it from a client
   -> ERROR: HTTP 500: Error looking for parameter names in bytecode: unexpected bytes in file.
5. Try to access to /services path
   -> ERROR: Error looking for paramter names in bytecode: unexpected bytes in file.

---
[1] http://wiki.openbravo.com/wiki/Development_Build_Tasks#SOAP_Webservice_Server_Tasks [^]
Proposed SolutionThe problem is in old axis library included within Openbravo, using this library is discouraged.

If required while migrating to a newer infrastructure, it is possible to replace axis jar with patched one published here [1].


[1] https://github.com/alostale/axis1-java/releases/tag/1.4-patched [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0037683 closedalostale Axis services page is always available 
related to feature request 0038196 closedplatform support for JDK 10 
related to design defect 0040536 closedalostale Remove support for axis 

-  Notes
(0117348)
hgbot (developer)
2020-01-30 09:34

Repository: erp/mods/org.openbravo.legacy.axis
Changeset: c2c80c697b3e87af25f1fcb94930747de016954b
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Jan 30 09:18:57 2020 +0100
URL: http://code.openbravo.com/erp/mods/org.openbravo.legacy.axis/rev/c2c80c697b3e87af25f1fcb94930747de016954b [^]

fixed BUG-39487: can't serve SOAP webservices compiled with JDK10+

  Patched axis.jar to support JDK10+. Sources for patch can be found at:

   https://github.com/alostale/axis1-java/tree/1.4-patched [^]

---
A lib/runtime/axis-1.4-patched.jar
R lib/runtime/axis.jar
---
(0117390)
caristu (developer)
2020-01-31 08:34

Reviewed: https://gitlab.com/openbravo/product/mods/org.openbravo.legacy.axis/-/merge_requests/1 [^]

- Issue History
Date Modified Username Field Change
2018-10-19 08:12 alostale New Issue
2018-10-19 08:12 alostale Assigned To => platform
2018-10-19 08:12 alostale Modules => Core
2018-10-19 08:12 alostale Triggers an Emergency Pack => No
2018-10-19 08:12 alostale Status new => acknowledged
2018-10-19 08:13 alostale Relationship added related to 0037683
2018-10-19 08:14 alostale Relationship added related to 0038196
2018-11-12 10:00 alostale Type defect => design defect
2018-11-12 10:00 alostale Steps to Reproduce Updated View Revisions
2018-11-12 10:00 alostale Proposed Solution updated
2019-04-05 11:00 caristu Relationship added related to 0040536
2020-01-30 09:09 alostale Assigned To platform => alostale
2020-01-30 09:09 alostale Review Assigned To => caristu
2020-01-30 09:34 hgbot Checkin
2020-01-30 09:34 hgbot Note Added: 0117348
2020-01-30 09:34 hgbot Status acknowledged => resolved
2020-01-30 09:34 hgbot Resolution open => fixed
2020-01-30 09:34 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/mods/org.openbravo.legacy.axis/rev/c2c80c697b3e87af25f1fcb94930747de016954b [^]
2020-01-31 08:34 caristu Note Added: 0117390
2020-01-31 08:34 caristu Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker