Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039475
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Modules] Advance Warehouse Operationsmajoralways2018-10-17 22:222018-11-12 09:01
ReporterlbressanView Statuspublic 
Assigned Toguilleaer 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision39fd113dcac3
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabasePostgreSQLJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Regression date
Regression introduced by commit
Regression level
Review Assigned Tojorge-garcia
Regression introduced in release
Summary

0039475: [AWOFE] Default Confirmed Quantity of Warehouse Front-End Configuration doen't work on Warehouse level

DescriptionWhen generating the tasks for the lines of a purchase order, where the selected warehouse has a front-end configuration defined with its Default Confirmed Quantity field unchecked, the tasks generated in the front-end appear with the confirmed quantity equal to the expected quantity, when they should be shown with zero value. (Confirmed-Qty-Incorrect.png)
If the tasks are generated with the front-end configuration at the routing level, the confirmed quantity is displayed correctly.
(Confirmed-Qty-Correct.png)
Steps To Reproduce1) Create a Purchase Order (Make sure to select a warehouse with Front-End configuration where the Default Confirmed Quantity field is unchecked
(Front-End-Configuration.png)
2) Create Order Lines with Operative Quantity different from zero.
3) Process the Order
4) Generate reception tasks
4) Go to front-end and check the value of the confirmed quantity, it appears equal to the expected quantity
TagsNo tags attached.
Attached Fileszip file icon Screenshots.zip [^] (135,854 bytes) 2018-10-17 22:22
diff file icon issue39475.diff [^] (6,550 bytes) 2018-10-24 18:06 [Show Content]

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0107568)
hgbot (developer)
2018-10-25 10:38

Repository: erp/pmods/org.openbravo.warehouse.advancedwarehouseoperations
Changeset: 9896f177dada6d7bfa7a8b84544d6cb8b19666ad
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Thu Oct 25 10:37:42 2018 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.warehouse.advancedwarehouseoperations/rev/9896f177dada6d7bfa7a8b84544d6cb8b19666ad [^]

Fixed issue 39475: Load configurations which are not being used at IR level

Because of a bug, configurations which are not defined at IR level are not being loaded. It can result in a configuration selected by default for the warehouse which is not used in any IR so it is not loaded in the FE side. It causes that configuration is not applied.

- Add a new query to load those configurations not referenced by any IR
- Adapat query properties file. now 2 queries are executed
- Add indexes to improve the query performance
- Add some comments in the client side code to better understanding

---
M src-db/database/model/tables/OBAWO_IR_MOBILE_BEHAVIOR.xml
M src/org/openbravo/warehouse/advancedwarehouseoperations/mobile/master/InternalRoutingRoleConfiguration.java
M src/org/openbravo/warehouse/advancedwarehouseoperations/mobile/master/InternalRoutingRoleConfigurationProperties.java
M web/org.openbravo.warehouse.advancedwarehouseoperations/source/utils/obawo-utils.js
---
(0107569)
hgbot (developer)
2018-10-25 10:39

Repository: retail/backports/AWO/3.0RR18Q3/org.openbravo.warehouse.advancedwarehouseoperations
Changeset: 39fd113dcac31ff00c1ec4f8bced8a080bd8b2ab
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Thu Oct 25 10:37:42 2018 +0200
URL: http://code.openbravo.com/retail/backports/AWO/3.0RR18Q3/org.openbravo.warehouse.advancedwarehouseoperations/rev/39fd113dcac31ff00c1ec4f8bced8a080bd8b2ab [^]

Fixed issue 39475: Load configurations which are not being used at IR level

Because of a bug, configurations which are not defined at IR level are not being loaded. It can result in a configuration selected by default for the warehouse which is not used in any IR so it is not loaded in the FE side. It causes that configuration is not applied.

- Add a new query to load those configurations not referenced by any IR
- Adapat query properties file. now 2 queries are executed
- Add indexes to improve the query performance
- Add some comments in the client side code to better understanding

---
M src-db/database/model/tables/OBAWO_IR_MOBILE_BEHAVIOR.xml
M src/org/openbravo/warehouse/advancedwarehouseoperations/mobile/master/InternalRoutingRoleConfiguration.java
M src/org/openbravo/warehouse/advancedwarehouseoperations/mobile/master/InternalRoutingRoleConfigurationProperties.java
M web/org.openbravo.warehouse.advancedwarehouseoperations/source/utils/obawo-utils.js
---
(0107657)
hgbot (developer)
2018-10-30 13:02

Repository: retail/backports/AWO/3.0RR18Q3/org.openbravo.warehouse.advancedwarehouseoperations
Changeset: c7048c10443d084ca1d172f03ba4e199412c7e75
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Tue Oct 30 13:02:34 2018 +0100
URL: http://code.openbravo.com/retail/backports/AWO/3.0RR18Q3/org.openbravo.warehouse.advancedwarehouseoperations/rev/c7048c10443d084ca1d172f03ba4e199412c7e75 [^]

Related to issue 39475: Fix compilation problem using java 7

---
M src/org/openbravo/warehouse/advancedwarehouseoperations/mobile/master/InternalRoutingRoleConfigurationProperties.java
---
(0107809)
hgbot (developer)
2018-11-08 18:52

Repository: erp/pmods/org.openbravo.warehouse.advancedwarehouseoperations
Changeset: f2471d939cd6f09e931028c659938bc8912b36f9
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Thu Nov 08 18:52:04 2018 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.warehouse.advancedwarehouseoperations/rev/f2471d939cd6f09e931028c659938bc8912b36f9 [^]

Related to issue 39475: Send JSONObject as a parameter instead of boolean allowing further changes

---
M src/org/openbravo/warehouse/advancedwarehouseoperations/mobile/master/InternalRoutingRoleConfiguration.java
M src/org/openbravo/warehouse/advancedwarehouseoperations/mobile/master/InternalRoutingRoleConfigurationProperties.java
---
(0107810)
hgbot (developer)
2018-11-08 18:57

Repository: retail/backports/AWO/3.0RR18Q3/org.openbravo.warehouse.advancedwarehouseoperations
Changeset: 3001b6613fd165c1a93fbdcac30dc262e5d2e2aa
Author: Guillermo Alvarez de Eulate <guillermo.alvarez <at> openbravo.com>
Date: Thu Nov 08 18:52:04 2018 +0100
URL: http://code.openbravo.com/retail/backports/AWO/3.0RR18Q3/org.openbravo.warehouse.advancedwarehouseoperations/rev/3001b6613fd165c1a93fbdcac30dc262e5d2e2aa [^]

Related to issue 39475: Send JSONObject as a parameter instead of boolean allowing further changes

---
M src/org/openbravo/warehouse/advancedwarehouseoperations/mobile/master/InternalRoutingRoleConfiguration.java
M src/org/openbravo/warehouse/advancedwarehouseoperations/mobile/master/InternalRoutingRoleConfigurationProperties.java
---
(0107835)
jorge-garcia (developer)
2018-11-12 09:01

Code reviewed and tested

- Issue History
Date Modified Username Field Change
2018-10-17 22:22 lbressan New Issue
2018-10-17 22:22 lbressan Assigned To => Triage Finance
2018-10-17 22:22 lbressan File Added: Screenshots.zip
2018-10-17 22:37 Practics Issue Monitored: Practics
2018-10-18 10:56 Sandrahuguet Assigned To Triage Finance => guilleaer
2018-10-23 08:39 guilleaer Summary Default Confirmed Quantity of Warehouse Front-End Configuration doen't work on Warehouse level => [AWOFE] Default Confirmed Quantity of Warehouse Front-End Configuration doen't work on Warehouse level
2018-10-23 11:17 jorge-garcia Assigned To guilleaer => Retail
2018-10-24 18:06 guilleaer File Added: issue39475.diff
2018-10-25 10:38 hgbot Checkin
2018-10-25 10:38 hgbot Note Added: 0107568
2018-10-25 10:38 hgbot Status new => resolved
2018-10-25 10:38 hgbot Resolution open => fixed
2018-10-25 10:38 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.warehouse.advancedwarehouseoperations/rev/9896f177dada6d7bfa7a8b84544d6cb8b19666ad [^]
2018-10-25 10:39 hgbot Checkin
2018-10-25 10:39 hgbot Note Added: 0107569
2018-10-25 10:39 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.warehouse.advancedwarehouseoperations/rev/9896f177dada6d7bfa7a8b84544d6cb8b19666ad [^] => http://code.openbravo.com/retail/backports/AWO/3.0RR18Q3/org.openbravo.warehouse.advancedwarehouseoperations/rev/39fd113dcac31ff00c1ec4f8bced8a080bd8b2ab [^]
2018-10-25 10:39 guilleaer Assigned To Retail => guilleaer
2018-10-30 13:02 hgbot Checkin
2018-10-30 13:02 hgbot Note Added: 0107657
2018-11-08 18:52 hgbot Checkin
2018-11-08 18:52 hgbot Note Added: 0107809
2018-11-08 18:57 hgbot Checkin
2018-11-08 18:57 hgbot Note Added: 0107810
2018-11-12 09:01 jorge-garcia Review Assigned To => jorge-garcia
2018-11-12 09:01 jorge-garcia Note Added: 0107835
2018-11-12 09:01 jorge-garcia Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker