Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039400
TypeCategorySeverityReproducibilityDate SubmittedLast Update
design defect[Openbravo ERP] A. PlatformmajorN/A2018-10-04 09:482018-12-11 20:22
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PriorityurgentResolutionfixedFixed in Version3.0PR19Q1
StatusclosedFix in branchFixed in SCM revision81abb68df45a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039400: session is not Serializable

DescriptionCurrently several objects that are set in session are not serializable. In order to make sessions distributable among different nodes in a cluster, it is necessary to serialize it, so all objects set in session should be serializable.

This is a pre-requisite to be able not to have sticky sessions in cluster 0035440.
Steps To Reproduce-
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on defect 0039502 closedalostale API change: removed methods in OBContext 
blocks design defect 0035440 acknowledgedplatform tomcat clustering is restricted to sticky sessions 
blocks design defect 0034490 acknowledgedplatform [clustering] Support clustering 
blocks feature request 0039431 acknowledgedplatform mark application as distributable 

-  Notes
(0107480)
hgbot (developer)
2018-10-22 14:28

Repository: erp/devel/pi
Changeset: 81abb68df45a5bfea2d4cec0fef1f89e78cfe5ec
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Mon Oct 22 14:27:12 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/81abb68df45a5bfea2d4cec0fef1f89e78cfe5ec [^]

fixed issue 39400: Openbravo session is now Serializable

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/window/FormInitializationComponent.java
M src-core/src/org/openbravo/base/MultipartRequest.java
M src-core/src/org/openbravo/base/VariablesBase.java
M src-core/src/org/openbravo/data/FieldProvider.java
M src-core/src/org/openbravo/data/Sqlc.java
M src-core/src/org/openbravo/uiTranslation/FieldGroupLabelsData.java
M src-core/src/org/openbravo/uiTranslation/FieldLabelsData.java
M src-core/src/org/openbravo/uiTranslation/InterfaceModuleInfoData.java
M src-core/src/org/openbravo/uiTranslation/InterfaceTrlInfoData.java
M src-core/src/org/openbravo/uiTranslation/ProcessLabelsData.java
M src-core/src/org/openbravo/uiTranslation/TextInterfacesData.java
M src-test/src/org/openbravo/test/AllAntTaskTests.java
M src-test/src/org/openbravo/test/dal/OBContextTest.java
M src/org/openbravo/base/secureApp/DefaultValuesData.java
M src/org/openbravo/dal/core/OBContext.java
M src/org/openbravo/dal/security/OrganizationStructureProvider.java
M src/org/openbravo/erpCommon/ad_forms/MaturityLevel.java
M src/org/openbravo/erpCommon/ad_forms/SQLExecutor_Query.java
M src/org/openbravo/erpCommon/ad_forms/ShowSessionVariablesStructureData.java
M src/org/openbravo/erpCommon/ad_help/HelpWindow.java
M src/org/openbravo/erpCommon/ad_reports/SummaryProductCategory.java
M src/org/openbravo/erpCommon/businessUtility/COAData.java
M src/org/openbravo/erpCommon/modules/ImportModule.java
M src/org/openbravo/erpCommon/utility/FieldProviderFactory.java
M src/org/openbravo/erpCommon/utility/OBError.java
M src/org/openbravo/erpCommon/utility/OBObjectFieldProvider.java
M src/org/openbravo/erpCommon/utility/SQLReturnObject.java
M src/org/openbravo/erpCommon/utility/SetPriorityCategoryData.java
M src/org/openbravo/erpCommon/utility/SimpleFieldProvider.java
M src/org/openbravo/erpCommon/utility/reporting/Report.java
M src/org/openbravo/erpCommon/utility/reporting/printing/AttachContent.java
M src/org/openbravo/erpCommon/utility/reporting/printing/PrintController.java
M src/org/openbravo/erpReports/ReportTaxPaymentJR.java
M src/org/openbravo/erpReports/ReportVatRegisterJR.java
---
(0107575)
hgbot (developer)
2018-10-25 12:18

Repository: erp/pmods/org.openbravo.creditmanagement.dunning
Changeset: 9d1d7a0a40d4daa44d159793965c1b42308dd4eb
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Oct 25 12:17:32 2018 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.creditmanagement.dunning/rev/9d1d7a0a40d4daa44d159793965c1b42308dd4eb [^]

related to issue 39400: supress serial warns

---
M src/org/openbravo/creditmanagement/dunning/biz/DunningReportData.java
M src/org/openbravo/creditmanagement/dunning/biz/FinPaymentScheduleInvVData.java
M src/org/openbravo/creditmanagement/dunning/biz/OBMessage.java
M src/org/openbravo/creditmanagement/dunning/forms/DunningRunData.java
M src/org/openbravo/creditmanagement/dunning/forms/LevelData.java
---
(0107576)
hgbot (developer)
2018-10-25 12:18

Repository: erp/pmods/org.openbravo.document.massinvoicing
Changeset: 11de27a7f48e084a86d5511fd94aaca338a87ff2
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Oct 25 12:17:49 2018 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.document.massinvoicing/rev/11de27a7f48e084a86d5511fd94aaca338a87ff2 [^]

related to issue 39400: supress serial warns

---
M src/org/openbravo/document/massinvoicing/MINVComboFieldProvider.java
M src/org/openbravo/document/massinvoicing/MINVMapFieldProvider.java
M src/org/openbravo/document/massinvoicing/MassInvoicing.java
---
(0107577)
hgbot (developer)
2018-10-25 12:19

Repository: erp/pmods/org.openbravo.externaldata.integration
Changeset: aa04105f4dbfa472d822dd1357574311efa6e80b
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Oct 25 12:17:49 2018 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.externaldata.integration/rev/aa04105f4dbfa472d822dd1357574311efa6e80b [^]

related to issue 39400: supress serial warns

---
M src-db/database/model/tables/OBEDL_REQUEST.xml
---
(0107578)
hgbot (developer)
2018-10-25 12:19

Repository: erp/mods/org.openbravo.module.generictreereport
Changeset: 0994b1552b04a26dd668dcda5f09f57334bdca3a
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Oct 25 12:17:49 2018 +0200
URL: http://code.openbravo.com/erp/mods/org.openbravo.module.generictreereport/rev/0994b1552b04a26dd668dcda5f09f57334bdca3a [^]

related to issue 39400: supress serial warns

---
M src/org/openbravo/module/generictreereport/ad_reports/TreeReportData.java
---
(0107579)
hgbot (developer)
2018-10-25 12:19

Repository: erp/mods/org.openbravo.utility.hqlquerytool
Changeset: e7878a1efbbb618f602d156986bc38964c69489c
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Oct 25 12:17:49 2018 +0200
URL: http://code.openbravo.com/erp/mods/org.openbravo.utility.hqlquerytool/rev/e7878a1efbbb618f602d156986bc38964c69489c [^]

related to issue 39400: supress serial warns

---
M src/org/openbravo/utility/hqlquerytool/HQLSimpleFieldProvider.java
---
(0107580)
hgbot (developer)
2018-10-25 12:19

Repository: erp/pmods/org.openbravo.warehouse.pickinglist
Changeset: f88bccdd0f9ddb0c210242eb845f3e9c46a26ced
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Oct 25 12:17:50 2018 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.warehouse.pickinglist/rev/f88bccdd0f9ddb0c210242eb845f3e9c46a26ced [^]

related to issue 39400: supress serial warns

---
M src-db/database/model/views/OBWPL_PICKINGLIST_PICK_EDIT.xml
---
(0107581)
hgbot (developer)
2018-10-25 12:22

Repository: erp/pmods/org.openbravo.warehouse.pickinglist
Changeset: ca604b13ab743ff86f1acdaee3717a5929c96308
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Oct 25 12:21:58 2018 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.warehouse.pickinglist/rev/ca604b13ab743ff86f1acdaee3717a5929c96308 [^]

related to issue 39400: backed out unintended changeset f88bccdd0f9d

---
M src-db/database/model/views/OBWPL_PICKINGLIST_PICK_EDIT.xml
---
(0107582)
hgbot (developer)
2018-10-25 12:25

Repository: erp/pmods/org.openbravo.externaldata.integration
Changeset: c61a0c9007f56e039a0e399842e6a64bc07f7ca6
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Oct 25 12:25:45 2018 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.externaldata.integration/rev/c61a0c9007f56e039a0e399842e6a64bc07f7ca6 [^]

related to issue 39400: backed out unintended changeset aa04105f4dbf

---
M src-db/database/model/tables/OBEDL_REQUEST.xml
---
(0107647)
hgbot (developer)
2018-10-30 07:52

Repository: erp/pmods/org.openbravo.creditmanagement.dunning
Changeset: 64983d5a34fba390510de7689daf3649747a062f
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Oct 30 07:52:52 2018 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.creditmanagement.dunning/rev/64983d5a34fba390510de7689daf3649747a062f [^]

related to issue 39400: removed redundant serialVersionUID

---
M src/org/openbravo/creditmanagement/dunning/biz/DunningReportData.java
M src/org/openbravo/creditmanagement/dunning/biz/FinPaymentScheduleInvVData.java
M src/org/openbravo/creditmanagement/dunning/biz/OBMessage.java
M src/org/openbravo/creditmanagement/dunning/forms/DunningRunData.java
M src/org/openbravo/creditmanagement/dunning/forms/LevelData.java
---
(0107648)
hgbot (developer)
2018-10-30 07:53

Repository: erp/pmods/org.openbravo.document.massinvoicing
Changeset: 9f122176c50c09f35603373c39549efb7eb9ce5b
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Oct 30 07:53:29 2018 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.document.massinvoicing/rev/9f122176c50c09f35603373c39549efb7eb9ce5b [^]

related to issue 39400: removed redundant serialVersionUID

---
M src/org/openbravo/document/massinvoicing/MINVComboFieldProvider.java
M src/org/openbravo/document/massinvoicing/MINVMapFieldProvider.java
---
(0107649)
hgbot (developer)
2018-10-30 07:53

Repository: erp/mods/org.openbravo.module.generictreereport
Changeset: 54531e2885218d1ab50ce638b502539c95a8948f
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue Oct 30 07:53:52 2018 +0100
URL: http://code.openbravo.com/erp/mods/org.openbravo.module.generictreereport/rev/54531e2885218d1ab50ce638b502539c95a8948f [^]

related to issue 39400: removed redundant serialVersionUID

---
M src/org/openbravo/module/generictreereport/ad_reports/TreeReportData.java
---
(0107807)
caristu (developer)
2018-11-08 18:30

Code reviewed. See: https://docs.google.com/spreadsheets/d/1EuvL6Yj69PU7-EAmHuxbjSq-lhVDXVZLWeHxVY3yGAk/edit#gid=0 [^]
(0108439)
hudsonbot (developer)
2018-12-11 20:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/470e3cd384c5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-10-04 09:48 alostale New Issue
2018-10-04 09:48 alostale Assigned To => alostale
2018-10-04 09:48 alostale Modules => Core
2018-10-04 09:48 alostale Triggers an Emergency Pack => No
2018-10-04 09:48 alostale Relationship added blocks 0035440
2018-10-04 09:48 alostale Status new => acknowledged
2018-10-04 09:49 alostale Relationship added blocks 0034490
2018-10-04 09:51 alostale Review Assigned To => caristu
2018-10-04 09:52 alostale Description Updated View Revisions
2018-10-10 13:19 alostale Relationship added blocks 0039431
2018-10-22 14:28 hgbot Checkin
2018-10-22 14:28 hgbot Note Added: 0107480
2018-10-22 14:28 hgbot Status acknowledged => resolved
2018-10-22 14:28 hgbot Resolution open => fixed
2018-10-22 14:28 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/81abb68df45a5bfea2d4cec0fef1f89e78cfe5ec [^]
2018-10-22 14:34 alostale Relationship added depends on 0039502
2018-10-25 12:18 hgbot Checkin
2018-10-25 12:18 hgbot Note Added: 0107575
2018-10-25 12:18 hgbot Checkin
2018-10-25 12:18 hgbot Note Added: 0107576
2018-10-25 12:19 hgbot Checkin
2018-10-25 12:19 hgbot Note Added: 0107577
2018-10-25 12:19 hgbot Checkin
2018-10-25 12:19 hgbot Note Added: 0107578
2018-10-25 12:19 hgbot Checkin
2018-10-25 12:19 hgbot Note Added: 0107579
2018-10-25 12:19 hgbot Checkin
2018-10-25 12:19 hgbot Note Added: 0107580
2018-10-25 12:22 hgbot Checkin
2018-10-25 12:22 hgbot Note Added: 0107581
2018-10-25 12:25 hgbot Checkin
2018-10-25 12:25 hgbot Note Added: 0107582
2018-10-30 07:52 hgbot Checkin
2018-10-30 07:52 hgbot Note Added: 0107647
2018-10-30 07:53 hgbot Checkin
2018-10-30 07:53 hgbot Note Added: 0107648
2018-10-30 07:53 hgbot Checkin
2018-10-30 07:53 hgbot Note Added: 0107649
2018-11-08 18:30 caristu Note Added: 0107807
2018-11-08 18:30 caristu Status resolved => closed
2018-11-08 18:30 caristu Fixed in Version => 3.0PR19Q1
2018-12-11 20:22 hudsonbot Checkin
2018-12-11 20:22 hudsonbot Note Added: 0108439


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker