Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039361
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Modules] Analyticsmajorhave not tried2018-09-27 14:152018-10-26 08:11
ReporterngarciaView Statuspublic 
Assigned Tocaristu 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision455d94f6f8b5
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Regression date
Regression introduced by commit
Regression level
Review Assigned Toalostale
Regression introduced in release
Summary

0039361: Cubes not shown in OB Analytics window after upgrading from a version prior to 1.3.0 if there is a dimension with XML definition

DescriptionCubes not shown in OB Analytics window after upgrading from a version prior to 1.3.0 if there is a dimension with XML definition
Steps To ReproduceAs group admin role:
   Create a new dimension for Sales Details Fact Cube


   As XML Definition field was removed in 1.3.0 due to the following commit, we will assign a value to it through database

   https://code.openbravo.com/erp/pmods/org.openbravo.client.analytics/rev/266570766403 [^]

update obanaly_cube_dimension
set xmldefinition = '<Dimension caption="Product" table="alias1_73" key="product-key" name="product">
<Attributes>
<Attribute name="product-key" visible="false" keyColumn="m_product_id" caption="Product" hasHierarchy="false">
<Annotations>
<Annotation name="entity">Product</Annotation>
</Annotations>
<MemberFormatter className="org.openbravo.client.analytics.mondrian.OBMondrianMemberFormatter"/>
</Attribute>
<Attribute name="productLevel" table="alias1_73" keyColumn="m_product_id" caption="Product" visible="true" orderByColumn="name">
<Annotations>
<Annotation name="entity">Product</Annotation>
</Annotations>
<MemberFormatter className="org.openbravo.client.analytics.mondrian.OBMondrianMemberFormatter"/>
</Attribute>
</Attributes>
</Dimension>'
where obanaly_cube_dimension_id = '<idOfDimensionCreated>'

As group admin role:
   Go to OB Analytics window and refresh the cubes
   Check no cubes are shown and the log shows:

      Caused by: mondrian.rolap.RolapSchema$MondrianSchemaException: table 'obanaly_time_dimension' not found (in Dimension 'dateDelivered') (at line 901, column 6)
    at mondrian.rolap.RolapSchemaLoaderHandlerImpl.error(RolapSchemaLoaderHandlerImpl.java:117)
    at mondrian.rolap.RolapSchemaLoader.getPhysRelation(RolapSchemaLoader.java:4110)
    at mondrian.rolap.RolapSchemaLoader.getOrCreateDimension(RolapSchemaLoader.java:2740)
    at mondrian.rolap.RolapSchemaLoader.createCube(RolapSchemaLoader.java:1563)
    at mondrian.rolap.RolapSchemaLoader.loadStage2(RolapSchemaLoader.java:420)
    at mondrian.rolap.RolapSchemaLoader.loadStage1(RolapSchemaLoader.java:336)
    at mondrian.rolap.RolapSchemaLoader.loadStage0(RolapSchemaLoader.java:272)
    at mondrian.rolap.RolapSchemaLoader.createSchema(RolapSchemaLoader.java:4303)
    at mondrian.rolap.RolapSchemaPool.get(RolapSchemaPool.java:179)
    at mondrian.rolap.RolapSchemaPool.get(RolapSchemaPool.java:62)
    at mondrian.rolap.RolapConnection.<init>(RolapConnection.java:160)
    at mondrian.rolap.RolapConnection.<init>(RolapConnection.java:84)
    at mondrian.olap.DriverManager.getConnection(DriverManager.java:112)
    at mondrian.olap.DriverManager.getConnection(DriverManager.java:68)
    at mondrian.olap4j.MondrianOlap4jConnection.<init>(MondrianOlap4jConnection.java:153)
    at mondrian.olap4j.FactoryJdbc4Plus$AbstractConnection.<init>(FactoryJdbc4Plus.java:323)
    at mondrian.olap4j.FactoryJdbc41Impl$MondrianOlap4jConnectionJdbc41.<init>(FactoryJdbc41Impl.java:118)
    at mondrian.olap4j.FactoryJdbc41Impl.newConnection(FactoryJdbc41Impl.java:32)
    at mondrian.olap4j.MondrianOlap4jDriver.connect(MondrianOlap4jDriver.java:139)
    at java.sql.DriverManager.getConnection(DriverManager.java:664)
    at java.sql.DriverManager.getConnection(DriverManager.java:208)
    at org.openbravo.client.analytics.mondrian.MondrianProvider.getOlapConnection(MondrianProvider.java:160)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0107238)
hgbot (developer)
2018-10-11 09:30

Repository: erp/pmods/org.openbravo.client.analytics
Changeset: 455d94f6f8b579103d34d26a3cc887f4e077557a
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Oct 11 09:22:35 2018 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.client.analytics/rev/455d94f6f8b579103d34d26a3cc887f4e077557a [^]

Fixes issue 39361: cube not shown if there is a dimension with XML definition

  The xml definition for cubes and dimensions was deprecated[1]. But there was still some code related with that feature which was causing troubles on cube generation if a dimension had an xml definition.

  That code has been removed.

[1] https://code.openbravo.com/erp/pmods/org.openbravo.client.analytics/rev/266570766403 [^]

---
M src/org/openbravo/client/analytics/mondrian/Mondrian4SchemaGenerator.java
---
(0107606)
alostale (developer)
2018-10-26 08:11

reviewed

- Issue History
Date Modified Username Field Change
2018-09-27 14:15 ngarcia New Issue
2018-09-27 14:15 ngarcia Assigned To => platform
2018-09-27 14:16 ngarcia Issue Monitored: networkb
2018-10-11 09:28 caristu Assigned To platform => caristu
2018-10-11 09:30 hgbot Checkin
2018-10-11 09:30 hgbot Note Added: 0107238
2018-10-11 09:30 hgbot Status new => resolved
2018-10-11 09:30 hgbot Resolution open => fixed
2018-10-11 09:30 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.client.analytics/rev/455d94f6f8b579103d34d26a3cc887f4e077557a [^]
2018-10-11 09:31 caristu Review Assigned To => alostale
2018-10-26 08:11 alostale Note Added: 0107606
2018-10-26 08:11 alostale Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker