Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039330
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2018-09-20 15:342018-12-11 20:22
ReportergsuarezView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityhighResolutionfixedFixed in Version3.0PR19Q1
StatusclosedFix in branchFixed in SCM revision334861bec141
ProjectionnoneETAnoneTarget Versionpi
OSLinux 64 bitDatabasePostgreSQLJava version7.x
OS VersionOpenbravo Appliance 14.04Database version9.3.xAnt version1.9.x
Product VersionpiSCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039330: Invoice status field in Goods Shipment don't work appropietly

DescriptionWhen a sales invoice is created from a shipment and don't complete it, the invoice status of the shipment is updated.
Steps To Reproduce1. Create a Goods Shipment with one line with quantity 1.
2. Book the Goods Shipment.
3. Create sales invoice header.
4. Press button Create Lines from Shipment.
5. Select the line created in the Goods Shipment.
6. Don't book the sales invoice.
7. Go to the Goods Shipment and check the invoice status field. The value is incorrect, because the sales invoice is not complete yet.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0039386 closedTriage Finance Goods Shipment IsCompletelyInvoiced flag is not properly updated when voiding Sales Invoice 

-  Notes
(0107104)
AtulOpenbravo (developer)
2018-10-02 07:48
edited on: 2018-10-02 08:48

1. Create a Goods Shipment with one line with quantity 10.
2. Book the Goods Shipment.
3. Create sales invoice header.
4. Press button Create Lines from Shipment.
5. Select the line created in the Goods Shipment.
6. Don't book the sales invoice.
7. Go to the Goods Shipment and check the invoice status field. The value is set 0 and it is correct, because the sales invoice is not complete yet.
8. Book the Sales Invoice and check the invoice status field in related Goods Shipment. The value is 100%.
9. Void the Sales Invoice and again check the invoice status field in related Goods Shipment. The value is 0%.

Similar tests are done for partial invoicing of goods shipment.

For eg: Movement Qty = 10

Sales Invoice 1 : Qty = 6

Goods Shipment, Invoice Status = 60%

Sales Invoice 2 : Qty = 4

Goods shipment, Invoice Status = 100%

Void First Sales invoice:

Check Goods shipment, Invoice Status = 40%.

(0107125)
hgbot (developer)
2018-10-02 17:57

Repository: erp/devel/pi
Changeset: 334861bec14192c6157fb99f2167c56089c904e9
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Fri Sep 28 01:58:48 2018 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/334861bec14192c6157fb99f2167c56089c904e9 [^]

Fixes Issue 39330:Invoice status field in Goods Shipment don't
work appropriately

Added clause whether invoice is processed when calculating
invoice status.

---
M src-db/database/model/functions/C_GETINVOICESTATUSFROMSHIPMENT.xml
---
(0107126)
Sandrahuguet (developer)
2018-10-02 17:58

Code review + testing OK
(0108414)
hudsonbot (developer)
2018-12-11 20:22

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/470e3cd384c5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-09-20 15:34 gsuarez New Issue
2018-09-20 15:34 gsuarez Assigned To => Triage Finance
2018-09-20 15:34 gsuarez Modules => Core
2018-09-20 15:34 gsuarez Triggers an Emergency Pack => No
2018-09-20 15:40 Practics Issue Monitored: Practics
2018-09-21 14:11 Sandrahuguet Assigned To Triage Finance => AtulOpenbravo
2018-09-27 19:52 AtulOpenbravo Status new => scheduled
2018-10-02 07:48 AtulOpenbravo Note Added: 0107104
2018-10-02 08:15 AtulOpenbravo Note Edited: 0107104 View Revisions
2018-10-02 08:48 AtulOpenbravo Note Edited: 0107104 View Revisions
2018-10-02 09:08 AtulOpenbravo Relationship added related to 0039386
2018-10-02 17:57 hgbot Checkin
2018-10-02 17:57 hgbot Note Added: 0107125
2018-10-02 17:57 hgbot Status scheduled => resolved
2018-10-02 17:57 hgbot Resolution open => fixed
2018-10-02 17:57 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/334861bec14192c6157fb99f2167c56089c904e9 [^]
2018-10-02 17:58 Sandrahuguet Review Assigned To => Sandrahuguet
2018-10-02 17:58 Sandrahuguet Note Added: 0107126
2018-10-02 17:58 Sandrahuguet Status resolved => closed
2018-10-02 17:58 Sandrahuguet Fixed in Version => 3.0PR19Q1
2018-12-11 20:22 hudsonbot Checkin
2018-12-11 20:22 hudsonbot Note Added: 0108414


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker