Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039231
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformmajoralways2018-09-05 17:422018-09-07 08:51
ReporterngarciaView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR18Q3.1
StatusclosedFix in branchFixed in SCM revision4934aaf55ca3
ProjectionnoneETAnoneTarget Version3.0PR18Q3.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2018-06-01
Regression introduced in release3.0PR18Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/7a4554ef6d4aec661601cddaac3b4212ab8e8371 [^]
Triggers an Emergency PackNo
Summary

0039231: Cannot install a module by adding the OBX in Module Management window

DescriptionCannot install a module by adding the OBX in Module Management window.

The problem seems to be in the following line of ImportModule class:

   String tier = (String) dynModule.get("COMMERCIAL_TIER");
Steps To ReproduceDownload the OBX of 1.4.2001 version of Analytics from Openbravo Forge

As System Admin role:
   Go to Module Management window
   Select Browse File System
   Click on Choose File
   Select the previously downloaded OBX
   Continue

   Check the following error message is shown:
      java.lang.IllegalArgumentException: Invalid property name 'COMMERCIAL_TIER'

   If you Continue java.lang.NullPointerException is shown


   The log shows

ERROR org.openbravo.erpCommon.ad_forms.ModuleManagement - Invalid property name 'COMMERCIAL_TIER'
java.lang.IllegalArgumentException: Invalid property name 'COMMERCIAL_TIER'
    at org.apache.commons.beanutils.BasicDynaBean.getDynaProperty(BasicDynaBean.java:400)
    at org.apache.commons.beanutils.BasicDynaBean.get(BasicDynaBean.java:151)
    at org.openbravo.erpCommon.modules.ImportModule.dyanaBeanToModules(ImportModule.java:1107)
    at org.openbravo.erpCommon.modules.ImportModule.checkDependenciesFile(ImportModule.java:241)
    at org.openbravo.erpCommon.ad_forms.ModuleManagement.printPageInstall1(ModuleManagement.java:1226)
    at org.openbravo.erpCommon.ad_forms.ModuleManagement.printPageInstallFile(ModuleManagement.java:751)
    at org.openbravo.erpCommon.ad_forms.ModuleManagement.doPost(ModuleManagement.java:180)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0039230 closedAugustoMauch Cannot install a module by adding the OBX in Module Management window 

-  Notes
(0106614)
hgbot (developer)
2018-09-06 10:26

Repository: erp/backports/3.0PR18Q3.1
Changeset: 4934aaf55ca34a6236625c2eb8f0db3596ebdb16
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Thu Sep 06 10:25:55 2018 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR18Q3.1/rev/4934aaf55ca34a6236625c2eb8f0db3596ebdb16 [^]

Fixes issue 39231: Removes unneeded reference to COMMERCIAL_TIER column

The column was removed in this changeset [1], but some code referencing it programatically was
left unremoved.

This code was putting the tier info in a map, there is no problem removing it because it was no
longer being checked.

[1] https://code.openbravo.com/erp/devel/pi/rev/7a4554ef6d4aec661601cddaac3b4212ab8e8371 [^]

---
M src/org/openbravo/erpCommon/modules/ImportModule.java
---
(0106637)
alostale (developer)
2018-09-07 08:51

reviewed + tested

- Issue History
Date Modified Username Field Change
2018-09-06 09:31 AugustoMauch Type defect => backport
2018-09-06 09:31 AugustoMauch Target Version => 3.0PR18Q3.1
2018-09-06 10:26 hgbot Checkin
2018-09-06 10:26 hgbot Note Added: 0106614
2018-09-06 10:26 hgbot Status scheduled => resolved
2018-09-06 10:26 hgbot Resolution open => fixed
2018-09-06 10:26 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR18Q3.1/rev/4934aaf55ca34a6236625c2eb8f0db3596ebdb16 [^]
2018-09-06 10:28 AugustoMauch Review Assigned To => alostale
2018-09-07 08:51 alostale Note Added: 0106637
2018-09-07 08:51 alostale Status resolved => closed
2018-09-07 08:51 alostale Fixed in Version => 3.0PR18Q3.1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker