Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039230
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2018-09-05 17:422018-09-12 21:33
ReporterngarciaView Statuspublic 
Assigned ToAugustoMauch 
PriorityimmediateResolutionfixedFixed in Version3.0PR18Q4
StatusclosedFix in branchFixed in SCM revisionbc3da89075bb
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2018-06-01
Regression introduced in release3.0PR18Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/7a4554ef6d4aec661601cddaac3b4212ab8e8371 [^]
Triggers an Emergency PackNo
Summary

0039230: Cannot install a module by adding the OBX in Module Management window

DescriptionCannot install a module by adding the OBX in Module Management window.

The problem seems to be in the following line of ImportModule class:

   String tier = (String) dynModule.get("COMMERCIAL_TIER");
Steps To ReproduceDownload the OBX of 1.4.2001 version of Analytics from Openbravo Forge

As System Admin role:
   Go to Module Management window
   Select Browse File System
   Click on Choose File
   Select the previously downloaded OBX
   Continue

   Check the following error message is shown:
      java.lang.IllegalArgumentException: Invalid property name 'COMMERCIAL_TIER'

   If you Continue java.lang.NullPointerException is shown


   The log shows

ERROR org.openbravo.erpCommon.ad_forms.ModuleManagement - Invalid property name 'COMMERCIAL_TIER'
java.lang.IllegalArgumentException: Invalid property name 'COMMERCIAL_TIER'
    at org.apache.commons.beanutils.BasicDynaBean.getDynaProperty(BasicDynaBean.java:400)
    at org.apache.commons.beanutils.BasicDynaBean.get(BasicDynaBean.java:151)
    at org.openbravo.erpCommon.modules.ImportModule.dyanaBeanToModules(ImportModule.java:1107)
    at org.openbravo.erpCommon.modules.ImportModule.checkDependenciesFile(ImportModule.java:241)
    at org.openbravo.erpCommon.ad_forms.ModuleManagement.printPageInstall1(ModuleManagement.java:1226)
    at org.openbravo.erpCommon.ad_forms.ModuleManagement.printPageInstallFile(ModuleManagement.java:751)
    at org.openbravo.erpCommon.ad_forms.ModuleManagement.doPost(ModuleManagement.java:180)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00392313.0PR18Q3.1 closedAugustoMauch Cannot install a module by adding the OBX in Module Management window 
caused by feature request 0038679 closedalostale remove obsolete License features 

-  Notes
(0106615)
hgbot (developer)
2018-09-06 10:28

Repository: erp/devel/pi
Changeset: bc3da89075bbd208a35512e30f04bbe8347a1a2a
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Sep 05 18:19:38 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/bc3da89075bbd208a35512e30f04bbe8347a1a2a [^]

Fixes issue 39230: Removes unneeded reference to COMMERCIAL_TIER column

The column was removed in this changeset [1], but some code referencing it programatically was
left unremoved.

This code was putting the tier info in a map, there is no problem removing it because it was no
longer being checked.

[1] https://code.openbravo.com/erp/devel/pi/rev/7a4554ef6d4aec661601cddaac3b4212ab8e8371 [^]

---
M src/org/openbravo/erpCommon/modules/ImportModule.java
---
(0106636)
alostale (developer)
2018-09-07 08:50

reviewed + tested
(0106724)
hudsonbot (developer)
2018-09-12 21:33

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/ad75d3cb1744 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-09-05 17:42 ngarcia New Issue
2018-09-05 17:42 ngarcia Assigned To => platform
2018-09-05 17:42 ngarcia Modules => Core
2018-09-05 17:42 ngarcia Triggers an Emergency Pack => No
2018-09-05 17:42 ngarcia Relationship added caused by 0038679
2018-09-05 17:55 Practics Issue Monitored: Practics
2018-09-05 18:00 ngarcia Issue Monitored: networkb
2018-09-05 18:01 ngarcia Steps to Reproduce Updated View Revisions
2018-09-05 18:18 AugustoMauch Regression level => Production - QA Approved
2018-09-05 18:18 AugustoMauch Regression date => 2018-06-01
2018-09-05 18:18 AugustoMauch Regression introduced in release => 3.0PR18Q3
2018-09-05 18:18 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/7a4554ef6d4aec661601cddaac3b4212ab8e8371 [^]
2018-09-05 18:18 AugustoMauch Assigned To platform => AugustoMauch
2018-09-06 09:31 AugustoMauch Status new => scheduled
2018-09-06 10:28 hgbot Checkin
2018-09-06 10:28 hgbot Note Added: 0106615
2018-09-06 10:28 hgbot Status scheduled => resolved
2018-09-06 10:28 hgbot Resolution open => fixed
2018-09-06 10:28 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/bc3da89075bbd208a35512e30f04bbe8347a1a2a [^]
2018-09-06 10:28 AugustoMauch Review Assigned To => alostale
2018-09-06 12:55 martinsdan Issue Monitored: martinsdan
2018-09-07 08:50 alostale Note Added: 0106636
2018-09-07 08:51 alostale Status resolved => closed
2018-09-07 08:51 alostale Fixed in Version => 3.0PR18Q4
2018-09-12 21:33 hudsonbot Checkin
2018-09-12 21:33 hudsonbot Note Added: 0106724


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker