Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039083
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Modules] External Data Integrationtrivialhave not tried2018-08-02 09:402019-05-29 12:41
ReporternaiaramartinezView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision6761585197db
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Regression date
Regression introduced by commit
Regression level
Review Assigned Tocaristu
Regression introduced in release
Summary

0039083: When re-processing the EDL is not saving the error in Response field

DescriptionWhen an EDL is processed the first time with Error, the error message is stored in Response field. Then, if the data is modified in order to fix the error, and the EDL is reprocessed, in case there is a new error, this error is shown only in the message bar but it is not stored in Response field.

See attached an image to understand it better.
Steps To Reproduce- Install the EDL Examples module [1]
- Add the following code to SyncUOMImportProcessItemProcessor to force an error:

  @Override
  protected void processItem(JSONObject item) throws OBException {
    throw new OBException("Error message 1");
  }

- Execute the Import UOM Synchronously process (available in the menu)
- The resulting EDL Request will show the proper error message
- Update SyncUOMImportProcessItemProcessor, replace "Error message 1" with "Error message 2"
- Reprocess the EDL Request. "Error message 2" will be shown in the status bar, but not in the Response field of the request
- Replace throw new OBException("Error message 1"); with super.processItem(item);. The process will run successfully, but the Status and Response fields of the EDL request are not updated.


[1] https://code.openbravo.com/erp/pmods/org.openbravo.externaldata.integration.examples/ [^]
TagsNo tags attached.
Attached Filesjpeg file icon EDL Error.jpeg [^] (50,533 bytes) 2018-08-02 09:40

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0039174 closedAugustoMauch SERQA 4522: EDL: Errors not deleted from import entry when reprocessed 

-  Notes
(0112071)
hgbot (developer)
2019-05-22 13:09

Repository: erp/pmods/org.openbravo.externaldata.integration
Changeset: 6761585197db450f1e50b6646723b5feef61786d
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed May 22 13:08:50 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.externaldata.integration/rev/6761585197db450f1e50b6646723b5feef61786d [^]

Fixes issue 39083: Reprocessing EDL request should update Status and Response

The problem was that when a synchronized EDL request was reprocessed, its status and response
fields were not being updated.

Now the setResponse method of the EDL Request is invoked with the updated response, and also
the EDL Request is being refreshed, because otherwise the changes were not flushed to the database.
This could happen because when there is an error, the session is closed before the response and
status fields are updated.

---
M src/org/openbravo/externaldata/integration/process/ProcessRequest.java
---
(0112213)
hgbot (developer)
2019-05-28 18:33

Repository: erp/pmods/org.openbravo.externaldata.integration
Changeset: 38b689b3ea125f7081f71017e024944082cec570
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Tue May 28 18:32:29 2019 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.externaldata.integration/rev/38b689b3ea125f7081f71017e024944082cec570 [^]

Related with issue 39083: Removes unneeded commitAndClose

There is no need to manually commit the connection at that point, it will be done the DalThreadHandler

---
M src/org/openbravo/externaldata/integration/process/ProcessRequest.java
---
(0112222)
caristu (developer)
2019-05-29 12:40

Reviewed + tested OK

- Issue History
Date Modified Username Field Change
2018-08-02 09:40 naiaramartinez New Issue
2018-08-02 09:40 naiaramartinez Assigned To => platform
2018-08-02 09:40 naiaramartinez File Added: EDL Error.jpeg
2018-08-02 09:40 naiaramartinez Modules => Core
2018-08-02 09:40 naiaramartinez Triggers an Emergency Pack => No
2018-08-03 13:41 caristu Summary [LA EUROPEA] When re-processing the EDL is not saving the error in Response field => When re-processing the EDL is not saving the error in Response field
2018-08-30 08:27 caristu Project Openbravo ERP => Modules
2018-08-30 08:28 caristu Category A. Platform => External Data Integration
2018-08-30 08:28 caristu Steps to Reproduce Updated View Revisions
2018-08-30 08:45 caristu Relationship added related to 0039174
2019-05-22 13:09 hgbot Checkin
2019-05-22 13:09 hgbot Note Added: 0112071
2019-05-22 13:09 hgbot Status new => resolved
2019-05-22 13:09 hgbot Resolution open => fixed
2019-05-22 13:09 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.externaldata.integration/rev/6761585197db450f1e50b6646723b5feef61786d [^]
2019-05-22 13:10 AugustoMauch Review Assigned To => caristu
2019-05-22 13:35 AugustoMauch Steps to Reproduce Updated View Revisions
2019-05-22 15:43 AugustoMauch Assigned To platform => AugustoMauch
2019-05-28 18:33 hgbot Checkin
2019-05-28 18:33 hgbot Note Added: 0112213
2019-05-29 12:41 caristu Note Added: 0112222
2019-05-29 12:41 caristu Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker