Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039034
TypeCategorySeverityReproducibilityDate SubmittedLast Update
design defect[Openbravo ERP] A. Platformminorhave not tried2018-07-24 17:012019-05-21 15:17
ReportershuehnerView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR19Q3
StatusclosedFix in branchFixed in SCM revision3f40f1cc2e7d
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039034: Illegal Access warning in xstream-1.3.1 library

DescriptionThis library is used internally by quartz which is the engine to run background processes.

On tomcat start (when scheduled processed are loaded) an illegal access warning is shown.

The topic is tracked upstream in issue:
https://github.com/x-stream/xstream/issues/101 [^]

However it is not solved yet.
Steps To Reproduce-
Proposed SolutionRemove dependency to xstream http://wiki.openbravo.com/wiki/Projects:Remove_XStream [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0035222 closedalostale Openbravo ERP warning messages are not displayed while rebuilding via MMC 
related to defect 0040860 closedplatform Openbravo ERP API change: removed xstream library from core 
related to defect 0040861 closedcaristu Openbravo ERP API change: reduce visibility of ApplyModulesResponse 
related to defect 0040873 closedcaristu Modules Adapt ImportData process to the new way of serializing the ProcessBundle parameters 
blocks design defect 0039031 newplatform Openbravo ERP Tracking issue: Remove illegal access warnings shown since java9 by updating affected jar libraries 

-  Notes
(0111673)
hgbot (developer)
2019-05-14 16:18

Repository: erp/devel/pi
Changeset: 3f40f1cc2e7d23c71f4c86cf37de1b1dab7a1e8c
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue May 14 16:17:07 2019 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3f40f1cc2e7d23c71f4c86cf37de1b1dab7a1e8c [^]

fixes issue 39034: Remove xstream-1.3.1 library

---
M legal/Licensing.txt
M src-test/src/org/openbravo/test/AllAntTaskTests.java
M src/org/openbravo/erpCommon/ad_process/ApplyModules.html
M src/org/openbravo/erpCommon/ad_process/ApplyModulesCallServlet.java
M src/org/openbravo/erpCommon/ad_process/ApplyModulesResponse.java
M src/org/openbravo/erpCommon/utility/OBError.java
M src/org/openbravo/erpCommon/utility/WindowTree.java
M src/org/openbravo/scheduling/OBScheduler.java
M src/org/openbravo/scheduling/ProcessBundle.java
M src/org/openbravo/scheduling/ProcessContext.java
A src-test/src/org/openbravo/test/system/JSONSerialization.java
A src/org/openbravo/scheduling/ParameterSerializationException.java
A src/org/openbravo/scheduling/ParameterSerializer.java
R lib/runtime/xstream-1.3.1.jar
---
(0111757)
alostale (developer)
2019-05-17 08:36

reviewed + tested
(0112031)
hudsonbot (developer)
2019-05-21 15:17

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9b8f37d9d85e [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-07-24 17:01 shuehner New Issue
2018-07-24 17:01 shuehner Assigned To => platform
2018-07-24 17:01 shuehner Modules => Core
2018-07-24 17:01 shuehner Triggers an Emergency Pack => No
2018-07-24 17:01 shuehner Relationship added blocks 0039031
2019-05-13 11:36 caristu Relationship added related to 0035222
2019-05-13 13:26 caristu Relationship added related to 0040860
2019-05-13 13:30 caristu Relationship added related to 0040861
2019-05-14 12:54 caristu Relationship added related to 0040873
2019-05-14 16:15 caristu Assigned To platform => caristu
2019-05-14 16:18 hgbot Checkin
2019-05-14 16:18 hgbot Note Added: 0111673
2019-05-14 16:18 hgbot Status new => resolved
2019-05-14 16:18 hgbot Resolution open => fixed
2019-05-14 16:18 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3f40f1cc2e7d23c71f4c86cf37de1b1dab7a1e8c [^]
2019-05-14 16:24 caristu Review Assigned To => alostale
2019-05-17 08:35 alostale Proposed Solution updated
2019-05-17 08:36 alostale Note Added: 0111757
2019-05-17 08:36 alostale Status resolved => closed
2019-05-17 08:36 alostale Fixed in Version => 3.0PR19Q3
2019-05-21 15:17 hudsonbot Checkin
2019-05-21 15:17 hudsonbot Note Added: 0112031


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker