Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039021
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2018-07-24 10:072018-07-27 11:25
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revision794efefb012d
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039021: API changes due to Hibernate upgrade

DescriptionThe Hibernate upgrade implies some API changes:

- Replacing the usage of deprecated org.hibernate.Query class with org.hibernate.query.Query.
- Replacing no longer available org.hibernate.classic.Session class with org.hibernate.Session.
- OBCriteria now extends org.hibernate.internal.CriteriaImpl instead of org.hibernate.impl.CriteriaImpl
- Replacing org.hibernate.engine.SessionImplementor with org.hibernate.engine.spi.SessionImplementor
- Changes due to internal changes within the Hibernate API
Steps To Reproduce.
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0037064 closedcaristu upgrade hibernate 

-  Notes
(0105853)
hgbot (developer)
2018-07-24 10:49

Repository: erp/devel/api-checks
Changeset: 794efefb012db23a976799d2c6dbcc87a3b9b653
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Jul 24 10:08:45 2018 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/794efefb012db23a976799d2c6dbcc87a3b9b653 [^]

fixes issue 39021: API changes due to Hibernate upgrade

---
M java/reference/java.japi.gz
---

- Issue History
Date Modified Username Field Change
2018-07-24 10:07 caristu New Issue
2018-07-24 10:07 caristu Assigned To => platform
2018-07-24 10:07 caristu Modules => Core
2018-07-24 10:07 caristu Triggers an Emergency Pack => No
2018-07-24 10:07 caristu Relationship added related to 0037064
2018-07-24 10:49 hgbot Checkin
2018-07-24 10:49 hgbot Note Added: 0105853
2018-07-24 10:49 hgbot Status new => resolved
2018-07-24 10:49 hgbot Resolution open => fixed
2018-07-24 10:49 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/api-checks/rev/794efefb012db23a976799d2c6dbcc87a3b9b653 [^]
2018-07-24 10:50 caristu Assigned To platform => caristu
2018-07-24 10:50 caristu Review Assigned To => alostale
2018-07-27 11:25 alostale Tag Attached: Approved
2018-07-27 11:25 alostale Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker