Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0039017
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 02. Master data managementmajoralways2018-07-23 17:152018-08-11 09:32
ReporterJONHMView Statuspublic 
Assigned Tocollazoandy4 
PriorityhighResolutionfixedFixed in Version3.0PR18Q4
StatusclosedFix in branchFixed in SCM revisionfe8d2427d863
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product Version3.0PR18Q2SCM revision 
Review Assigned ToSandrahuguet
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0039017: Performance issue in Requisition To Order window

DescriptionPerformance issue in Requisition To Order window, it takes 43 seconds to load
Steps To ReproduceAsk environment to Support

- Open Requisition to Order window
TagsNo tags attached.
Attached Filespng file icon Screenshot from 2018-07-23 17-14-14.png [^] (120,688 bytes) 2018-07-23 17:15

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0106021)
collazoandy4 (developer)
2018-07-30 16:19

Test Plan
  Go to Requisition window and create a new record for Region Norte org
    Create a new record in Lines Tab:
      Need by Date: Today
      Product: Cerveza Ale 0,5L
      Quantity: 10
    Complete the Requisition
  Go to Requisition to order window and chec the previous record is shown

Test Plan II
  Repeat the previous test plan with AUM preference enabled
(0106022)
collazoandy4 (developer)
2018-07-30 16:21

With the fix proposed the query execution time was reduced from 40433.560 to 180.711 ms
(0106285)
hgbot (developer)
2018-08-10 14:13

Repository: erp/devel/pi
Changeset: fe8d2427d8630cdccb6e3ec29b59210bf29a3908
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Tue Jul 24 17:18:24 2018 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/fe8d2427d8630cdccb6e3ec29b59210bf29a3908 [^]

Fixes issue 39017: Performance issue in Requisition To Order window

---
M src/org/openbravo/erpCommon/ad_forms/RequisitionToOrder.java
M src/org/openbravo/erpCommon/ad_forms/RequisitionToOrder_data.xsql
---
(0106287)
hgbot (developer)
2018-08-10 14:50

Repository: erp/devel/pi
Changeset: 389e4c0f5e997f44fc0426ee22f7a022dcd0c2a0
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Fri Aug 10 14:45:30 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/389e4c0f5e997f44fc0426ee22f7a022dcd0c2a0 [^]

related to issue 39017 code review changes

change m_pricelist_id column by name column, because is the correct one

---
M src/org/openbravo/erpCommon/ad_forms/RequisitionToOrder_data.xsql
---
(0106288)
hgbot (developer)
2018-08-10 15:02

Repository: erp/devel/pi
Changeset: 6bc6e85153109c0448a29ffa3249836d4fcc6d7d
Author: Sandra Huguet <sandra.huguet <at> openbravo.com>
Date: Fri Aug 10 15:02:15 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/6bc6e85153109c0448a29ffa3249836d4fcc6d7d [^]

related to issue 39017 code review changes

fix group by clause

---
M src/org/openbravo/erpCommon/ad_forms/RequisitionToOrder_data.xsql
---
(0106289)
Sandrahuguet (developer)
2018-08-10 15:06

Code review + testing OK
(0106299)
hudsonbot (developer)
2018-08-11 09:32

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7d17883ca725 [^]
Maturity status: Test
(0106300)
hudsonbot (developer)
2018-08-11 09:32

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7d17883ca725 [^]
Maturity status: Test
(0106301)
hudsonbot (developer)
2018-08-11 09:32

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/7d17883ca725 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-07-23 17:15 JONHM New Issue
2018-07-23 17:15 JONHM Assigned To => Triage Finance
2018-07-23 17:15 JONHM File Added: Screenshot from 2018-07-23 17-14-14.png
2018-07-23 17:15 JONHM Modules => Core
2018-07-23 17:15 JONHM Triggers an Emergency Pack => No
2018-07-23 17:16 JONHM version => 3.0PR18Q2
2018-07-23 23:50 collazoandy4 Assigned To Triage Finance => collazoandy4
2018-07-23 23:51 collazoandy4 Status new => scheduled
2018-07-30 16:19 collazoandy4 Note Added: 0106021
2018-07-30 16:21 collazoandy4 Note Added: 0106022
2018-08-10 14:13 hgbot Checkin
2018-08-10 14:13 hgbot Note Added: 0106285
2018-08-10 14:13 hgbot Status scheduled => resolved
2018-08-10 14:13 hgbot Resolution open => fixed
2018-08-10 14:13 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/fe8d2427d8630cdccb6e3ec29b59210bf29a3908 [^]
2018-08-10 14:50 hgbot Checkin
2018-08-10 14:50 hgbot Note Added: 0106287
2018-08-10 15:02 hgbot Checkin
2018-08-10 15:02 hgbot Note Added: 0106288
2018-08-10 15:06 Sandrahuguet Review Assigned To => Sandrahuguet
2018-08-10 15:06 Sandrahuguet Note Added: 0106289
2018-08-10 15:06 Sandrahuguet Status resolved => closed
2018-08-10 15:06 Sandrahuguet Fixed in Version => 3.0PR18Q4
2018-08-11 09:32 hudsonbot Checkin
2018-08-11 09:32 hudsonbot Note Added: 0106299
2018-08-11 09:32 hudsonbot Checkin
2018-08-11 09:32 hudsonbot Note Added: 0106300
2018-08-11 09:32 hudsonbot Checkin
2018-08-11 09:32 hudsonbot Note Added: 0106301


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker