Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038962
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POS Hardware Managermajoralways2018-07-16 08:552018-10-18 20:37
ReporterjorgewederagoView Statuspublic 
Assigned TojavierRodriguez 
PrioritynormalResolutionfixedFixed in VersionRR19Q1
StatusclosedFix in branchFixed in SCM revision624f6c4fa1d2
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038962: Some chinese characters are missing when printing in chinese

DescriptionSome Chinese characters are not being printed correctly. Instead of being printed they are being converted into "?" (default character if not found).
Steps To Reproduce1.- Start a hardware manager with printing in screen mode
2.- Change the name of a product to: 防曬跑步運動T恤
3.- Go to WebPOS and buy the previous product
4.- When the ticket is printed some Chinese characters will be interrogation marks.

Attached an example of the same product printed with TH200i
TagsNo tags attached.
Attached Filesjpg file icon th200iExample.jpg [^] (36,046 bytes) 2018-07-16 08:55

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0041141 newjoniturralde93 Some chinese characters are missing when printing in chinese 

-  Notes
(0106306)
adrianromero (manager)
2018-08-13 08:36

The reason why these specific Chinese chararacters are not printed is because do not belong to the GB2312 character set table that is the table used to print Chinese characters.

This is the line that defines what is the character table to use when printing characters from the CJK UNIFIED IDEOGRAPH Unicode set -> https://code.openbravo.com/erp/pmods/org.openbravo.retail.poshwmanager.sources/file/tip/project/src/META-INF/unicodeblocks.xml#l3 [^]

And if you go to the GB2312 character set table here -> http://tools.jb51.net/table/gb2312 [^] you can see that all the characters printed properly can be found in this table but characters printed as "?" cannot.
(0106327)
marvintm (developer)
2018-08-13 16:29

Changing it to feedback until the topic with the printer manufacturer is clarified
(0107329)
hgbot (developer)
2018-10-16 12:44

Repository: erp/pmods/org.openbravo.retail.poshwmanager.sources
Changeset: 813b60cc7d47e6bfb9e1599b7df0b4fff9c51ae2
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Tue Oct 16 12:44:32 2018 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.poshwmanager.sources/rev/813b60cc7d47e6bfb9e1599b7df0b4fff9c51ae2 [^]

Related to issue 38962: Some chinese characters are missing when printing in chinese

---
M project/src/META-INF/unicodeblocks.xml
---
(0107330)
hgbot (developer)
2018-10-16 12:44

Repository: erp/pmods/org.openbravo.retail.poshwmanager
Changeset: 624f6c4fa1d2fc91d85436d33d08f83c9f25b207
Author: Javier Rodriguez <javier.rodriguez <at> openbravo.com>
Date: Mon Oct 15 11:28:28 2018 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.poshwmanager/rev/624f6c4fa1d2fc91d85436d33d08f83c9f25b207 [^]

Fixed issue 38962: Some chinese characters are missing when printing in chinese

---
M bin/poshw.jar
M bin/rev.id
---

- Issue History
Date Modified Username Field Change
2018-07-16 08:55 jorgewederago New Issue
2018-07-16 08:55 jorgewederago Assigned To => Retail
2018-07-16 08:55 jorgewederago File Added: th200iExample.jpg
2018-07-16 08:55 jorgewederago Triggers an Emergency Pack => No
2018-07-16 11:02 jorgewederago Description Updated View Revisions
2018-08-09 10:20 javierRodriguez Assigned To Retail => javierRodriguez
2018-08-09 10:21 javierRodriguez Status new => scheduled
2018-08-13 08:36 adrianromero Note Added: 0106306
2018-08-13 16:29 marvintm Note Added: 0106327
2018-08-13 16:29 marvintm Assigned To javierRodriguez => malsasua
2018-08-13 16:29 marvintm Status scheduled => feedback
2018-10-16 12:44 hgbot Checkin
2018-10-16 12:44 hgbot Note Added: 0107329
2018-10-16 12:44 hgbot Checkin
2018-10-16 12:44 hgbot Note Added: 0107330
2018-10-16 12:44 hgbot Status feedback => resolved
2018-10-16 12:44 hgbot Resolution open => fixed
2018-10-16 12:44 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.poshwmanager/rev/624f6c4fa1d2fc91d85436d33d08f83c9f25b207 [^]
2018-10-18 20:37 marvintm Assigned To malsasua => javierRodriguez
2018-10-18 20:37 marvintm Review Assigned To => marvintm
2018-10-18 20:37 marvintm Status resolved => closed
2018-10-18 20:37 marvintm Fixed in Version => RR19Q1
2019-06-20 17:28 malsasua Relationship added related to 0041141


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker