Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038907
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 01. General setupmajorhave not tried2018-07-05 18:142018-08-08 13:06
ReporterplujanView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR18Q4
StatusclosedFix in branchFixed in SCM revision3bdec175d941
ProjectionnoneETAnoneTarget Version
OSAnyDatabasePostgreSQLJava version
OS VersionDatabase versionAnt version
Product VersionmainSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelQA functional test
Regression date2018-06-28
Regression introduced in releasemain
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/ed73bce3ae3b093cba0908df13b6ffabb73f6564 [^]
Triggers an Emergency PackNo
Summary

0038907: DB errors which several OB messages are not correctly parsed in PG

DescriptionWhen creating a Sales Order and one of the lines contains a product that has been marked as "Obsolete" the error message on booking the order says:

"Error: Please verify its PLM Status"
Steps To Reproduce1. Having a product marked as Obsolete in its PLM Status, create a new Sales Order
2. Add several lines containing active products and one line containing the obsolete one.
3. Try to book the order. The message shown does not point out which was the obsolete product, making the message not practical. See attached screenshot.
TagsNo tags attached.
Attached Filespng file icon PLM-ErrorMessage.png [^] (57,823 bytes) 2018-07-05 18:14


png file icon Selection_269.png [^] (36,406 bytes) 2018-08-02 08:56

- Relationships Relation Graph ] Dependency Graph ]
related to design defect 0033940 newplatform [SERQA 1558 ]When Postgres database is configured in French the unique message is not found in Openbravo's ad_message 
depends on backport 00390803.0PR18Q3 closedcaristu DB errors which several OB messages are not correctly parsed in PG 
depends on backport 00390813.0PR18Q2.2 closedcaristu DB errors which several OB messages are not correctly parsed in PG 
caused by defect 0038827 closedcaristu Some trigger error messages are not shown nicely when using PostgreSQL version 10 (shows part of technical error) 
related to defect 0038855 closedalostale Error in 'Purchase Order Report' is not user friendly 

-  Notes
(0105653)
plujan (manager)
2018-07-05 18:25

When a product is in Ramp Down status and its stock is 0, the message is also missing informative text.
(0106094)
alostale (developer)
2018-08-02 09:10

In Oracle it works properly, it fails only in PG.
(0106115)
hgbot (developer)
2018-08-02 13:18

Repository: erp/devel/pi
Changeset: 3bdec175d94119ce31aa03d6bc74a2b67531cb48
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Aug 02 13:03:20 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/3bdec175d94119ce31aa03d6bc74a2b67531cb48 [^]

fixes bug 38907: PG error text parser is not translating properly some messages

  Fix for issue 0038827 was not taking into accout the possibility of having multiple translatable elements (text surrounded by @) in the same error message.

  Therefore, it has been restored the previous regular expression, and we are now directly stripping the part that contains the technical information of a trigger failure from the DB message returned by PostgreSQL.

---
M src/org/openbravo/erpCommon/utility/ErrorTextParserPOSTGRE.java
---
(0106116)
hgbot (developer)
2018-08-02 13:18

Repository: erp/devel/pi
Changeset: f78e4433d0cc5abf9a24919e66be1ca474ba3d7e
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Aug 02 13:16:08 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f78e4433d0cc5abf9a24919e66be1ca474ba3d7e [^]

related to issue 38907: add test case

  - Extracted the test that reproduces some particular scenarios to test the error parsing into new ErrorTextParserIntegrationTest test class.
  - Use the ErrorTextParserTest to keep just those tests that directly test the parsing/translation of error string messages.

---
M src-test/src/org/openbravo/test/AllAntTaskTests.java
M src-test/src/org/openbravo/test/AllQuickAntTaskTests.java
M src-test/src/org/openbravo/test/AntTaskTests.java
M src-test/src/org/openbravo/test/system/ErrorTextParserTest.java
A src-test/src/org/openbravo/test/system/ErrorTextParserIntegrationTest.java
---
(0106158)
AugustoMauch (developer)
2018-08-03 12:57

Code reviewed and verified
(0106237)
hudsonbot (developer)
2018-08-08 13:06

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/bfd7a414183a [^]
Maturity status: Test
(0106238)
hudsonbot (developer)
2018-08-08 13:06

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/bfd7a414183a [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-07-05 18:14 plujan New Issue
2018-07-05 18:14 plujan Assigned To => Triage Finance
2018-07-05 18:14 plujan File Added: PLM-ErrorMessage.png
2018-07-05 18:14 plujan Modules => Core
2018-07-05 18:14 plujan Triggers an Emergency Pack => No
2018-07-05 18:25 plujan Note Added: 0105653
2018-07-27 01:32 collazoandy4 Assigned To Triage Finance => collazoandy4
2018-07-27 01:32 collazoandy4 Status new => scheduled
2018-08-01 14:45 Sandrahuguet Assigned To collazoandy4 => platform
2018-08-01 16:49 alostale Status scheduled => acknowledged
2018-08-02 08:56 alostale Relationship added related to 0033940
2018-08-02 08:56 alostale File Added: Selection_269.png
2018-08-02 08:56 alostale Status acknowledged => scheduled
2018-08-02 09:10 alostale Note Added: 0106094
2018-08-02 09:12 alostale Relationship added caused by 0038827
2018-08-02 09:17 alostale Regression level => QA functional test
2018-08-02 09:17 alostale Regression date => 2018-06-28
2018-08-02 09:17 alostale Regression introduced in release => 3.0PR17Q3
2018-08-02 09:17 alostale Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/ed73bce3ae3b093cba0908df13b6ffabb73f6564 [^]
2018-08-02 09:17 alostale Status scheduled => feedback
2018-08-02 09:18 alostale Status feedback => new
2018-08-02 09:18 alostale Summary [PR18Q3] [PLM] Error message when including an obsolete product is not clear => DB errors which several OB messages are not correctly parsed in PG
2018-08-02 09:19 alostale Status new => scheduled
2018-08-02 09:26 alostale Assigned To platform => caristu
2018-08-02 09:26 alostale Priority normal => immediate
2018-08-02 09:45 alostale Regression introduced in release 3.0PR17Q3 => main
2018-08-02 10:26 alostale Relationship added related to 0038855
2018-08-02 13:18 hgbot Checkin
2018-08-02 13:18 hgbot Note Added: 0106115
2018-08-02 13:18 hgbot Status scheduled => resolved
2018-08-02 13:18 hgbot Resolution open => fixed
2018-08-02 13:18 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/3bdec175d94119ce31aa03d6bc74a2b67531cb48 [^]
2018-08-02 13:18 hgbot Checkin
2018-08-02 13:18 hgbot Note Added: 0106116
2018-08-02 13:20 caristu Review Assigned To => AugustoMauch
2018-08-03 12:57 AugustoMauch Note Added: 0106158
2018-08-03 12:57 AugustoMauch Status resolved => closed
2018-08-03 12:57 AugustoMauch Fixed in Version => 3.0PR18Q4
2018-08-08 13:06 hudsonbot Checkin
2018-08-08 13:06 hudsonbot Note Added: 0106237
2018-08-08 13:06 hudsonbot Checkin
2018-08-08 13:06 hudsonbot Note Added: 0106238


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker