Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038864
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2018-06-29 10:192018-08-08 13:06
Reporterjoniturralde93View Statuspublic 
Assigned Tocollazoandy4 
PriorityurgentResolutionfixedFixed in Version3.0PR18Q4
StatusclosedFix in branchFixed in SCM revision4e896f3e4b17
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038864: Problems in 'Add Details' (Payment In) when autodistribute amount property is disabled

DescriptionWindow 'Payment In', button 'Add Details'.

When 'Add Payment: Automatically distribute amounts' property is set to 'N' or there are more than 100 shown invoices (so it doesn't autodistribute anyway), if you have many selected invoices and you change the 'Actual Payment' value to the same as 'Expected Payment', 'There is a difference of' doesn't refresh automatically (it should be 0) and therefore, 'Overpayment Action' combo box doesn't dissapear. Both fields should be refreshed in real time when 'Actual Payment' is modified.
Steps To Reproduce1. Create a 'Payment In' record ('Payment Method'=Transferencia, 'Amount'=50000).
2. Set 'Add Payment: Automatically distribute amounts' property to 'N' with a preference.
3. Create some invoices, all with payment method 'Transferencia', with lines, no payments and completed, so they can be selected in 'Add Details'.
4. Click 'Add Details' for the 'Payment In' record.
5. Select some invoices.
6. Change 'Actual Payment' to 'Expected Payment' value.
7. Neither 'There is a difference of' or 'Overpayment Action' fields are refreshed ('There is a difference of' should be 0 and 'Overpayment Action' should disappear)


Point 2 works the same if you create more than 100 invoices, since system doesn't autodistribute amount when there are more than 100 records.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0105811)
collazoandy4 (developer)
2018-07-19 16:09

Test Plan
 Go to Preference window and create a new record:
   Property: Add Payment: Automatically distribute amounts
   Value: N
 Create some invoices pending to be paid
 Go to Payment In window and create a new record:
   Payment Method: Transferencia
   Amount: 50000
   Clic on Add Details button
     Select some invoices and change Actual Payment to Expected Payment value.
     Check There is a difference of and Overpayment Action fields are updated.


Test Plan II
  Repeat the previous test plan with Add Payment: Automatically distribute amounts preference value to Y

Test Plan III
  Repeat the two previous tests plan with more than 100 invoices pending to be paid.
(0105941)
hgbot (developer)
2018-07-25 11:55

Repository: erp/devel/pi
Changeset: 4e896f3e4b174d10049a78887f0654ab514c3b70
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Wed Jul 18 23:32:49 2018 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/4e896f3e4b174d10049a78887f0654ab514c3b70 [^]

Fixes issue 38864: Problems in 'Add Details' (Payment In) when autodistribute
amount property is disabled

When 'Add Payment: Automatically distribute amounts' property is set to 'N' or
there are more than 100 shown invoices, if you have many selected invoices and
you change the 'Actual Payment' value to the same as 'Expected Payment',
'There is a difference of' doesn't refresh automatically (it should be 0) and
therefore, 'Overpayment Action' combo box doesn't dissapear. Both fields should
be refreshed in real time when 'Actual Payment' is modified.

Now the fields are properly updated even if the amount doesn't distribute
automatically

---
M modules/org.openbravo.advpaymentmngt/web/org.openbravo.advpaymentmngt/js/ob-aprm-addPayment.js
---
(0105942)
dmiguelez (developer)
2018-07-25 11:55

Code Review + Testing Ok
(0106229)
hudsonbot (developer)
2018-08-08 13:06

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/bfd7a414183a [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-06-29 10:19 joniturralde93 New Issue
2018-06-29 10:19 joniturralde93 Assigned To => Triage Finance
2018-06-29 10:19 joniturralde93 Modules => Core
2018-06-29 10:19 joniturralde93 Triggers an Emergency Pack => No
2018-07-10 15:56 Sandrahuguet Assigned To Triage Finance => AtulOpenbravo
2018-07-18 18:03 collazoandy4 Assigned To AtulOpenbravo => collazoandy4
2018-07-18 18:04 collazoandy4 Status new => scheduled
2018-07-19 16:09 collazoandy4 Note Added: 0105811
2018-07-25 11:55 hgbot Checkin
2018-07-25 11:55 hgbot Note Added: 0105941
2018-07-25 11:55 hgbot Status scheduled => resolved
2018-07-25 11:55 hgbot Resolution open => fixed
2018-07-25 11:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/4e896f3e4b174d10049a78887f0654ab514c3b70 [^]
2018-07-25 11:55 dmiguelez Review Assigned To => dmiguelez
2018-07-25 11:55 dmiguelez Note Added: 0105942
2018-07-25 11:55 dmiguelez Status resolved => closed
2018-07-25 11:55 dmiguelez Fixed in Version => 3.0PR18Q4
2018-08-08 13:06 hudsonbot Checkin
2018-08-08 13:06 hudsonbot Note Added: 0106229


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker