Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038857
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Gift cards and gift vouchersmajoralways2018-06-28 15:092018-08-17 12:58
ReporterrafarodaView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityhighResolutionfixedFixed in VersionRR18Q4
StatusclosedFix in branchFixed in SCM revision
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038857: Error in Credit Note printed ticket when customer already had some solde client

DescriptionError in Credit Note printed ticket when customer already had some solde client
Steps To ReproduceIn Live Builds
* Terminal YS-11 (MUST be this one) user vallblanca https://livebuilds.openbravo.com/retail_modules_pgsql_pi/web/org.openbravo.retail.posterminal/?terminal=YS-11 [^]
* Created new customer RAFA RODA
* Ticket for this customer with Avalanche Transceiver product 150.50€
* Clicked on the line: Return Line
* Make the return in Credit Note: the Credit Note printed in Hardware Manager is OK, displays Credit Note YS-11/0000002 with Inital Balance 150.50 and barcode is OK too
* Go to backend https://livebuilds.openbravo.com/retail_modules_pgsql_pi/ [^]
* Gift Card Instance window: filter by business partner Rafa Roda, see record YS-11/0000002. Initial Balance 150.50, Current Balance 150.50
* In Return From Customer backend window: see record YS-11/0000002
* Create a new ticket to partially use this credit note
* Ticket line with Adhesive Body Warmers for customer RAFA RODA: 3.60€
* Pay it with Credit Note previously created YS-11/0000002
* Gift Card Instance window: filter by business partner Rafa Roda, see record YS-11/0000002. Initial Balance 150.50, Current Balance 146.90
* In WebPOS, Menu > Gift / Credit Notes: reprint YS-11/0000002 and check in the printed ticket Initial Balance 150.50, Current Balance 146.90
* Create a new ticket for customer RAFA RODA with Avalanche Transceiver product 150.50€
* Clicked on the line: Return Line
* Make the return in Credit Note: the Credit Note printed in Hardware Manager
 displays Credit Note YS-11/0000002 (OK) with Inital Balance 150.50 (NOK, should be 297.40) and Current Balance 146.90 (NOK, should be 297.40) and barcode is OK
* Gift Card Instance window: filter by business partner Rafa Roda, see record YS-11/0000002. Initial Balance 297.40 (150,50-3,60+150,50), Current Balance 297.40 and closed YS-11/0000002*C1 Initial Balance 150.50, Current Balance 0: OK
* In Return From Customer backend window: see record YS-11/0000004: OK
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0105610)
ranjith_qualiantech_com (developer)
2018-07-05 08:59

Repository: erp/pmods/org.openbravo.retail.giftcards
Changeset: 2d3e49df99a75129aa0966b54d8062d582a2e6b2
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Thu Jul 05 11:54:40 2018 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/2d3e49df99a75129aa0966b54d8062d582a2e6b2 [^] [^]

Related to issue 38857 : Credit Note Balance should be printed for Unqiue Credit Note

* For Unique Credit Note, Credit Note will be processed when order is getting synced with backoffice.
  Before that, For printing credit note, Credit Note balance should be updated with order credit note
---
M web/org.openbravo.retail.giftcards/js/hooks/printGiftCardPrePrintHook.js
(0106065)
guillermogil (manager)
2018-08-01 08:18

Reopened due to wrong initial balance print
(0106079)
hgbot (developer)
2018-08-01 12:28

Repository: erp/pmods/org.openbravo.retail.giftcards
Changeset: c4e46a4744f814ee2e1a1669780f3954ab9d3d81
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Wed Aug 01 15:58:05 2018 +0530
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.giftcards/rev/c4e46a4744f814ee2e1a1669780f3954ab9d3d81 [^]

Related to issue 38857 : Initial Balance should be updated with current payment for Unique Credit Note

* For Unique Credit Note, Return receipt payment amount should be updated with both initial balance and current balance

---
M web/org.openbravo.retail.giftcards/js/hooks/printGiftCardPrePrintHook.js
---

- Issue History
Date Modified Username Field Change
2018-06-28 15:09 rafaroda New Issue
2018-06-28 15:09 rafaroda Assigned To => Retail
2018-06-28 15:09 rafaroda Triggers an Emergency Pack => No
2018-07-02 15:07 ranjith_qualiantech_com Assigned To Retail => ranjith_qualiantech_com
2018-07-03 08:23 ranjith_qualiantech_com Status new => scheduled
2018-07-05 08:59 ranjith_qualiantech_com Note Added: 0105610
2018-07-05 14:05 ranjith_qualiantech_com Status scheduled => resolved
2018-07-05 14:05 ranjith_qualiantech_com Resolution open => fixed
2018-07-31 09:05 marvintm Review Assigned To => marvintm
2018-07-31 09:05 marvintm Status resolved => closed
2018-07-31 09:05 marvintm Fixed in Version => RR18Q4
2018-08-01 08:18 guillermogil Note Added: 0106065
2018-08-01 08:18 guillermogil Status closed => new
2018-08-01 08:18 guillermogil Resolution fixed => open
2018-08-01 08:18 guillermogil Fixed in Version RR18Q4 =>
2018-08-01 11:35 ranjith_qualiantech_com Status new => scheduled
2018-08-01 12:28 hgbot Checkin
2018-08-01 12:28 hgbot Note Added: 0106079
2018-08-01 14:35 ranjith_qualiantech_com Status scheduled => resolved
2018-08-01 14:35 ranjith_qualiantech_com Resolution open => fixed
2018-08-17 12:58 marvintm Status resolved => closed
2018-08-17 12:58 marvintm Fixed in Version => RR18Q4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker