Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038661
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfacemajoralways2018-05-30 17:202018-06-08 11:54
Reporterjoniturralde93View Statuspublic 
Assigned Tocaristu 
PriorityurgentResolutionfixedFixed in Version3.0PR18Q3
StatusclosedFix in branchFixed in SCM revisionb06b5a1512ec
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038661: Problem with tabs with 'Time' fields

DescriptionWhen you modify and save in a tab with a field whose column reference type is 'Time', there are problems. It saves the record correctly, but when you click in other fields or lose the focus in the tab, the save button turns available again, just like when there are pending changes to save.
This doesn't allow to refresh and can lead to errors.
It happens modifying any field on the record, not only the time reference ones.
Steps To Reproduce1. Open Process Request window (i.e.)
2. Create a new record with Timing: 'Run Later'
3. Save the record
4. Now modify either the Start Date or the Start Time
5. Save again
6. Click into other fields or minimize the window
7. The record can be saved again with no modifications, which doesn't allow to refresh and can lead to misunderstandings by the customer.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00258383.0PR14Q2 closedAugustoMauch Time fields are still not working properly in timezones with negative offsets 

-  Notes
(0104883)
hgbot (developer)
2018-06-01 15:12

Repository: erp/devel/pi
Changeset: 99a1cd55eaaae00b545038f83c1c8019ad162f3d
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Jun 01 14:53:03 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/99a1cd55eaaae00b545038f83c1c8019ad162f3d [^]

related to issue 38661: initial code clean up

  Removed some unused variables

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-time.js
---
(0104884)
hgbot (developer)
2018-06-01 15:12

Repository: erp/devel/pi
Changeset: b06b5a1512ec9f5bfed790a1c39526495da12e89
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Jun 01 09:20:31 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b06b5a1512ec9f5bfed790a1c39526495da12e89 [^]

fixes bug 38661: False form change detection due to blur event of 'Time' fields

  When a blur was performed on time fields, false changes were being detected in the form. This was happening because the comparison done by SC between the value of the field and the value returned with the mapDisplayToValue() function were different.

  Changes were detected because time fields stores also the date, and when getting/setting the value todays date is set as date. This change was not being done in the mapDisplayToValue() function. So, now we are setting todays date in the value returned by mapDisplayToValue() in order to be consistent. This avoids the false change detection in the form.

  Note that we are extracting the setTodaysDate as a class method of OBTimeItem, this is because how SC TimeItem is invoking the mapDisplayToValue() function[1]. This way we ensure that the function can always be found.

[1] https://code.openbravo.com/erp/mods/org.openbravo.userinterface.smartclient.dev/file/tip/web/org.openbravo.userinterface.smartclient/isomorphic/client/widgets/form/TimeItem.js#l281 [^]

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-time.js
---
(0104955)
hudsonbot (developer)
2018-06-05 17:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8317f2f73d00 [^]
Maturity status: Test
(0104956)
hudsonbot (developer)
2018-06-05 17:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/8317f2f73d00 [^]
Maturity status: Test
(0105032)
alostale (developer)
2018-06-08 11:54

reviewed + tested

- Issue History
Date Modified Username Field Change
2018-05-30 17:20 joniturralde93 New Issue
2018-05-30 17:20 joniturralde93 Assigned To => platform
2018-05-30 17:20 joniturralde93 Modules => Core
2018-05-30 17:20 joniturralde93 Triggers an Emergency Pack => No
2018-06-01 09:19 caristu Relationship added related to 0025838
2018-06-01 09:34 caristu Status new => scheduled
2018-06-01 09:34 caristu Assigned To platform => caristu
2018-06-01 15:12 hgbot Checkin
2018-06-01 15:12 hgbot Note Added: 0104883
2018-06-01 15:12 hgbot Checkin
2018-06-01 15:12 hgbot Note Added: 0104884
2018-06-01 15:12 hgbot Status scheduled => resolved
2018-06-01 15:12 hgbot Resolution open => fixed
2018-06-01 15:12 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b06b5a1512ec9f5bfed790a1c39526495da12e89 [^]
2018-06-01 15:12 caristu Review Assigned To => alostale
2018-06-05 17:29 hudsonbot Checkin
2018-06-05 17:29 hudsonbot Note Added: 0104955
2018-06-05 17:29 hudsonbot Checkin
2018-06-05 17:29 hudsonbot Note Added: 0104956
2018-06-08 11:54 alostale Note Added: 0105032
2018-06-08 11:54 alostale Status resolved => closed
2018-06-08 11:54 alostale Fixed in Version => 3.0PR18Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker