Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038639
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2018-05-28 11:242018-11-07 09:44
ReporterngarciaView Statuspublic 
Assigned ToAtulOpenbravo 
PriorityimmediateResolutionfixedFixed in Version3.0PR18Q3
StatusclosedFix in branchFixed in SCM revisiond2cc1590b1a1
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2017-08-04
Regression introduced in release3.0PR17Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/2ab8016a2353 [^]
Triggers an Emergency PackNo
Summary

0038639: Debit and credit amounts are wrongly updated in G/L Journal lines with different currency than general ledger currency

DescriptionDebit and credit amounts are wrongly updated in G/L Journal lines with different currency than general ledger currency
Steps To ReproduceAs group admin role:
   Define a valid Conversion Rate (different from 1) from EUR to USD
   Create a G/L Journal
      Organization: F&B US, Inc.
      Currency: EUR

   Add a header to it
      Organization: F&B US, Inc.
      General Ledger: F&B International Group US/A/US Dollar
      Currency: EUR
   Check the rate is updated accordingly

   Add a line to it
   Select an account
   Add a Debit amount and check it is updated with the value of 'General Ledger Currency Debit' and it should not
   The same happens with Credit amount
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00386433.0PR18Q2.1 closedAtulOpenbravo Debit and credit amounts are wrongly updated in G/L Journal lines with different currency than general ledger currency 
depends on backport 00386443.0PR18Q1.4 closedAtulOpenbravo Debit and credit amounts are wrongly updated in G/L Journal lines with different currency than general ledger currency 
caused by design defect 0036067 closedmarkmm82 old callouts should be refactored to implement SimpleCallout 

-  Notes
(0104755)
AtulOpenbravo (developer)
2018-05-28 21:31

Test Plan
- Login as F&B International Group Admin role:
- For current period May 18 realize that Currency Conversion EUR to USD is 1.23
- Create a G/L Journal
   - Organization: F&B US, Inc.
   - Currency: EUR
- Add a header to it
   - Organization: F&B US, Inc.
   - General Ledger: F&B International Group US/A/US Dollar
   -Currency: EUR
- Check the rate is set as 1.23
- Add a line to it
- Select any account
- Set Debit amount as 100 and realize that 'General Ledger Currency Debit' is set as 123.
- Set Credit amount as 100 and realize that 'General Legder Currency Credit' is set as 123.
(0104771)
hgbot (developer)
2018-05-29 15:16

Repository: erp/devel/pi
Changeset: d2cc1590b1a146d9bca402b1704b2fb53c50a9aa
Author: Atul Gaware <atul.gaware <at> openbravo.com>
Date: Tue May 29 00:27:14 2018 +0530
URL: http://code.openbravo.com/erp/devel/pi/rev/d2cc1590b1a146d9bca402b1704b2fb53c50a9aa [^]

Fixes Issue 0038639: Debit and credit amounts are wrongly updated
in G/L Journal lines with different currency than general ledger
currency

**amtSourceDr was wrongly set as amtAcctDr and amtSourceCr as
amtAcctCr in the callouts refactor project. Both values are
set correctly now.

---
M src/org/openbravo/erpCommon/ad_callouts/SL_JournalLineAmt.java
---
(0104775)
dmiguelez (developer)
2018-05-29 15:20

Code Review + Testing Ok
(0104792)
hudsonbot (developer)
2018-05-30 00:14

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/08f13cf1fa33 [^]
Maturity status: Test
(0107775)
Sandrahuguet (developer)
2018-11-07 09:44

Created test case in testlink:

https://testlink.openbravo.com/testlink/linkto.php?tprojectPrefix=Communit&item=testcase&id=Communit-11014 [^]

- Issue History
Date Modified Username Field Change
2018-05-28 11:24 ngarcia New Issue
2018-05-28 11:24 ngarcia Assigned To => Triage Finance
2018-05-28 11:24 ngarcia Modules => Core
2018-05-28 11:24 ngarcia Triggers an Emergency Pack => No
2018-05-28 11:24 ngarcia Relationship added caused by 0036067
2018-05-28 11:25 ngarcia Issue Monitored: networkb
2018-05-28 15:48 dmiguelez Assigned To Triage Finance => AtulOpenbravo
2018-05-28 17:52 AtulOpenbravo Status new => scheduled
2018-05-28 17:56 AtulOpenbravo Regression level => Production - Confirmed Stable
2018-05-28 17:56 AtulOpenbravo Regression date => 2017-08-04
2018-05-28 17:56 AtulOpenbravo Regression introduced in release => 3.0PR17Q4
2018-05-28 17:56 AtulOpenbravo Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/2ab8016a2353 [^]
2018-05-28 21:31 AtulOpenbravo Note Added: 0104755
2018-05-29 15:16 hgbot Checkin
2018-05-29 15:16 hgbot Note Added: 0104771
2018-05-29 15:16 hgbot Status scheduled => resolved
2018-05-29 15:16 hgbot Resolution open => fixed
2018-05-29 15:16 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d2cc1590b1a146d9bca402b1704b2fb53c50a9aa [^]
2018-05-29 15:20 dmiguelez Review Assigned To => dmiguelez
2018-05-29 15:20 dmiguelez Note Added: 0104775
2018-05-29 15:20 dmiguelez Status resolved => closed
2018-05-29 15:20 dmiguelez Fixed in Version => 3.0PR18Q3
2018-05-30 00:14 hudsonbot Checkin
2018-05-30 00:14 hudsonbot Note Added: 0104792
2018-11-07 09:44 Sandrahuguet Note Added: 0107775


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker