Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038617
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformmajoralways2018-05-16 17:312018-05-25 09:26
ReportergorkaionView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR18Q2.1
StatusclosedFix in branchFixed in SCM revisiond13caf113d0e
ProjectionnoneETAnoneTarget Version3.0PR18Q2.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2017-05-30
Regression introduced in release3.0PR17Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/624c1fa5299c [^]
Triggers an Emergency PackNo
Summary

0038617: Autologon and AuthenticationManagers using SSO not working

DescriptionIf you configure an application to use the Autologon Authentication Manager the application is always redirected to the Login page.

The issue is in the index.jsp file.

It is retrieving the AD_SESSION_ID parameter and, if it is not set, it redirects to the login page.

That value is set by the Autologon and other SSO AM later when the authenticate method is executed. So these AM are always redirected to the login page.
Steps To ReproduceConfigure the Openbravo.properties to use Autologon AM:

authentication.class=org.openbravo.authentication.basic.AutologonAuthenticationManager
authentication.autologon.username=Openbravo

compile and try to access the application
Proposed SolutionProposed solution is to create a new method in the AuthenticationManager to determine if the AM is using a SSO login or not. In case of using SSO it should not redirect to the login as the session will be created in the authenticate method.

If finally an authentication is needed the authenticate method should redirect to the login page.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0038566 closedcaristu Autologon and AuthenticationManagers using SSO not working 

-  Notes
(0104681)
hgbot (developer)
2018-05-24 19:09

Repository: erp/backports/3.0PR18Q2.1
Changeset: d13caf113d0e033402060230407b5b9347d590ce
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu May 24 18:01:58 2018 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR18Q2.1/rev/d13caf113d0e033402060230407b5b9347d590ce [^]

fixes issue 38617: Allow to skip the login page redirection done in index.jsp

After the fix for issue 0030031, it was not possible to login in Openbravo by using the authentication retrieved with an external login page. This is because in the index.jsp we first check if the DB session has been created and if not, a redirect to the login page is done.

This was breaking the flow where the authentication is performed externally and then a redirection with the result is done to directly access Openbravo, because in that case the DB session does not exists yet causing the redirection to the login page instead of granting the access into the application.

To fix this problem a new method called useExternalLoginPage() has been added to the AuthenticationManager class. It should be overridden by the subclasses that want to avoid the redirection if the DB session is not still present when trying to access into the application.

---
M src/index.jsp
M src/org/openbravo/authentication/AuthenticationManager.java
M src/org/openbravo/authentication/basic/AutologonAuthenticationManager.java
---
(0104695)
alostale (developer)
2018-05-25 09:26

tested + reviewed

- Issue History
Date Modified Username Field Change
2018-05-24 14:07 caristu Type defect => backport
2018-05-24 14:07 caristu Target Version => 3.0PR18Q2.1
2018-05-24 19:09 hgbot Checkin
2018-05-24 19:09 hgbot Note Added: 0104681
2018-05-24 19:09 hgbot Status scheduled => resolved
2018-05-24 19:09 hgbot Resolution open => fixed
2018-05-24 19:09 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR18Q2.1/rev/d13caf113d0e033402060230407b5b9347d590ce [^]
2018-05-24 19:09 caristu Assigned To platform => caristu
2018-05-25 09:26 alostale Review Assigned To => alostale
2018-05-25 09:26 alostale Note Added: 0104695
2018-05-25 09:26 alostale Status resolved => closed
2018-05-25 09:26 alostale Fixed in Version => 3.0PR18Q2.1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker