Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038500
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] A. PlatformtrivialN/A2018-05-08 08:222018-05-08 11:16
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PrioritynormalResolutionfixedFixed in Versionpi
StatusclosedFix in branchFixed in SCM revision2ec0366c9fe2
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038500: raise minimum required ant

DescriptionCurrently ant versions supported start from 1.7 which was published in 2006. There is no need to continue supporting such old versions.
Steps To Reproduce-
Proposed Solution- Current ubuntu 14.04 appliance ships with ant 1.9.3
- Openbravo currently (since 3.0PR14Q4) includes ant-1.9.2.jar for MMC builds

So in order to continue supporting 14.04 appliance and to minimize change in core (not requiring to update any library), minimum required will be raised to 1.9.2.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0027282 closedAugustoMauch package-info file is not compiled from the Module Management 
blocks backport 00384993.0PR18Q2 closedalostale raise minimum required ant 

-  Notes
(0104318)
hgbot (developer)
2018-05-08 08:56

Repository: erp/devel/pi
Changeset: 2ec0366c9fe290d4b962933661884409ffda4c47
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Tue May 08 08:56:25 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/2ec0366c9fe290d4b962933661884409ffda4c47 [^]

fixes 38500: raise minimum required ant version to 1.9.2

  Check on init task current version is at least 1.9.2

---
M build.xml
---
(0104321)
caristu (developer)
2018-05-08 11:16

Reviewed

- Issue History
Date Modified Username Field Change
2018-05-08 08:51 alostale Type feature request => backport
2018-05-08 08:51 alostale Target Version => 3.0PR18Q2
2018-05-08 08:56 hgbot Checkin
2018-05-08 08:56 hgbot Note Added: 0104318
2018-05-08 08:56 hgbot Status scheduled => resolved
2018-05-08 08:56 hgbot Resolution open => fixed
2018-05-08 08:56 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/2ec0366c9fe290d4b962933661884409ffda4c47 [^]
2018-05-08 09:00 alostale Relationship added related to 0027282
2018-05-08 09:01 alostale Target Version 3.0PR18Q2 =>
2018-05-08 09:04 alostale Type backport => feature request
2018-05-08 11:16 caristu Note Added: 0104321
2018-05-08 11:16 caristu Status resolved => closed
2018-05-08 11:16 caristu Fixed in Version => pi


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker