Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038421
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformmajoralways2018-04-20 13:282018-05-09 19:29
ReporteranderarangurenView Statuspublic 
Assigned Tojarmendariz 
PriorityhighResolutionfixedFixed in Version3.0PR18Q3
StatusclosedFix in branchFixed in SCM revisiond41eeba32732
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionpiSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038421: The width of the drop down of a selector in a grid view is too small.

DescriptionThe width of the drop down of a selector in a grid view is too small.
Steps To Reproduce- Login as System administrator
- Go to Reference window
- Search by name 'Project' and select it
- Go to Defined Selector tab
- Go to Defined Selector Field tab
- Check one record as Show in Picklist: Yes
- Change the rol
- Go to the Simple G/L Item window
- Create a record
- Go to lines in grid view and show 'project' column
- Move that column to the right side
- Create a record in grid mode
- And in 'project' column click the selector dropdown
- If you can see properly the width of the selector add more columns and move 'project' column to the last position
TagsNo tags attached.
Attached Filespng file icon ScreenshotWidthSelector.png [^] (166,542 bytes) 2018-04-20 13:35

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0027544 closedinigosanchez Not possible to use the dropdown of a selector when the line where the selector is located is on the bottom of the page. 

-  Notes
(0104091)
hgbot (developer)
2018-04-26 12:50

Repository: erp/devel/pi
Changeset: d41eeba327329ac54030c340299e1924e5c1408e
Author: Javier Armendáriz <javier.armendariz <at> openbravo.com>
Date: Wed Apr 25 12:32:18 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/d41eeba327329ac54030c340299e1924e5c1408e [^]

Fixed issue 38421: Grid selector dropdown is too small.

Dropdown width calculations doesn't take into account that grid fields length
may be longer than the available viewport, so part of the space left of the
field is not visible in the viewport. ScrollLeft property gives the distance from
the beginning to the point where fields starts to be visible in viewport, so
subtracting this value gives the visible left space available.

Also, the code is refactored to make this calculations more readable.

---
M modules/org.openbravo.userinterface.selector/web/org.openbravo.userinterface.selector/js/ob-selector-item.js
---
(0104148)
caristu (developer)
2018-04-27 10:49

Code reviewed + tested OK.

Repeated also test cases for related issue 0027544. See: https://issues.openbravo.com/view.php?id=27544#c70540 [^]
(0104401)
hudsonbot (developer)
2018-05-09 19:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/2be7d3efe606 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-04-20 13:28 anderaranguren New Issue
2018-04-20 13:28 anderaranguren Assigned To => platform
2018-04-20 13:28 anderaranguren Modules => Core
2018-04-20 13:28 anderaranguren Triggers an Emergency Pack => No
2018-04-20 13:35 anderaranguren Steps to Reproduce Updated View Revisions
2018-04-20 13:35 anderaranguren File Added: ScreenshotWidthSelector.png
2018-04-24 13:09 jarmendariz Status new => scheduled
2018-04-24 13:09 jarmendariz Assigned To platform => jarmendariz
2018-04-26 12:50 hgbot Checkin
2018-04-26 12:50 hgbot Note Added: 0104091
2018-04-26 12:50 hgbot Status scheduled => resolved
2018-04-26 12:50 hgbot Resolution open => fixed
2018-04-26 12:50 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/d41eeba327329ac54030c340299e1924e5c1408e [^]
2018-04-26 12:51 jarmendariz Review Assigned To => caristu
2018-04-27 10:32 caristu Relationship added related to 0027544
2018-04-27 10:49 caristu Note Added: 0104148
2018-04-27 10:49 caristu Status resolved => closed
2018-04-27 10:49 caristu Fixed in Version => 3.0PR18Q3
2018-04-27 10:55 caristu Relationship deleted related to 0027544
2018-04-27 10:56 caristu Relationship added caused by 0027544
2018-05-09 19:29 hudsonbot Checkin
2018-05-09 19:29 hudsonbot Note Added: 0104401


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker