Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038401
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] B. User interfacecriticalalways2018-04-18 11:442018-05-09 19:29
ReporterkchoperenaView Statuspublic 
Assigned Tocaristu 
PriorityurgentResolutionfixedFixed in Version3.0PR18Q3
StatusclosedFix in branchFixed in SCM revisionf7a294ef4724
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038401: [SERQA 3982]: Grid Configuration filtering does not work correctly for foreign key filters

DescriptionWhen we use a filter to filtering foreign key values, if we use the mouse to launch the search, when we click on V the value of the filter will be lost. Also, if after select the value we click out of the box will be lost.
Steps To Reproduce1.- Log into the backend
2.- Config any window grid using the configuration of the attached image.
3.- Go to the configured window and select a value from the list and click on search [Also happens clicking out of the search box]

Video: https://drive.google.com/file/d/1ItbxGvHkn_bgRCNVPop5hjQy8OuDvTOR [^]

Expected: The value of the filter will be lost.
TagsNo tags attached.
Attached Filespng file icon GridConfiguration.png [^] (86,148 bytes) 2018-04-23 19:00

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0104040)
caristu (developer)
2018-04-23 18:21

For the moment, we are not reproducing this issue.

Can you please provide how you define your grid configuration in detail? According to the steps to reproduce it seems that we should configure the "Lazy Filtering". Is any other configuration required?

(0104041)
kchoperena (developer)
2018-04-23 19:01

Added a screenshot of the configuration and a video with the steps to reproduce it
(0104064)
hgbot (developer)
2018-04-24 19:25
edited on: 2018-04-24 19:26

Repository: erp/devel/pi
Changeset: f7a294ef4724c956020cb5c2b4be3d816cfadc6a
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Apr 24 18:47:33 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f7a294ef4724c956020cb5c2b4be3d816cfadc6a [^]

fixes issue 38401: Wrong filter behavior depending on the grid configuration

  Having a grid configuration which both enables lazy filtering and does not allow filtering foreign keys by its identifier, it was not possible to apply a filter in a foreign key combo using the mouse.

  This was happening because when it is allowed to filter foreign keys by its identifier, there is some code that restores the filter editor with the previous criteria in case the entered criteria is not valid when the editor loses the focus (on blur).

  This logic was causing the lose of the filter criteria because it was restoring it with an empty criteria (the grid was not containing any criteria applied because of the lazy filtering). Therefore, to fix this issue we are not restoring the criteria if the lazy filtering is enabled in the grid.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-fk-filter.js
---

(0104110)
AugustoMauch (developer)
2018-04-26 16:58

Code reviewed and verified
(0104392)
hudsonbot (developer)
2018-05-09 19:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/2be7d3efe606 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-04-18 11:44 kchoperena New Issue
2018-04-18 11:44 kchoperena Assigned To => platform
2018-04-18 11:44 kchoperena Modules => Core
2018-04-18 11:44 kchoperena Triggers an Emergency Pack => No
2018-04-23 18:21 caristu Note Added: 0104040
2018-04-23 18:21 caristu Assigned To platform => kchoperena
2018-04-23 18:21 caristu Status new => feedback
2018-04-23 18:58 kchoperena Steps to Reproduce Updated View Revisions
2018-04-23 19:00 kchoperena File Added: GridConfiguration.png
2018-04-23 19:01 kchoperena Note Added: 0104041
2018-04-23 19:05 caristu Assigned To kchoperena => caristu
2018-04-24 19:25 hgbot Checkin
2018-04-24 19:25 hgbot Note Added: 0104064
2018-04-24 19:25 hgbot Status feedback => resolved
2018-04-24 19:25 hgbot Resolution open => fixed
2018-04-24 19:25 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/f7a294ef4724c956020cb5c2b4be3d816cfadc6a [^]
2018-04-24 19:25 caristu Review Assigned To => AugustoMauch
2018-04-24 19:26 caristu Note Edited: 0104064 View Revisions
2018-04-26 16:58 AugustoMauch Note Added: 0104110
2018-04-26 16:58 AugustoMauch Status resolved => closed
2018-04-26 16:58 AugustoMauch Fixed in Version => 3.0PR18Q3
2018-05-09 19:29 hudsonbot Checkin
2018-05-09 19:29 hudsonbot Note Added: 0104392


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker