Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038337
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Web POS Hardware Managermajoralways2018-04-11 18:142018-05-04 15:19
Reportergorka_gilView Statuspublic 
Assigned Togorka_gil 
PriorityurgentResolutionfixedFixed in VersionRR18Q3
StatusclosedFix in branchFixed in SCM revision66eee80c7ed2
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038337: make hardware manager compatible with java 9 - 11

Descriptionhardware manager don't compile with java 9 nor java 11
Steps To Reproduce - hg clone https://code.openbravo.com/erp/pmods/org.openbravo.retail.poshwmanager.sources [^]
 - cd org.openbravo.retail.poshwmanager.sources
 - export JAVA_HOME=path_to_a_java9
 - and clean jar
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0037966 closedshuehner JDK 9: fix new BigDecimal related deprecation warnigns 
depends on backport 0038338RR18Q2 closedgorka_gil make hardware manager compatible with java 9 - 11 

-  Notes
(0103848)
gorka_gil (administrator)
2018-04-12 16:09

tested version openjdk 11ea8
(0103872)
hgbot (developer)
2018-04-13 11:23

Repository: erp/pmods/org.openbravo.retail.poshwmanager
Changeset: 6bba8946e0418820f7503350d725a5cce21a0316
Author: Gorka Gil <gorka.gil <at> openbravo.com>
Date: Thu Apr 12 17:42:21 2018 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.poshwmanager/rev/6bba8946e0418820f7503350d725a5cce21a0316 [^]

Fixes issue 38337: make hardware manager compatible with java 9 - 11

Tested in jdk9 and jdk11ea8

- Change deprecated(jdk9)/deleted(jdk11) function to convert from hex to byte in UnicodeTranslator.java
- Fix Integer, Double, Byte, Float instantiation in many java's
- Delete TicketParserJSON.java since is not used
- Removed the option to play sounds in the hardware manager since is not used and the java applet is deprecated

---
M bin/poshw.jar
M bin/rev.id
---
(0103873)
hgbot (developer)
2018-04-13 11:23

Repository: erp/pmods/org.openbravo.retail.poshwmanager.sources
Changeset: 66eee80c7ed2beb018cc58670c42785913e85659
Author: Gorka Gil <gorka.gil <at> openbravo.com>
Date: Thu Apr 12 17:01:54 2018 +0200
URL: http://code.openbravo.com/erp/pmods/org.openbravo.retail.poshwmanager.sources/rev/66eee80c7ed2beb018cc58670c42785913e85659 [^]

Fixes issue 38337: make hardware manager compatible with java 9 - 11

Tested in jdk9 and jdk11ea8

- Change deprecated(jdk9)/deleted(jdk11) function to convert from hex to byte in UnicodeTranslator.java
- Fix Integer, Double, Byte, Float instantiation in many java's
- Delete TicketParserJSON.java since is not used
- Removed the option to play sounds in the hardware manager since is not used and the java applet is deprecated

---
M project/src/com/openbravo/pos/printer/TicketParser.java
M project/src/com/openbravo/pos/printer/escpos/Codes.java
M project/src/com/openbravo/pos/printer/escpos/CodesWincor.java
M project/src/com/openbravo/pos/printer/escpos/UnicodeTranslator.java
M project/src/com/openbravo/pos/printjrxml/JRJsonDatasource.java
M project/src/com/openbravo/pos/scale/GenericContinuousScale.java
M project/src/com/openbravo/pos/scale/GenericScale.java
M project/src/com/openbravo/pos/scale/ScaleDialog1.java
M project/src/com/openbravo/pos/scale/ScaleFake.java
M project/src/com/openbravo/pos/scale/ScaleSamsungEsp.java
M project/src/com/openbravo/pos/scale/ScaleSerial.java
R project/src/com/openbravo/pos/printer/TicketParserJSON.java
---

- Issue History
Date Modified Username Field Change
2018-04-11 18:14 gorka_gil New Issue
2018-04-11 18:14 gorka_gil Assigned To => gorka_gil
2018-04-11 18:14 gorka_gil Triggers an Emergency Pack => No
2018-04-11 18:14 gorka_gil Status new => scheduled
2018-04-11 18:16 gorka_gil Relationship added related to 0037966
2018-04-12 16:09 gorka_gil Note Added: 0103848
2018-04-13 11:23 hgbot Checkin
2018-04-13 11:23 hgbot Note Added: 0103872
2018-04-13 11:23 hgbot Status scheduled => resolved
2018-04-13 11:23 hgbot Resolution open => fixed
2018-04-13 11:23 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.retail.poshwmanager/rev/6bba8946e0418820f7503350d725a5cce21a0316 [^]
2018-04-13 11:23 hgbot Checkin
2018-04-13 11:23 hgbot Note Added: 0103873
2018-04-13 11:23 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.poshwmanager/rev/6bba8946e0418820f7503350d725a5cce21a0316 [^] => http://code.openbravo.com/erp/pmods/org.openbravo.retail.poshwmanager.sources/rev/66eee80c7ed2beb018cc58670c42785913e85659 [^]
2018-05-04 15:19 marvintm Review Assigned To => marvintm
2018-05-04 15:19 marvintm Status resolved => closed
2018-05-04 15:19 marvintm Fixed in Version => RR18Q3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker