Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038288
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Modules] Remittancemajoralways2018-04-06 11:452018-05-09 19:29
ReporterngarciaView Statuspublic 
Assigned Tocollazoandy4 
PriorityurgentResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionbbec1f5c7300
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Regression date
Regression introduced by commit
Regression level
Review Assigned Todmiguelez
Regression introduced in release
Summary

0038288: Sales Invoice Payment Plan Due date can be modified when related payment is in Remitted status

DescriptionSales Invoice Payment Plan Due date can be modified when related payment is in Remitted status

Remittances only accept documents with due date prior to their expected date, so if the due date of a payment plan is increased it will not fulfill that condition
Steps To ReproduceAs system admin role:
   Set as Displayed the 'Sales Invoice - Payment Plan - Modify Payment Plan'
   Compile the tab and restart tomcat

As group admin role:
   Create a Sales Invoice, set Remittance as its payment method, add a line to it and complete it
   Add a payment to it, execute it and include it on a remittance
   Return to the Sales Invoice, select the payment plan record and Modify Payment Plan
   Check you can increase the due date and you should not
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0038425 newTriage Finance Support for Editable Payment Plan 
causes defect 0038509 closedAtulOpenbravo Sales Invoice Payment Plan Due date cannot be modified when related remitted payment has been protested and voided 

-  Notes
(0103801)
collazoandy4 (developer)
2018-04-10 23:16
edited on: 2018-04-23 18:08

Test Plan
  As System Admin role:
   Set as Displayed the Modify Payment Plan field in Payment Plan tab of Sales Invoice
   Compile the tab and restart tomcat

  As International Group Admin Role:
   Create a new Sales Invoice for any bp, set Transferencia as payment method, add a line to it and complete it
     Go to Payment Plan tab and clic on Modify Payment Plan button and check the process ends without error
   
Test Plan II
   Create a new Sales Invoice for any bp, set Remittance as its payment method, add a line to it and complete it
   Add a payment to it, execute it and include it on a remittance
   Go to the previous invoice created, select the payment plan record and clic on Modify Payment Plan
   Check the process shows the error message 'The invoice is already included in a Remittance.'

Test Plan III
   Create a new Sales Invoice for any bp, set Remittance as its payment method, add a line to it and complete it
   Create a new Remittance header and add the previous invoice as remittance line (Select Order or Invoices button)
   Go to the previous invoice created, select the payment plan record and clic on Modify Payment Plan
   Check the process shows the error message 'The invoice is already included in a Remittance.'

(0104172)
hgbot (developer)
2018-04-30 16:54

Repository: erp/mods/org.openbravo.module.remittance
Changeset: c369ffae37fc26a073a460ffb7faa03364a381b9
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Tue Apr 10 17:12:25 2018 -0400
URL: http://code.openbravo.com/erp/mods/org.openbravo.module.remittance/rev/c369ffae37fc26a073a460ffb7faa03364a381b9 [^]

Fixes issue 38288: Sales Invoice Payment Plan Due date can be modified when
related payment is in Remitted status

Remittances only accept documents with due date prior to their expected date,
the due date of a payment plan can be increased because the process doesn't
properly check the that condition

A new hook is created to check the edited payment schedule lines and avoid validation
issues

---
A src/org/openbravo/module/remittance/hooks/REMModifyPaymentPlanHook.java
---
(0104173)
hgbot (developer)
2018-04-30 16:54

Repository: erp/mods/org.openbravo.module.remittance
Changeset: 5264700466418e90fa9e084b073f7488f3bb9931
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Mon Apr 23 09:10:35 2018 +0200
URL: http://code.openbravo.com/erp/mods/org.openbravo.module.remittance/rev/5264700466418e90fa9e084b073f7488f3bb9931 [^]

Related to Issue 38288. Changed exception thrown.

If the Invoice is already included in a Remittance, or if it has
a Payment included in a Remittance, then an exception is thrown

---
M src/org/openbravo/module/remittance/hooks/REMModifyPaymentPlanHook.java
---
(0104174)
hgbot (developer)
2018-04-30 16:54

Repository: erp/mods/org.openbravo.module.remittance
Changeset: d80ccca9457b27fb19445d5c1e1b61772c90ab9c
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Mon Apr 30 11:09:03 2018 +0200
URL: http://code.openbravo.com/erp/mods/org.openbravo.module.remittance/rev/d80ccca9457b27fb19445d5c1e1b61772c90ab9c [^]

Related to issue 38288. Removed @ signs from message since
are no longer needed with OBMessageUtils API

---
M src/org/openbravo/module/remittance/hooks/REMModifyPaymentPlanHook.java
---
(0104175)
hgbot (developer)
2018-04-30 16:54

Repository: erp/mods/org.openbravo.module.remittance
Changeset: 94dd91908282844e5e83fe9ef616d56d7894a31e
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Mon Apr 30 16:53:41 2018 +0200
URL: http://code.openbravo.com/erp/mods/org.openbravo.module.remittance/rev/94dd91908282844e5e83fe9ef616d56d7894a31e [^]

Related to issue 38288. Updated Module version

---
M src-db/database/sourcedata/AD_MODULE.xml
---
(0104176)
hgbot (developer)
2018-04-30 16:54

Repository: erp/devel/pi
Changeset: bbec1f5c73008c05f8c22c03cf61addf6ea0ce80
Author: Armaignac <collazoandy4 <at> gmail.com>
Date: Tue Apr 10 17:12:31 2018 -0400
URL: http://code.openbravo.com/erp/devel/pi/rev/bbec1f5c73008c05f8c22c03cf61addf6ea0ce80 [^]

Fixes issue 38288: Sales Invoice Payment Plan Due date can be modified when
related payment is in Remitted status

Remittances only accept documents with due date prior to their expected date,
the due date of a payment plan can be increased because the process doesn't
properly check the that condition

A new hook is created to check the edited payment schedule lines and avoid validation
issues

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/actionHandler/ModifyPaymentPlanActionHandler.java
A modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/ModifyPaymentPlanHook.java
A modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/actionHandler/ModifyPaymentPlanHookCaller.java
---
(0104177)
hgbot (developer)
2018-04-30 16:54

Repository: erp/devel/pi
Changeset: f3cb10dc3207e8f3d6f91ce56e8d98669ae2b7b7
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Mon Apr 23 09:17:37 2018 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/f3cb10dc3207e8f3d6f91ce56e8d98669ae2b7b7 [^]

Related to Issue 38288. Code review changes

* Moved validation of Payment Plan before performing any logic
* Changed logic to retrieve messages, it now usses API from OBMessageUtils

---
M modules/org.openbravo.advpaymentmngt/src/org/openbravo/advpaymentmngt/actionHandler/ModifyPaymentPlanActionHandler.java
---
(0104178)
dmiguelez (developer)
2018-04-30 16:56

Code Review + Testing Ok.

Needs to be updated to include a dependency for 18Q3
(0104411)
hudsonbot (developer)
2018-05-09 19:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/2be7d3efe606 [^]
Maturity status: Test
(0104412)
hudsonbot (developer)
2018-05-09 19:29

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/2be7d3efe606 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-04-06 11:45 ngarcia New Issue
2018-04-06 11:45 ngarcia Assigned To => Triage Finance
2018-04-06 12:10 Practics Issue Monitored: Practics
2018-04-06 19:12 dmiguelez Assigned To Triage Finance => collazoandy4
2018-04-09 23:41 collazoandy4 Status new => scheduled
2018-04-10 23:16 collazoandy4 Note Added: 0103801
2018-04-23 13:11 ngarcia Relationship added related to 0038425
2018-04-23 18:08 collazoandy4 Note Edited: 0103801 View Revisions
2018-04-30 16:54 hgbot Checkin
2018-04-30 16:54 hgbot Note Added: 0104172
2018-04-30 16:54 hgbot Status scheduled => resolved
2018-04-30 16:54 hgbot Resolution open => fixed
2018-04-30 16:54 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/mods/org.openbravo.module.remittance/rev/c369ffae37fc26a073a460ffb7faa03364a381b9 [^]
2018-04-30 16:54 hgbot Checkin
2018-04-30 16:54 hgbot Note Added: 0104173
2018-04-30 16:54 hgbot Checkin
2018-04-30 16:54 hgbot Note Added: 0104174
2018-04-30 16:54 hgbot Checkin
2018-04-30 16:54 hgbot Note Added: 0104175
2018-04-30 16:54 hgbot Checkin
2018-04-30 16:54 hgbot Note Added: 0104176
2018-04-30 16:54 hgbot Fixed in SCM revision http://code.openbravo.com/erp/mods/org.openbravo.module.remittance/rev/c369ffae37fc26a073a460ffb7faa03364a381b9 [^] => http://code.openbravo.com/erp/devel/pi/rev/bbec1f5c73008c05f8c22c03cf61addf6ea0ce80 [^]
2018-04-30 16:54 hgbot Checkin
2018-04-30 16:54 hgbot Note Added: 0104177
2018-04-30 16:56 dmiguelez Review Assigned To => dmiguelez
2018-04-30 16:56 dmiguelez Note Added: 0104178
2018-04-30 16:56 dmiguelez Status resolved => closed
2018-05-09 16:12 ngarcia Issue cloned 0038509
2018-05-09 16:12 ngarcia Relationship added caused by 0038509
2018-05-09 16:12 ngarcia Relationship replaced causes 0038509
2018-05-09 19:29 hudsonbot Checkin
2018-05-09 19:29 hudsonbot Note Added: 0104411
2018-05-09 19:29 hudsonbot Checkin
2018-05-09 19:29 hudsonbot Note Added: 0104412


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker