Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0038131
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformtrivialhave not tried2018-03-14 11:102018-03-15 15:32
ReporterjarmendarizView Statuspublic 
Assigned Tojarmendariz 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q2
StatusclosedFix in branchFixed in SCM revisionbf94b5ddb743
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version9
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0038131: Remove deprecated message for AccessibleObject.isAccesible

DescriptionStarting from JDK9, AccesibleObject.isAccesible() is marked as deprecated. The documentation [1] suggests that it should be replaced by canAccess(Object), however this method is available only from JDK9.


[1] https://docs.oracle.com/javase/9/docs/api/java/lang/reflect/AccessibleObject.html#isAccessible-- [^]
Steps To ReproduceCompile project with Java 9, open the project with Eclipse and see the resulting warnings.
Proposed SolutionMark with @SupressWarnings("deprecation") the lines with the deprecated code.
When the minimum Java version supported raises to 9, then it should be replaced with canAccess(Object).
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0037083 closedalostale support JDK 9 
related to design defect 0038132 acknowledgedplatform Replace deprecated isAccesible() with canAccess() introduced in JDK9 

-  Notes
(0103246)
hgbot (developer)
2018-03-14 17:06

Repository: erp/devel/pi
Changeset: bf94b5ddb7433eda47159094d702dff2493dd9a9
Author: Javier Armendáriz <javier.armendariz <at> openbravo.com>
Date: Wed Mar 14 16:52:23 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/bf94b5ddb7433eda47159094d702dff2493dd9a9 [^]

Fixed bug 38131: Removed deprecation warning of isAccesible

Added @SupressWarning("all") to temporarily remove the deprecation warning of isAccessible
method until it can be replaced with the new canAccess(). Using the "all" value
because using @SuppressWarning("deprecation") shows an "unnecesary suppress warning"
warning in JDK8 and lower.

---
M modules/org.openbravo.base.weld/src-test/org/openbravo/base/weld/test/ParameterCdiTestRule.java
M modules/org.openbravo.client.application/src-test/org/openbravo/client/application/test/DisplayLogicAtServerLevelTest.java
M src-test/src/org/openbravo/test/base/HiddenObjectHelper.java
---
(0103259)
hudsonbot (developer)
2018-03-14 23:43

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/91dc222dee6a [^]
Maturity status: Test
(0103267)
hgbot (developer)
2018-03-15 08:57

Repository: erp/devel/pi
Changeset: c6d53eea0b79de58d67e2f588a70398c50975035
Author: Javier Armendáriz <javier.armendariz <at> openbravo.com>
Date: Thu Mar 15 08:54:37 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/c6d53eea0b79de58d67e2f588a70398c50975035 [^]

Related to bug 38131: Removed deprecation warning of isAccesible

Moved code in order to be able to put @SupressWarnings for a single line
instead of the whole method.

---
M modules/org.openbravo.base.weld/src-test/org/openbravo/base/weld/test/ParameterCdiTestRule.java
---
(0103268)
caristu (developer)
2018-03-15 09:11

Verified
(0103280)
hudsonbot (developer)
2018-03-15 15:32

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c6d6e97c6d07 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-03-14 11:10 jarmendariz New Issue
2018-03-14 11:10 jarmendariz Assigned To => platform
2018-03-14 11:10 jarmendariz Modules => Core
2018-03-14 11:10 jarmendariz Triggers an Emergency Pack => No
2018-03-14 11:14 jarmendariz Relationship added related to 0037083
2018-03-14 11:19 jarmendariz Relationship added related to 0038132
2018-03-14 11:34 jarmendariz Assigned To platform => jarmendariz
2018-03-14 11:34 jarmendariz Status new => scheduled
2018-03-14 17:06 hgbot Checkin
2018-03-14 17:06 hgbot Note Added: 0103246
2018-03-14 17:06 hgbot Status scheduled => resolved
2018-03-14 17:06 hgbot Resolution open => fixed
2018-03-14 17:06 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/bf94b5ddb7433eda47159094d702dff2493dd9a9 [^]
2018-03-14 18:31 jarmendariz Review Assigned To => caristu
2018-03-14 23:43 hudsonbot Checkin
2018-03-14 23:43 hudsonbot Note Added: 0103259
2018-03-15 08:57 hgbot Checkin
2018-03-15 08:57 hgbot Note Added: 0103267
2018-03-15 09:11 caristu Note Added: 0103268
2018-03-15 09:11 caristu Status resolved => closed
2018-03-15 09:11 caristu Fixed in Version => 3.0PR18Q2
2018-03-15 09:13 caristu Steps to Reproduce Updated View Revisions
2018-03-15 15:32 hudsonbot Checkin
2018-03-15 15:33 hudsonbot Note Added: 0103280


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker