Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037989
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 07. Sales managementmajoralways2018-02-21 15:452018-03-02 21:18
ReportermaiteView Statuspublic 
Assigned Tomarkmm82 
PriorityimmediateResolutionfixedFixed in Version3.0PR18Q2
StatusclosedFix in branchFixed in SCM revisionc4a55a7aa3c4
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/86dcf5d294d9 [^]
Triggers an Emergency PackNo
Summary

0037989: Tax tab info is not correctly recalculated when tax defined as "Line Net Amount + Tax Amount" is modified

DescriptionWhen changing the tax in an already created sales invoice line Tax tab is not correctly recalculated (while Line Tax tab is)
Steps To Reproduce1. Access "Tax rate" window and create:
  * one record defined as "Summary level"
  * another record with any rate, Base Amount =Line Net Amount and Parent tax rate= previous summary tax
  * another record with any rate, Base Amount =Line Net Amount + Tax Amount, Base ax= previous one and Parent tax rate= previous summary tax
2. Create Sales Invoice record. Add line, set any product and Tax= summary tax
3. Realize that both "Tax line" tab and "Tax" tab has both children taxes
4. Access Sales Invoice line and change tax to set any other value
5. Access "Line tax" tab and realize that correct tax appears
6. However access "Tax" tab and realize that still one rate belonging to previous tax is there, which is wrong
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00380043.0PR18Q1.1 closedmarkmm82 Tax tab info is not correctly recalculated when tax defined as "Line Net Amount + Tax Amount" is modified 
depends on backport 00380053.0PR17Q4.2 closedmarkmm82 Tax tab info is not correctly recalculated when tax defined as "Line Net Amount + Tax Amount" is modified 
caused by design defect 0032265 closedaferraz [SER QA 1434] Taxes at document level are not properly calculated in some cases 
related to defect 0038302 closedcollazoandy4 Tax tab info is not correctly recalculated when negative child tax defined as "cascade" is modified 

-  Notes
(0102828)
markmm82 (developer)
2018-02-23 17:36

1. Access "Tax rate" window and create:
  * one record defined as "Summary level"
  * another record with any rate, Base Amount =Line Net Amount and Parent tax rate= previous summary tax
  * another record with any rate, Base Amount =Line Net Amount + Tax Amount, Base ax= previous one and Parent tax rate= previous summary tax
2. Create Sales Invoice record. Add line, set any product and Tax= summary tax
3. Realize that both "Tax line" tab and "Tax" tab has both children taxes
4. Access Sales Invoice line and change tax to set any other value.
5. Access "Line tax" tab and realize that correct tax appears
6. Access "Tax" tab and realize that all rates belonging to previous tax has been deleted and new one has been created related to the line tax.
(0102829)
markmm82 (developer)
2018-02-23 17:39

Executed the TaxesTest test suite and the 800 test cases ran without failures.
(0102840)
hgbot (developer)
2018-02-27 09:10

Repository: erp/devel/pi
Changeset: c4a55a7aa3c4800a3c7cf074be7d189c8eee4fbf
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Fri Feb 23 14:32:01 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/c4a55a7aa3c4800a3c7cf074be7d189c8eee4fbf [^]

Fixes issue 37989. Order Invoice Tax Lines before deleting.

The order in which the Invoice Tax Lines are deleted can affect
calculations done by the triggers. They must be deleted
in the correct order.

---
M src-db/database/model/triggers/C_INVOICELINE_TRG2.xml
---
(0102843)
dmiguelez (developer)
2018-02-27 09:13

Code Review + Testing Ok
(0102952)
hudsonbot (developer)
2018-03-02 21:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/05dece3dc80b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-02-21 15:45 maite New Issue
2018-02-21 15:45 maite Assigned To => Triage Finance
2018-02-21 15:45 maite Modules => Core
2018-02-21 15:45 maite Triggers an Emergency Pack => No
2018-02-21 15:45 maite Issue Monitored: networkb
2018-02-21 16:30 achaves Issue Monitored: achaves
2018-02-21 17:56 jfrances Issue Monitored: jfrances
2018-02-22 11:19 maite Priority urgent => immediate
2018-02-22 12:39 dmiguelez Assigned To Triage Finance => markmm82
2018-02-22 15:26 markmm82 Status new => acknowledged
2018-02-22 19:52 markmm82 Relationship added caused by 0032265
2018-02-22 19:53 markmm82 Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/86dcf5d294d9 [^]
2018-02-23 17:36 markmm82 Note Added: 0102828
2018-02-23 17:39 markmm82 Note Added: 0102829
2018-02-27 09:04 dmiguelez Status acknowledged => scheduled
2018-02-27 09:10 hgbot Checkin
2018-02-27 09:10 hgbot Note Added: 0102840
2018-02-27 09:10 hgbot Status scheduled => resolved
2018-02-27 09:10 hgbot Resolution open => fixed
2018-02-27 09:10 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/c4a55a7aa3c4800a3c7cf074be7d189c8eee4fbf [^]
2018-02-27 09:13 dmiguelez Review Assigned To => dmiguelez
2018-02-27 09:13 dmiguelez Note Added: 0102843
2018-02-27 09:13 dmiguelez Status resolved => closed
2018-02-27 09:13 dmiguelez Fixed in Version => 3.0PR18Q2
2018-03-02 21:18 hudsonbot Checkin
2018-03-02 21:18 hudsonbot Note Added: 0102952
2018-04-09 18:21 aferraz Relationship added related to 0038302


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker