Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037982
TypeCategorySeverityReproducibilityDate SubmittedLast Update
design defect[Openbravo ERP] 06. Material requirement planning (MRP)minoralways2018-02-20 17:442018-03-02 21:18
ReportergorkaionView Statuspublic 
Assigned Tomarkmm82 
PriorityimmediateResolutionfixedFixed in Version3.0PR18Q2
StatusclosedFix in branchFixed in SCM revisiona959a97929c7
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression levelPre packaging ( pi )
Regression date2018-01-22
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/21e9102f2f7d35c80b8c06aa5984cfb761005220 [^]
Triggers an Emergency PackNo
Summary

0037982: Not possible to delete Manufacturing Plans

DescriptionWhen the tree view of Manufacturing Plan lines was enabled the Node Deletion Policy selected was "Do Not Allow If Has Children"

This policy has broken the ability to delete the Manufacturing Plan header deleting all the lines. It throws the following error:
org.openbravo.base.exception.OBException: You cannot delete this node because it has children nodes associated

Changing the policy to "Reparent Child Nodes" fixes the issue and the plan is deleted.

The ability to delete the header is required as this window usually generates thousands of lines.
Steps To ReproduceConfigure and execute a Manufacturing Plan.
Try to delete it.
Proposed SolutionIdeally implement a new deletion policy: "Delete Child Nodes" and use it.

At short term: change the Node Deletion Policy to "Reparent Child Nodes"
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by design defect 0037642 closednonofrancisco Enable tree view in MRP Manufacturing Plan window 

-  Notes
(0102559)
markmm82 (developer)
2018-02-21 16:10

Test Plan

As F&B International Group Admin
  * Create a new Product
    Organization "F&B España Region Norte"
    Search key: "RM"
    Name: "Raw Material"
    Production: true
  * Create a new Product
      Organization "F&B España Region Norte"
      Search key: "Final"
      Name: "Final Product"
      Production: true

  * Create a new Manufacturing Plan
      Organization "F&B España Region Norte"
      Name: "MP"
      * Verify Lines tab is showing in grid view
      * Create a new line
        Planned date: today
        Product: "Final"
      * Create a new line
        Planned date: today
        Product: "Raw Material"
        Report set: "MP - - Final - Final - -"
      * Activate tree view for Lines tab

  Verify the lines are shown in tree view, the root node of the tree is the line containing "Final" product; the leaf node is the line containing "Raw Material" product.

   * Delete the created Manufacturing Plan. Notice header and all the lines are removed without any error.
(0102597)
hgbot (developer)
2018-02-22 12:57

Repository: erp/devel/pi
Changeset: a959a97929c7acdee072484147b77eb1996ba8fe
Author: Mark <markmm82 <at> gmail.com>
Date: Wed Feb 21 10:20:19 2018 -0500
URL: http://code.openbravo.com/erp/devel/pi/rev/a959a97929c7acdee072484147b77eb1996ba8fe [^]

Fixes issue 37982: Not possible to delete Manufacturing Plans

Changed the policy to "Reparent Child Nodes" in the Table Tree Category to be able
to delete a Manufactoring plan and it lines without need to do by a line by line
process

---
M src-db/database/sourcedata/AD_TABLE_TREE.xml
---
(0102598)
dmiguelez (developer)
2018-02-22 13:03

Code Review + Testing Ok
(0102945)
hudsonbot (developer)
2018-03-02 21:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/05dece3dc80b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-02-20 17:44 gorkaion New Issue
2018-02-20 17:44 gorkaion Assigned To => Triage Finance
2018-02-20 17:44 gorkaion Modules => Core
2018-02-20 17:44 gorkaion Regression level => Pre packaging ( pi )
2018-02-20 17:44 gorkaion Regression date => 2018-01-22
2018-02-20 17:44 gorkaion Regression introduced in release => pi
2018-02-20 17:44 gorkaion Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/21e9102f2f7d35c80b8c06aa5984cfb761005220 [^]
2018-02-20 17:44 gorkaion Triggers an Emergency Pack => No
2018-02-20 17:44 gorkaion Issue generated from 0037642
2018-02-20 17:44 gorkaion Relationship added caused by 0037642
2018-02-20 17:48 gorkaion Priority high => immediate
2018-02-21 11:54 dmiguelez Assigned To Triage Finance => markmm82
2018-02-21 15:04 markmm82 Status new => scheduled
2018-02-21 16:10 markmm82 Note Added: 0102559
2018-02-22 10:20 Practics Issue Monitored: Practics
2018-02-22 12:57 hgbot Checkin
2018-02-22 12:57 hgbot Note Added: 0102597
2018-02-22 12:57 hgbot Status scheduled => resolved
2018-02-22 12:57 hgbot Resolution open => fixed
2018-02-22 12:57 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/a959a97929c7acdee072484147b77eb1996ba8fe [^]
2018-02-22 13:03 dmiguelez Review Assigned To => dmiguelez
2018-02-22 13:03 dmiguelez Note Added: 0102598
2018-02-22 13:03 dmiguelez Status resolved => closed
2018-02-22 13:03 dmiguelez Fixed in Version => 3.0PR18Q2
2018-03-02 21:18 hudsonbot Checkin
2018-03-02 21:18 hudsonbot Note Added: 0102945


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker