Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037880
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] 09. Financial managementminorhave not tried2018-02-11 12:502018-04-11 17:02
ReportershuehnerView Statuspublic 
Assigned Toshuehner 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q3
StatusclosedFix in branchFixed in SCM revision9dd5be4a1bd3
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037880: Remove broken report "Settlement", used in print button of old-flow window "Settlement" (pre-aprm), as uses obsolete fop

DescriptionThis report "RptC_Settlement" is using the old fop rendering technology planned to be removed eventually.

Apart:
1.) It is used only in print button of "Settlement" window
2.) That window is deactivated by default.
3.) It is related to the old-flow payments system from before APRM.
aprm is mandatory to be used since start of 2.50
4.) The report is broken by default as it is affected by fop-upgrade in done in start of 2016 in issue 32110. And it was not updated.
Afaik no report came in about it not working in the last 2 years.

So probably it could be just removed from the core product instead of being fixed or rewritten.
Steps To Reproduce-
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0032110 closedcaristu Openbravo ERP Upgrade FOP library 
related to defect 0038320 closedshuehner Openbravo ERP API-Change for removal of 4 obsolete fop-related reports (RptM_Inout, RptM_Movement, RptC_Settlement, PromissoryNote) 
related to defect 0038321 closedshuehner Retail Modules Retail issue to update all 3 retail sampledata's in relation to 4 ad_process deletions in pi. 
blocks feature request 0037874 closedalostale Openbravo ERP Remove support for fop rendering from core product as very nearly not used 

-  Notes
(0102309)
shuehner (administrator)
2018-02-11 12:52

Note other usage of this process 800070 (apart of the tab mentioned above) could be found in pi or download of getAllModules.
(0103793)
hgbot (developer)
2018-04-10 21:13

Repository: erp/devel/pi
Changeset: 9dd5be4a1bd333661133e6918b320846e64c4b90
Author: Stefan Hühner <stefan.huehner <at> openbravo.com>
Date: Sun Feb 11 13:12:12 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/9dd5be4a1bd333661133e6918b320846e64c4b90 [^]

Fixed 37880. Remove broken & obsolete Report RptC_Settlement (pre-arpm)

That report is broken since start of 2016 as not updated for api-changes
related to fop library upgrade. No bug was reported during last 2 years
about that.
Apart is related to pre-arpm old payment flow which is not used since start
of 3.0 and only for transactions done before that.

---
M referencedata/sampledata/F_B_International_Group/AD_PROCESS_ACCESS.xml
M referencedata/sampledata/QA_Testing/AD_PROCESS_ACCESS.xml
M src-db/database/sourcedata/AD_MODEL_OBJECT.xml
M src-db/database/sourcedata/AD_MODEL_OBJECT_MAPPING.xml
M src-db/database/sourcedata/AD_PROCESS.xml
M src-db/database/sourcedata/AD_TAB.xml
M src-db/database/sourcedata/AD_TEXTINTERFACES.xml
R src/org/openbravo/erpReports/RptC_Settlement.fo
R src/org/openbravo/erpReports/RptC_Settlement.java
R src/org/openbravo/erpReports/RptC_Settlement.xml
R src/org/openbravo/erpReports/RptC_SettlementHeader.fo
R src/org/openbravo/erpReports/RptC_SettlementHeader.xml
R src/org/openbravo/erpReports/RptC_SettlementLines.fo
R src/org/openbravo/erpReports/RptC_SettlementLines.xml
R src/org/openbravo/erpReports/RptC_Settlement_Header_data.xsql
R src/org/openbravo/erpReports/RptC_Settlement_Lines_data.xsql
R src/org/openbravo/erpReports/RptC_Settlement_data.xsql
---
(0103824)
vmromanos (developer)
2018-04-11 17:02

Code review OK

Stuff belonging to old payment flow

- Issue History
Date Modified Username Field Change
2018-02-11 12:50 shuehner New Issue
2018-02-11 12:50 shuehner Assigned To => shuehner
2018-02-11 12:50 shuehner Modules => Core
2018-02-11 12:50 shuehner Triggers an Emergency Pack => No
2018-02-11 12:50 shuehner Relationship added blocks 0037874
2018-02-11 12:52 shuehner Note Added: 0102309
2018-02-11 12:53 shuehner Relationship added related to 0032110
2018-04-10 21:00 shuehner Relationship added related to 0038320
2018-04-10 21:04 shuehner Relationship added related to 0038321
2018-04-10 21:13 hgbot Checkin
2018-04-10 21:13 hgbot Note Added: 0103793
2018-04-10 21:13 hgbot Status new => resolved
2018-04-10 21:13 hgbot Resolution open => fixed
2018-04-10 21:13 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/9dd5be4a1bd333661133e6918b320846e64c4b90 [^]
2018-04-10 21:18 shuehner Review Assigned To => vmromanos
2018-04-11 17:02 vmromanos Note Added: 0103824
2018-04-11 17:02 vmromanos Status resolved => closed
2018-04-11 17:02 vmromanos Fixed in Version => 3.0PR18Q3
2018-12-24 13:42 alostale Relationship added blocks 0039848


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker