Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037875
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] 04. Warehouse managementminorhave not tried2018-02-10 14:442018-04-11 16:57
ReportershuehnerView Statuspublic 
Assigned Toshuehner 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q3
StatusclosedFix in branchFixed in SCM revisionb91caad20e5c
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037875: Delete report RptM_Inout (based on old fop, not used)

DescriptionThat Report is obsolete and should be removed.

a.) It is based on old fop technology
b.1) It does not have any reference to its ad_process entry ( no menu)
b.2) Is not used for 'print button' in any tab

Old issue 11996 in 2010 removed that process as print button.

c.) It does not have html gui so can only be used by other code setting id via http session (not such code could be found)
d.) No user in getAllModules download could be found
Steps To Reproduce-
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00119962.50MP14 closedadrianromero Openbravo ERP The jasper report linked to MM Shipment/Receipt is not printed 
related to defect 0038320 closedshuehner Openbravo ERP API-Change for removal of 4 obsolete fop-related reports (RptM_Inout, RptM_Movement, RptC_Settlement, PromissoryNote) 
related to defect 0038321 closedshuehner Retail Modules Retail issue to update all 3 retail sampledata's in relation to 4 ad_process deletions in pi. 
blocks feature request 0037874 closedalostale Openbravo ERP Remove support for fop rendering from core product as very nearly not used 

-  Notes
(0102307)
shuehner (administrator)
2018-02-11 10:57

Update issue as technically report could still be used (via print button of tab based in m_inout) but is not since many years.
(0103791)
hgbot (developer)
2018-04-10 21:13

Repository: erp/devel/pi
Changeset: b91caad20e5c155889612b1bc462806d67fb59cf
Author: Stefan Hühner <stefan.huehner <at> openbravo.com>
Date: Sat Feb 10 15:11:46 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/b91caad20e5c155889612b1bc462806d67fb59cf [^]

Fixed 37875. Remove unused & broken RptM_Inout report.

That report does not support uuids, so cannot work on any entries since
start of 2.50. As that was never reported that report in fact seems not
used by anybody.

---
M referencedata/sampledata/F_B_International_Group/AD_PROCESS_ACCESS.xml
M referencedata/sampledata/QA_Testing/AD_PROCESS_ACCESS.xml
M src-db/database/sourcedata/AD_MODEL_OBJECT.xml
M src-db/database/sourcedata/AD_MODEL_OBJECT_MAPPING.xml
M src-db/database/sourcedata/AD_PROCESS.xml
M src-db/database/sourcedata/AD_TEXTINTERFACES.xml
R src/org/openbravo/erpReports/RptM_Inout.fo
R src/org/openbravo/erpReports/RptM_Inout.java
R src/org/openbravo/erpReports/RptM_Inout.xml
R src/org/openbravo/erpReports/RptM_InoutHeader.fo
R src/org/openbravo/erpReports/RptM_InoutHeader.xml
R src/org/openbravo/erpReports/RptM_InoutLines.fo
R src/org/openbravo/erpReports/RptM_InoutLines.xml
R src/org/openbravo/erpReports/RptM_Inout_Header_data.xsql
R src/org/openbravo/erpReports/RptM_Inout_Lines_data.xsql
R src/org/openbravo/erpReports/RptM_Inout_data.xsql
---
(0103822)
vmromanos (developer)
2018-04-11 16:57

Code review + testing OK

M_InOut related tabs can be properly printed via Document Type's Report Template.

- Issue History
Date Modified Username Field Change
2018-02-10 14:44 shuehner New Issue
2018-02-10 14:44 shuehner Assigned To => shuehner
2018-02-10 14:44 shuehner Modules => Core
2018-02-10 14:44 shuehner Triggers an Emergency Pack => No
2018-02-10 14:44 shuehner Relationship added blocks 0037874
2018-02-10 15:20 shuehner Category A. Platform => 04. Warehouse management
2018-02-11 10:57 shuehner Note Added: 0102307
2018-02-11 10:57 shuehner Type defect => feature request
2018-02-11 10:57 shuehner Summary Delete report RptM_Inout (does not support uuids, based on old fop, no ad_menu) => Delete report RptM_Inout (based on old fop, not used)
2018-02-11 10:57 shuehner Description Updated View Revisions
2018-02-11 10:57 shuehner Steps to Reproduce Updated View Revisions
2018-02-11 10:57 shuehner Proposed Solution updated
2018-02-11 11:05 shuehner Relationship added related to 0011996
2018-04-10 21:00 shuehner Relationship added related to 0038320
2018-04-10 21:04 shuehner Relationship added related to 0038321
2018-04-10 21:13 hgbot Checkin
2018-04-10 21:13 hgbot Note Added: 0103791
2018-04-10 21:13 hgbot Status new => resolved
2018-04-10 21:13 hgbot Resolution open => fixed
2018-04-10 21:13 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b91caad20e5c155889612b1bc462806d67fb59cf [^]
2018-04-10 21:17 shuehner Review Assigned To => vmromanos
2018-04-11 16:57 vmromanos Note Added: 0103822
2018-04-11 16:57 vmromanos Status resolved => closed
2018-04-11 16:57 vmromanos Fixed in Version => 3.0PR18Q3
2018-12-24 13:42 alostale Relationship added blocks 0039848


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker