Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037850
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 04. Warehouse managementmajoralways2018-02-07 11:532018-03-02 21:18
ReporterngarciaView Statuspublic 
Assigned Tocollazoandy4 
PriorityhighResolutionfixedFixed in Version3.0PR18Q2
StatusclosedFix in branchFixed in SCM revision4949275527c9
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037850: Stock Valuation of 0 in Product - Unit Cost tab if product is received in a warehouse created after unit cost is calculated

DescriptionStock Valuation of 0 in Product - Unit Cost tab if product is received in a warehouse created after unit cost is calculated
Steps To ReproduceAs group admin role:
   Set 'Allow to persist Unit Cost' preference to Y
   Log out and log in
   Create a new Costing Rule for 'F&B US, Inc.', select Warehouse Dimension checkbox and Validate it
   Launch Reset Unit Cost process for 'F&B US, Inc.'
   Create a warehouse and storage bin for 'F&B US East Coast'
   Create a Goods Movements and move 5 units of a product for EC-0-0-0 to the newly created storage bin
   Launch the Costing Background Process
   Go to Product - Unit Cost tab and check the Total Stock Valuation is shown as 0 for the newly created warehouse. This is wrong

   Launch the Reset Unit Cost process and check the Total Stock Valuation is updated correctly
   
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]

-  Notes
(0102501)
collazoandy4 (developer)
2018-02-19 20:32

Test Plan
  Go to Preference window and create a new record:
    Organization: F&B US, Inc., Property: Allow to persist Unit Cost, Value: Y
  Log out and Log in
  Create a new Costing Rule for 'F&B US, Inc.', select Warehouse Dimension checkbox and Validate it
  Launch Reset Unit Cost for F&B US, Inc. organization
  Go to Warehouse and Storage Bin and create a new record:
    Organization: F&B US East Coast
    Search Key/Name: IssueWarehouse
    Set an Spain location
    Create a new record in Storage Bin tab:
      Search Key: Bin1
      Fill all the required fields
  Go to Goods Movements Window and create a new record:
    Organization: F&B US East Coast
    Create a new record in Lines tab:
      Product: White wine
      Movement Quantity: 5
      New Storage Bin: Bin1
    Process the Movement
  Go to Process Reques window and unschedule the Costing Background Process and edit it to Run Inmediately and Reschedule the Process and check ends successfully
  Go to Product window and select White wine record:
    Check in Unit Cost a new record was created for IssueWarehouse with:
      Organization: F&B US, Inc., Stock: 5, Stock Valuation: 17.75, Warehouse: Issue Warehouse, Unit Cost: 3.55
  Go to Goods Receipts window and create a new record:
    Organization: F&B US East Coast
    Business Partner: Be Soft Drinker, Inc.
    Create a new record in Lines tab:
      Product: White wine
      Storage Bin: Bin1
      Movement Quantity: 7
    Complete the Receipt
  Launch the Costing Background Process
  Go to White wine product and check the Valuation Stock for Issue Warehouse was updated
    Organization: F&B US, Inc., Stock: 12, Stock Valuation: 42.6, Warehouse: Issue Warehouse, Unit Cost: 3.55


Test Plan II
  Go to Product window and create a new record:
    Organization: F&B US, Inc.
    Search Key/Name: Issue Product
    Create a new record in Price tab:
      Price List Version: Be Soft Drinker Price List
      Unit Price: 7
    Check 0 Stock Valuation value for the three warehouses
  Go to Goods Receipts window and create a new record:
    Organization: F&B US East Coast
    Business Partner: Be Soft Drinker, Inc.
    Create a new record in Lines tab:
      Product: Issue Product
      Storage Bin: Bin1
      Movement Quantity: 10
    Complete the Receipt
  Launch the Costing Background Process
  Go to Product window and select Issue Product record and check the Valuation Stock for Issue Warehouse was updated
    Organization: F&B US, Inc., Stock: 10, Stock Valuation: 70, Warehouse: Issue Warehouse, Unit Cost: 7
(0102807)
hgbot (developer)
2018-02-23 08:49

Repository: erp/devel/pi
Changeset: 4949275527c9a095d0d441e58a0b79e05abe96a5
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Fri Feb 23 08:45:53 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/4949275527c9a095d0d441e58a0b79e05abe96a5 [^]

Fixes issue 37850: Stock Valuation of 0 in Product - Unit Cost tab if product is
received in a warehouse created after unit cost is calculated

When a new transaction increase the product stock in a warehouse and doesn't exist
a stock valuation record to this warehouse the M_Transaction_Cost trigger can't
set the valuation cost because the stock is 0.

The flush to M_Transaction when the cost is calculated trigger the M_Update_Stock_Valuation
with the correct stock quantity and then the M_Transaction_Cost trigger can set the
valuation cost to the Stock Valuation created in the M_Transaction trigger.

---
M src/org/openbravo/costing/CostingServer.java
---
(0102808)
dmiguelez (developer)
2018-02-23 08:51

Code Review + Testing Ok
(0102947)
hudsonbot (developer)
2018-03-02 21:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/05dece3dc80b [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-02-07 11:53 ngarcia New Issue
2018-02-07 11:53 ngarcia Assigned To => Triage Finance
2018-02-07 11:53 ngarcia Modules => Core
2018-02-07 11:53 ngarcia Triggers an Emergency Pack => No
2018-02-07 11:54 ngarcia Issue Monitored: networkb
2018-02-07 12:24 eugeni Issue Monitored: eugeni
2018-02-14 17:38 ngarcia Severity minor => major
2018-02-15 17:28 dmiguelez Assigned To Triage Finance => collazoandy4
2018-02-16 18:48 collazoandy4 Status new => scheduled
2018-02-19 20:32 collazoandy4 Note Added: 0102501
2018-02-23 08:49 hgbot Checkin
2018-02-23 08:49 hgbot Note Added: 0102807
2018-02-23 08:49 hgbot Status scheduled => resolved
2018-02-23 08:49 hgbot Resolution open => fixed
2018-02-23 08:49 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/4949275527c9a095d0d441e58a0b79e05abe96a5 [^]
2018-02-23 08:51 dmiguelez Review Assigned To => dmiguelez
2018-02-23 08:51 dmiguelez Note Added: 0102808
2018-02-23 08:51 dmiguelez Status resolved => closed
2018-02-23 08:51 dmiguelez Fixed in Version => 3.0PR18Q2
2018-03-02 21:18 hudsonbot Checkin
2018-03-02 21:18 hudsonbot Note Added: 0102947


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker