Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037796
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 05. Production managementmajoralways2018-01-31 17:472018-02-22 18:18
ReporterngarciaView Statuspublic 
Assigned Todmiguelez 
PriorityimmediateResolutionfixedFixed in Version3.0PR18Q2
StatusclosedFix in branchFixed in SCM revisionb45167e7c675
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2017-05-31
Regression introduced in release3.0PR17Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/bd09a9d5ffa8f7b2dce0cb634b14aef05c67270f [^]
Triggers an Emergency PackNo
Summary

0037796: Cannot select a product with stock in Work effort and Production Run windows

DescriptionCannot select a product with stock in Work effort and Production Run windows
Steps To ReproduceAs group admin role:
   Create a product
   Set it as production
   Add an attribute set to it
   Create a goods receipt, add that product in two lines (with a different attribute set value each) set and complete it

   Create a Process Plan in which the process is consumed
   Create the Work Requirement and a work effort from it
   Go to Work Effort - Production Run - Product tab and open the Product selector (in order to select the other attribute set value)
   Clear the filter in order to show the products with stock
   Check the products with stock do not appear
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00378003.0PR18Q1 closeddmiguelez Cannot select a product with stock in Work effort and Production Run windows 
depends on backport 00378013.0PR17Q4.1 closedTriage Finance Cannot select a product with stock in Work effort and Production Run windows 
caused by defect 0036008 closedcollazoandy4 It is possible to add not production products in work efforts 

-  Notes
(0102123)
collazoandy4 (developer)
2018-02-01 19:00

Test Plan
As group admin role:
  Go to Product window and create a new record:
    Search Key/Name: ProductionProduct
    Production: Y
    Attribute Set: Lote
  Go to Goods Receipt window and create a new record:
    Business Partner: Bebidas Alegres, S.L.
    Create two records in Lines tab:
      1. Product: ProductionProduct, Attribute Set Value: 111, Movement quantity: 10
      2. Product: ProductionProduct, Attribute Set Value: 222, Movement quantity: 20
    Complete the Receipt
  Go to Manufacturing Cost Center and create a new record:
    Search Key/Name: Cost Center
    Create a new record in Version tab:
      Valid From Date: Today
  Go to Activity window and create a new record:
    Search Key/Name: Activity
    Cost Center: Cost Center
  Go to Process Plan window and create a new record:
    Search Key/Name: ProcessPlan
    Create a new record in Version Tab:
      Starting Date: Today
      Ending Date: Last Day of Month
      Create a new record in Operation tab:
        Search Key/Name: Operation
        Activity: Activity
  Go to Work Requirement window and create a new record:
    Process Plan: ProcessPlan
    Starting Date: Today
      Ending Date: Last Day of Month
      Quantity: 10
      Process the requirement
    Clic on Create a Work Effort button
      Date: Today
  Go to Work Effort window and select the previous one created:
    Create a new record in Product tab under Production Run tab and check that you can select the previous product created with stock in the product selector
  Go to Production Run and select the previous record created:
    Create a new record in Product tab and check that you can select the previous product created with stock in the product selector
(0102137)
hgbot (developer)
2018-02-02 09:25

Repository: erp/devel/pi
Changeset: b45167e7c675058c638998dd67bf8572d195e399
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Thu Feb 01 12:16:41 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/b45167e7c675058c638998dd67bf8572d195e399 [^]

Fixes Issue 37796. Selector for Product in Work Effort and Production Run Windows
does not filter Products by non stocked. It is possible to select a product
regardless of having stock of it. If there is stock, it is possible to select
the specific stock.

---
M src-db/database/sourcedata/OBUISEL_SELECTOR.xml
---
(0102141)
dmiguelez (developer)
2018-02-02 09:34

Code Review + Testing Ok
(0102710)
hudsonbot (developer)
2018-02-22 18:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/980a6ad5bbf5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-01-31 17:47 ngarcia New Issue
2018-01-31 17:47 ngarcia Assigned To => Triage Finance
2018-01-31 17:47 ngarcia Modules => Core
2018-01-31 17:47 ngarcia Triggers an Emergency Pack => No
2018-01-31 17:48 ngarcia Relationship added caused by 0036008
2018-01-31 17:48 ngarcia Issue Monitored: ngarcia
2018-02-01 12:11 dmiguelez Regression level => Production - Confirmed Stable
2018-02-01 12:11 dmiguelez Regression date => 2017-05-31
2018-02-01 12:11 dmiguelez Regression introduced in release => 3.0PR17Q3
2018-02-01 12:11 dmiguelez Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/bd09a9d5ffa8f7b2dce0cb634b14aef05c67270f [^]
2018-02-01 12:11 dmiguelez Status new => scheduled
2018-02-01 12:11 dmiguelez Assigned To Triage Finance => dmiguelez
2018-02-01 19:00 collazoandy4 Note Added: 0102123
2018-02-02 09:25 hgbot Checkin
2018-02-02 09:25 hgbot Note Added: 0102137
2018-02-02 09:25 hgbot Status scheduled => resolved
2018-02-02 09:25 hgbot Resolution open => fixed
2018-02-02 09:25 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b45167e7c675058c638998dd67bf8572d195e399 [^]
2018-02-02 09:34 dmiguelez Review Assigned To => dmiguelez
2018-02-02 09:34 dmiguelez Note Added: 0102141
2018-02-02 09:34 dmiguelez Status resolved => closed
2018-02-02 09:34 dmiguelez Fixed in Version => 3.0PR18Q2
2018-02-22 18:18 hudsonbot Checkin
2018-02-22 18:18 hudsonbot Note Added: 0102710


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker