Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037676
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 08. Project and service managementmajoralways2018-01-19 10:002018-02-22 18:18
ReportermaiteView Statuspublic 
Assigned Todmiguelez 
PriorityimmediateResolutionfixedFixed in Version
StatusclosedFix in branchFixed in SCM revisionb39a4d259c57
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2017-08-04
Regression introduced in release3.0PR17Q4
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/2ab8016a2353 [^]
Triggers an Emergency PackNo
Summary

0037676: "Project Phase" field does not show any value (although Project is selected) in Expense Sheet window

DescriptionUser is not able to set "Project Phase" value in Expense Sheet Line window after setting "Project" value
Steps To Reproduce1. Create new Multiphase Project and add any Project Phase in the tab
2. Create new Expense Sheet, Save header and create new Line. Set previous project and realize that phase is not shown in "Project Phase" when clicking in the combo
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00377153.0PR17Q4.1 closeddmiguelez "Project Phase" field does not show any value (although Project is selected) in Expense Sheet window 
depends on backport 00377173.0PR18Q1 closeddmiguelez "Project Phase" field does not show any value (although Project is selected) in Expense Sheet window 
caused by design defect 0036067 closedmarkmm82 old callouts should be refactored to implement SimpleCallout 

-  Notes
(0101918)
nonofrancisco (developer)
2018-01-23 17:50

Test Plan:

1. Create new Multiphase Project and add any Project Phase and Tasks in subsequent tabs.
2. Create new Expense Sheet, Save header and create new Line.
3.- Set previous project and realize that phase is shown in "Project Phase" when clicking in the combo
4.- Select the Project Phase and realize the Task in shown in combo
(0101921)
hgbot (developer)
2018-01-24 13:11

Repository: erp/devel/pi
Changeset: b39a4d259c575aa3f264d815d78fea7d5b429905
Author: Nono Carballo <nonofce <at> gmail.com>
Date: Wed Jan 24 13:09:52 2018 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/b39a4d259c575aa3f264d815d78fea7d5b429905 [^]

Fixes issue 37676: "Project Phase" field does not show any value
(although Project is selected) in Expense Sheet window

In callouts, for fields representing Ids, an empty string is returned instead
of null.

---
M src/org/openbravo/erpCommon/ad_callouts/SE_Expense_BP_Project.java
M src/org/openbravo/erpCommon/ad_callouts/SE_InOut_Organization.java
M src/org/openbravo/erpCommon/ad_callouts/SE_Invoice_BPartner.java
M src/org/openbravo/erpCommon/ad_callouts/SE_Order_BPartner.java
M src/org/openbravo/erpCommon/ad_callouts/SE_Order_Organization.java
M src/org/openbravo/erpCommon/ad_callouts/SE_Project_BPartner.java
M src/org/openbravo/erpCommon/ad_callouts/SE_Trxtype_Transaction.java
M src/org/openbravo/erpCommon/ad_callouts/SL_GlobalUse_Product.java
M src/org/openbravo/erpCommon/ad_callouts/SL_InOutLine_Product.java
M src/org/openbravo/erpCommon/ad_callouts/SL_InOut_BPartner.java
M src/org/openbravo/erpCommon/ad_callouts/SL_Internal_Consumption_Conversion.java
M src/org/openbravo/erpCommon/ad_callouts/SL_Internal_Consumption_Product.java
M src/org/openbravo/erpCommon/ad_callouts/SL_InvAmtUpd_ProductRefDate.java
M src/org/openbravo/erpCommon/ad_callouts/SL_Inventory_Product.java
M src/org/openbravo/erpCommon/ad_callouts/SL_Invoice_DocType.java
M src/org/openbravo/erpCommon/ad_callouts/SL_Invoice_Product.java
M src/org/openbravo/erpCommon/ad_callouts/SL_Journal_MultiAcctSchema.java
M src/org/openbravo/erpCommon/ad_callouts/SL_Movement_Product.java
M src/org/openbravo/erpCommon/ad_callouts/SL_Order_DocType.java
M src/org/openbravo/erpCommon/ad_callouts/SL_Order_Product.java
M src/org/openbravo/erpCommon/ad_callouts/SL_Production_Product.java
M src/org/openbravo/erpCommon/ad_callouts/SL_RefreshSequenceAndLength.java
M src/org/openbravo/erpCommon/ad_callouts/SL_RequisitionLine_Product.java
M src/org/openbravo/erpCommon/ad_callouts/SL_SequenceProduct_Product.java
---
(0101922)
dmiguelez (developer)
2018-01-24 13:13

Code Review + Testing Ok
(0101928)
dmiguelez (developer)
2018-01-24 16:35

Reopened to create backports.
(0102683)
hudsonbot (developer)
2018-02-22 18:18

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/980a6ad5bbf5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2018-01-19 10:00 maite New Issue
2018-01-19 10:00 maite Assigned To => Triage Finance
2018-01-19 10:00 maite Modules => Core
2018-01-19 10:00 maite Triggers an Emergency Pack => No
2018-01-19 10:00 maite Issue Monitored: networkb
2018-01-22 16:33 nonofrancisco Assigned To Triage Finance => nonofrancisco
2018-01-22 16:35 nonofrancisco Status new => scheduled
2018-01-23 17:50 nonofrancisco Note Added: 0101918
2018-01-24 13:11 hgbot Checkin
2018-01-24 13:11 hgbot Note Added: 0101921
2018-01-24 13:11 hgbot Status scheduled => resolved
2018-01-24 13:11 hgbot Resolution open => fixed
2018-01-24 13:11 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/b39a4d259c575aa3f264d815d78fea7d5b429905 [^]
2018-01-24 13:13 dmiguelez Review Assigned To => dmiguelez
2018-01-24 13:13 dmiguelez Note Added: 0101922
2018-01-24 13:13 dmiguelez Status resolved => closed
2018-01-24 13:13 dmiguelez Fixed in Version => 3.0PR18Q2
2018-01-24 16:32 dmiguelez Regression level => Production - Confirmed Stable
2018-01-24 16:32 dmiguelez Regression date => 2017-08-04
2018-01-24 16:32 dmiguelez Regression introduced in release => 3.0PR17Q3
2018-01-24 16:32 dmiguelez Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/2ab8016a2353 [^]
2018-01-24 16:35 dmiguelez Assigned To nonofrancisco => dmiguelez
2018-01-24 16:35 dmiguelez Note Added: 0101928
2018-01-24 16:35 dmiguelez Status closed => new
2018-01-24 16:35 dmiguelez Resolution fixed => open
2018-01-24 16:35 dmiguelez Fixed in Version 3.0PR18Q2 =>
2018-01-24 16:35 dmiguelez Status new => scheduled
2018-01-24 16:35 dmiguelez Status scheduled => resolved
2018-01-24 16:35 dmiguelez Fixed in Version => 3.0PR18Q2
2018-01-24 16:35 dmiguelez Resolution open => fixed
2018-01-24 16:36 dmiguelez Status resolved => closed
2018-01-24 16:54 dmiguelez Regression level Production - Confirmed Stable => Production - QA Approved
2018-01-24 16:54 dmiguelez Regression introduced in release 3.0PR17Q3 => 3.0PR17Q4
2018-01-24 16:55 dmiguelez Relationship added caused by 0036067
2018-01-24 16:57 dmiguelez Status closed => new
2018-01-24 16:57 dmiguelez Resolution fixed => open
2018-01-24 16:57 dmiguelez Fixed in Version 3.0PR18Q2 =>
2018-01-24 16:57 dmiguelez Status new => scheduled
2018-01-24 16:57 dmiguelez Status scheduled => resolved
2018-01-24 16:57 dmiguelez Resolution open => fixed
2018-01-24 16:57 dmiguelez Status resolved => closed
2018-02-22 18:18 hudsonbot Checkin
2018-02-22 18:18 hudsonbot Note Added: 0102683


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker