Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037572
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Retail Modules] Web POSmajoralways2017-12-13 15:552018-01-25 13:32
ReporterjorgewederagoView Statuspublic 
Assigned Toranjith_qualiantech_com 
PriorityurgentResolutionfixedFixed in VersionRR17Q4.1
StatusclosedFix in branchFixed in SCM revision9c522af47c34
ProjectionnoneETAnoneTarget VersionRR17Q4.1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toguilleaer
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037572: Under certain circumstances when creating a sales order from a quotation wrong data is generated in the backend

DescriptionWhen creating a sales order from a firm quotation, if the price of the product has changed since the quotation was created, after closing the transaction there will be wrong information in the backend. Eg: The line in the sales order will have a discount applied.
Steps To Reproduce1.- Log in into WebPOS
2.- Click the menu button and select Create Quotation
3.- Add a product to the receipt
4.- Finish the Quotation
5.- Go to the backend and change the price of the product
6.- Go back to WebPOS and refresh
7.- Load the quotation if needed, go to the menu and press Create Sales Order
8.- Check Firm Quotation and press Create Sales Order
9.- Finish the transaction
10.- Go to the back end and check in the Sales Order Window the information of the line in the sales order.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0037471 closedrqueralta Under certain circumstances when creating a sales order from a quotation wrong data is generated in the backend 
blocks defect 0037570RR17Q4.1 closedranjith_qualiantech_com Tests LayawayProductsNotInAssortment and QuotationProductsNotInAssortment are failing in Q4 after fix for issue 37558 

-  Notes
(0101304)
guilleaer (developer)
2018-01-03 10:33
edited on: 2018-01-03 10:35

This backport is required because the fix of issue 37471 is needed to fix issue 37570

(0101904)
hgbot (developer)
2018-01-23 12:13

Repository: retail/backports/3.0RR17Q4.1/org.openbravo.retail.posterminal
Changeset: 187c18984f86eed472a28608e13a86a6c8d49909
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Jan 23 16:42:56 2018 +0530
URL: http://code.openbravo.com/retail/backports/3.0RR17Q4.1/org.openbravo.retail.posterminal/rev/187c18984f86eed472a28608e13a86a6c8d49909 [^]

Fixed issue 37572 : Line PriceList should be updated for receipt calculations

---
M web/org.openbravo.retail.posterminal/js/model/order.js
---
(0101907)
hgbot (developer)
2018-01-23 12:19

Repository: retail/backports/3.0RR17Q4.1/org.openbravo.retail.posterminal
Changeset: 9c522af47c3432ebe186974f5012702148f28a3e
Author: Ranjith S R <ranjith <at> qualiantech.com>
Date: Tue Jan 23 16:48:57 2018 +0530
URL: http://code.openbravo.com/retail/backports/3.0RR17Q4.1/org.openbravo.retail.posterminal/rev/9c522af47c3432ebe186974f5012702148f28a3e [^]

Fixed issue 37572 : Line PriceList should be updated for receipt calculations

---
M src/org/openbravo/retail/posterminal/OrderLoader.java
---

- Issue History
Date Modified Username Field Change
2018-01-03 10:29 guilleaer Type defect => backport
2018-01-03 10:29 guilleaer Target Version => RR17Q4.1
2018-01-03 10:30 guilleaer Relationship added blocks 0037570
2018-01-03 10:33 guilleaer Note Added: 0101304
2018-01-03 10:33 guilleaer Note Edited: 0101304 View Revisions
2018-01-03 10:35 guilleaer Note Edited: 0101304 View Revisions
2018-01-03 10:41 guilleaer Assigned To rqueralta => ranjith_qualiantech_com
2018-01-03 10:41 guilleaer Status scheduled => resolved
2018-01-03 10:41 guilleaer Resolution open => fixed
2018-01-03 10:41 guilleaer Status resolved => new
2018-01-03 10:41 guilleaer Resolution fixed => open
2018-01-23 12:12 ranjith_qualiantech_com Status new => scheduled
2018-01-23 12:13 hgbot Checkin
2018-01-23 12:13 hgbot Note Added: 0101904
2018-01-23 12:13 hgbot Status scheduled => resolved
2018-01-23 12:13 hgbot Resolution open => fixed
2018-01-23 12:13 hgbot Fixed in SCM revision http://code.openbravo.com/erp/pmods/org.openbravo.retail.posterminal/rev/9b4b3fab3caac94eaae9ccc0b0d794887287182d [^] => http://code.openbravo.com/retail/backports/3.0RR17Q4.1/org.openbravo.retail.posterminal/rev/187c18984f86eed472a28608e13a86a6c8d49909 [^]
2018-01-23 12:19 hgbot Checkin
2018-01-23 12:19 hgbot Note Added: 0101907
2018-01-23 12:19 hgbot Fixed in SCM revision http://code.openbravo.com/retail/backports/3.0RR17Q4.1/org.openbravo.retail.posterminal/rev/187c18984f86eed472a28608e13a86a6c8d49909 [^] => http://code.openbravo.com/retail/backports/3.0RR17Q4.1/org.openbravo.retail.posterminal/rev/9c522af47c3432ebe186974f5012702148f28a3e [^]
2018-01-25 13:32 guilleaer Status resolved => closed
2018-01-25 13:32 guilleaer Fixed in Version => RR17Q4.1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker