Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037551
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Retail Modules] Mobile Physical Inventorymajoralways2017-12-27 12:092018-01-16 08:41
ReporterngarciaView Statuspublic 
Assigned Tojorge-garcia 
PriorityimmediateResolutionfixedFixed in VersionRR18Q2
StatusclosedFix in branchFixed in SCM revision3470ed405531
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tomarvintm
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037551: Wrong Quantity Count in inventory lines if they are created with Create Inventory Count List process and not edited in mobile

DescriptionWrong Quantity Count in inventory lines if they are created with Create Inventory Count List process and not edited in mobile.

The problem is that the default value in DB for em_obmwhpi_counted column is 'N'

Additional notes after several conversations with the customer:

- Customer has installed the module but he is not using yet the mobile side, so they want to work using the backend
- Before, they generate the list of inventory lines using the process, then they do the count in several lines and for those lines they change the field "counted" so when the Physical Inventory is processed, it works from them.
- Now they can't do it because the field has been hidden
Steps To ReproduceAs group admin role:
   Create an inventory header
   Launch the Create Inventory Count List process
   Select a storage bin, Inventory Quantity = not 0 and Set Book Quantity to Zero = Y
   Check some lines have been added
   Modify its Quantity Count with a value different from the Book Quantity (in order to increase/decrease the stock)

   Process Inventory
   Check Quantity Count has been updated with Book Quantity value, so no changes have been mad on the stock
Proposed SolutionCreate a callout for field quantity count.
When this field is changed in the UI, callout will be executed.
This callout should have a hook which will be implemmented by mobile physical inventory module which will set the field "counted" to yes when this field changes.
This hook should take into account issue 36307.
I also propose to show the field "counted" as a read only field.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0036307 closedebecerra Wrong qty count in physical inventory lines if order quantity and uom fields are filled (2nd UOM) and counted is not selected 

-  Notes
(0101663)
hgbot (developer)
2018-01-11 09:35

Repository: erp/pmods/org.openbravo.mobile.warehouse.physicalinventory
Changeset: 3470ed405531445bdeafc4292856820d9d95ef3a
Author: Jorge Garcia <jorge.garcia <at> openbravo.com>
Date: Thu Jan 11 09:32:22 2018 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.mobile.warehouse.physicalinventory/rev/3470ed405531445bdeafc4292856820d9d95ef3a [^]

Fixed issue 37551: Wrong Quantity Count in inventory lines if they are
created with Create Inventory Count List process and not edited in mobile

EventHandler has been created on update event to set the counted flag to
yes if the quantity booked has changed.

The field counted added by the module no is displayed and it’s a field of
read only.

---
M src-db/database/sourcedata/AD_FIELD.xml
A src/org/openbravo/mobile/warehouse/physicalinventory/eventhandler/MobilePhysicalInventoryLineEventHandler.java
---

- Issue History
Date Modified Username Field Change
2017-12-27 12:09 ngarcia New Issue
2017-12-27 12:09 ngarcia Assigned To => Retail
2017-12-27 12:09 ngarcia Triggers an Emergency Pack => No
2017-12-27 12:09 ngarcia Relationship added caused by 0036307
2017-12-27 12:10 ngarcia Issue Monitored: networkb
2017-12-27 18:27 guilleaer Status new => scheduled
2017-12-27 18:29 guilleaer Note Added: 0101268
2017-12-27 18:29 guilleaer Assigned To Retail => guilleaer
2017-12-27 18:29 guilleaer Status scheduled => feedback
2017-12-28 09:56 ngarcia Status feedback => scheduled
2017-12-29 09:20 guilleaer Status scheduled => resolved
2017-12-29 09:20 guilleaer Resolution open => fixed
2017-12-29 09:20 guilleaer Assigned To guilleaer => Retail
2017-12-29 09:20 guilleaer Status resolved => new
2017-12-29 09:20 guilleaer Resolution fixed => open
2017-12-29 09:36 guilleaer Description Updated View Revisions
2017-12-29 09:36 guilleaer Proposed Solution updated
2018-01-04 16:27 guilleaer Note Deleted: 0101268
2018-01-05 13:43 jorge-garcia Status new => scheduled
2018-01-05 13:43 jorge-garcia Assigned To Retail => jorge-garcia
2018-01-11 09:35 hgbot Checkin
2018-01-11 09:35 hgbot Note Added: 0101663
2018-01-11 09:35 hgbot Status scheduled => resolved
2018-01-11 09:35 hgbot Resolution open => fixed
2018-01-11 09:35 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/pmods/org.openbravo.mobile.warehouse.physicalinventory/rev/3470ed405531445bdeafc4292856820d9d95ef3a [^]
2018-01-16 08:41 marvintm Review Assigned To => marvintm
2018-01-16 08:41 marvintm Status resolved => closed
2018-01-16 08:41 marvintm Fixed in Version => RR18Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker