Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037499
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2017-12-16 18:152018-01-30 13:07
ReportershuehnerView Statuspublic 
Assigned Toshuehner 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q2
StatusclosedFix in branchFixed in SCM revision66c4a0c6f9c1
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037499: Remove unused feature to export ob_version + code_revision into xml files

DescriptionThe EntityXmlConverter has a feature to add 3 attributes to root 'Openbravo'
element of files it is creating (ob-version, ob-revision, created). That is
done by calling addSystemAttributes of the class.

However the rewrite of the xml export done in commit (102ba22a81ca, 2009-02-12)
did stop calling that method.

No other caller of that protectod method can be found in pi or search in
getAllModules.

Apart the only code requesting that optional feature was the dataset xml export
That export later has been switched over to a checksum of the exported content.
    
As that is now dead code since 8 years remove that feature. As that removes the
3 attributes from the export also remove those from the generated XML-Schema
which can be requested via /ws/dal/schema and the constants naming those
attributes from XMLConstants.
Steps To Reproduce-
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on defect 0037770 closedalostale API change: some removals in very old and obsolete code 
related to design defect 0032688 acknowledgedplatform remove unused resources 
blocks feature request 0037500 closedshuehner Stop running 'hg id' during ant tasks (install.source & compilation) 

-  Notes
(0102049)
hgbot (developer)
2018-01-30 13:03

Repository: erp/devel/pi
Changeset: 66c4a0c6f9c127775455a0d330453c0f67e0a7b3
Author: Stefan Hühner <stefan.huehner <at> openbravo.com>
Date: Sat Dec 16 18:26:08 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/66c4a0c6f9c127775455a0d330453c0f67e0a7b3 [^]

Fixed 37499. Remove unused feature to export code_revision to xml files.

EntityXmlConverter has a feature to add 3 attributes to root 'Openbravo'
element of files it is creating (ob-version, ob-revision, crated), by calling
addSystemAttributes method.
However rewrite of the xml export done in commit (102ba22a81ca, 2009-02-12)
stopped calling that method.
No other caller of that protected method can be found in pi or search in
getAllModules today.
Apart even before the only code requesting those attributes was the dataset
xml export. That has been later switched over to checksum for exported content.

As that is now dead code since 8 years remove that unused feature.

---
M src-test/src/org/openbravo/test/xml/EntityXMLImportTestBusinessObject.java
M src-test/src/org/openbravo/test/xml/EntityXMLImportTestSingle.java
M src-test/src/org/openbravo/test/xml/UniqueConstraintImportTest.java
M src-test/src/org/openbravo/test/xml/XMLBaseTest.java
M src/org/openbravo/dal/xml/EntityXMLConverter.java
M src/org/openbravo/dal/xml/ModelXMLConverter.java
M src/org/openbravo/dal/xml/XMLConstants.java
M src/org/openbravo/service/db/DataExportService.java
---
(0102052)
alostale (developer)
2018-01-30 13:07

reviewed

- Issue History
Date Modified Username Field Change
2017-12-16 18:15 shuehner New Issue
2017-12-16 18:15 shuehner Assigned To => platform
2017-12-16 18:15 shuehner Modules => Core
2017-12-16 18:15 shuehner Triggers an Emergency Pack => No
2017-12-16 18:15 shuehner Relationship added related to 0032688
2017-12-16 18:19 shuehner Relationship added blocks 0037500
2018-01-30 12:59 alostale Relationship added depends on 0037770
2018-01-30 13:01 alostale Assigned To platform => shuehner
2018-01-30 13:03 hgbot Checkin
2018-01-30 13:03 hgbot Note Added: 0102049
2018-01-30 13:03 hgbot Status new => resolved
2018-01-30 13:03 hgbot Resolution open => fixed
2018-01-30 13:03 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/66c4a0c6f9c127775455a0d330453c0f67e0a7b3 [^]
2018-01-30 13:07 alostale Review Assigned To => alostale
2018-01-30 13:07 alostale Note Added: 0102052
2018-01-30 13:07 alostale Status resolved => closed
2018-01-30 13:07 alostale Fixed in Version => 3.0PR18Q2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker