Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037481
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Otherstrivialhave not tried2017-12-14 16:152018-03-08 09:31
ReporteralostaleView Statuspublic 
Assigned Toshuehner 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revision04e31d92fefd
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037481: unused PL variables - platform

DescriptionIn the PL code there are many unused variables.
Steps To ReproduceRun pgpgsql-check and check for unused variables.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0037637 closedAugustoMauch Retail Modules Delete unused variables from pl-code 
related to defect 0037482 closedcollazoandy4 Openbravo ERP unused PL variables - functional 
related to defect 0037495 closedshuehner Retail Modules Remove never read variables from pl code 
related to design defect 0038435 acknowledgedplatform Openbravo ERP ad_get_preference_value function shows a warning: record "selpref" is not assigned yet 

-  Notes
(0101040)
hgbot (developer)
2017-12-14 16:23

Repository: erp/devel/pi
Changeset: 09d1efdbd476b0d70cea51e8aa7215370573d508
Author: Stefan Hühner <stefan.huehner <at> openbravo.com>
Date: Thu Dec 14 16:23:30 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/09d1efdbd476b0d70cea51e8aa7215370573d508 [^]

fixed bug 37481: unused PL variables

  Removed unused variables in platform PL code

---
M modules/org.openbravo.client.application/src-db/database/model/triggers/OBUIAPP_UIPERS_MOD_TRG.xml
M modules/org.openbravo.client.myob/src-db/database/model/triggers/OBKMO_WIDGET_REFERENCE_MOD_TRG.xml
M src-db/database/model/functions/AD_COLUMN_IDENTIFIER_REF_SQL.xml
M src-db/database/model/functions/AD_TABLE_IMPORT.xml
M src-db/database/model/functions/AD_TAB_IMPORT.xml
M src-db/database/model/functions/AD_UPDATE_TABLE_IDENTIFIER.xml
M src-db/database/model/triggers/AD_AUXILIARINPUT_MOD_TRG.xml
M src-db/database/model/triggers/AD_CALLOUT_MOD_TRG.xml
M src-db/database/model/triggers/AD_COLUMN_MOD_TRG.xml
M src-db/database/model/triggers/AD_DATASET_MOD_TRG.xml
M src-db/database/model/triggers/AD_ELEMENT_MOD_TRG.xml
M src-db/database/model/triggers/AD_FIELDGROUP_MOD_TRG.xml
M src-db/database/model/triggers/AD_FIELD_MOD_TRG.xml
M src-db/database/model/triggers/AD_FORM_MOD_TRG.xml
M src-db/database/model/triggers/AD_MENU_MOD_TRG.xml
M src-db/database/model/triggers/AD_MESSAGE_MOD_TRG.xml
M src-db/database/model/triggers/AD_MODULE_DBPREFIX_MOD_TRG.xml
M src-db/database/model/triggers/AD_MODULE_DBPREFIX_TRG.xml
M src-db/database/model/triggers/AD_MODULE_DEPENDENCY_MOD_TRG.xml
M src-db/database/model/triggers/AD_PACKAGE_MOD_TRG.xml
M src-db/database/model/triggers/AD_PREFERENCE_MOD_TRG.xml
M src-db/database/model/triggers/AD_PROCESS_GROUP_LIST_MOD_TRG.xml
M src-db/database/model/triggers/AD_PROCESS_GROUP_MOD_TRG.xml
M src-db/database/model/triggers/AD_PROCESS_MOD_TRG.xml
M src-db/database/model/triggers/AD_REFERENCE_MOD_TRG.xml
M src-db/database/model/triggers/AD_REF_SEARCH_COLUMN_MOD_TRG.xml
M src-db/database/model/triggers/AD_REF_SEARCH_MOD_TRG.xml
M src-db/database/model/triggers/AD_REF_TABLE_MOD_TRG.xml
M src-db/database/model/triggers/AD_TABLE_MOD_TRG.xml
M src-db/database/model/triggers/AD_TABLE_NAVIGATION_MOD_TRG.xml
M src-db/database/model/triggers/AD_TAB_MOD_TRG.xml
M src-db/database/model/triggers/AD_TEXTINTERFACES_MOD_TRG.xml
M src-db/database/model/triggers/AD_VAL_RULE_MOD_TRG.xml
M src-db/database/model/triggers/AD_WINDOW_MOD_TRG.xml
---
(0101042)
alostale (developer)
2017-12-14 16:24

reviewed
(0101081)
hgbot (developer)
2017-12-16 13:37

Repository: erp/devel/pi
Changeset: 04e31d92fefd4888ba5d05b187e74b75ea8fb83a
Author: Stefan Hühner <stefan.huehner <at> openbravo.com>
Date: Sat Dec 16 13:36:33 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/04e31d92fefd4888ba5d05b187e74b75ea8fb83a [^]

Fixed 37481. Fix new unused variable warning.

Last commit to this issue accidentally introduced a new unused variable
warning as consequence to deleting other unused code. That has been missed in
testing as try did not flag it because of some logic error in the try logic.

---
M src-db/database/model/functions/AD_UPDATE_TABLE_IDENTIFIER.xml
---
(0101525)
hudsonbot (developer)
2018-01-03 12:39

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test
(0103073)
hgbot (developer)
2018-03-08 09:31

Repository: erp/pmods/org.openbravo.externaldata.integration
Changeset: 9ebc6f3fdc439b16159374d62e6903331d57ce86
Author: Stefan Hühner <stefan.huehner <at> openbravo.com
Date: Thu Mar 08 09:22:40 2018 +0100
URL: http://code.openbravo.com/erp/pmods/org.openbravo.externaldata.integration/rev/9ebc6f3fdc439b16159374d62e6903331d57ce86 [^]

related to bug 37481: unused PL variables

  Removed unused variables in EDL

---
M src-db/database/model/triggers/OBEDL_OUTPUT_TYPE_MOD_TRG.xml
M src-db/database/model/triggers/OBEDL_PROCESS_MOD_TRG.xml
---

- Issue History
Date Modified Username Field Change
2017-12-14 16:15 alostale New Issue
2017-12-14 16:15 alostale Assigned To => shuehner
2017-12-14 16:15 alostale Modules => Core
2017-12-14 16:15 alostale Triggers an Emergency Pack => No
2017-12-14 16:16 alostale Issue cloned 0037482
2017-12-14 16:16 alostale Relationship added related to 0037482
2017-12-14 16:23 hgbot Checkin
2017-12-14 16:23 hgbot Note Added: 0101040
2017-12-14 16:23 hgbot Status new => resolved
2017-12-14 16:23 hgbot Resolution open => fixed
2017-12-14 16:23 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/09d1efdbd476b0d70cea51e8aa7215370573d508 [^]
2017-12-14 16:24 alostale Review Assigned To => alostale
2017-12-14 16:24 alostale Note Added: 0101042
2017-12-14 16:24 alostale Status resolved => closed
2017-12-14 16:24 alostale Fixed in Version => 3.0PR18Q1
2017-12-16 13:37 hgbot Checkin
2017-12-16 13:37 hgbot Note Added: 0101081
2017-12-16 13:37 hgbot Status closed => resolved
2017-12-16 13:37 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/09d1efdbd476b0d70cea51e8aa7215370573d508 [^] => http://code.openbravo.com/erp/devel/pi/rev/04e31d92fefd4888ba5d05b187e74b75ea8fb83a [^]
2017-12-16 14:17 shuehner Relationship added related to 0037495
2017-12-19 11:15 alostale Status resolved => closed
2018-01-03 12:39 hudsonbot Checkin
2018-01-03 12:39 hudsonbot Note Added: 0101525
2018-02-20 09:11 alostale Relationship added related to 0037637
2018-03-08 09:31 hgbot Checkin
2018-03-08 09:31 hgbot Note Added: 0103073
2018-04-24 13:23 aferraz Relationship added related to 0038435


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker