Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037412
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 09. Financial managementmajoralways2017-11-28 17:002017-12-29 13:48
ReporterdmiguelezView Statuspublic 
Assigned Todmiguelez 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revisiond9d9285d3022
ProjectionnoneETAnoneTarget Version
OSLinux 64 bitDatabasePostgreSQLJava version7.x
OS VersionOpenbravo Appliance 14.04Database version9.3.xAnt version1.9.x
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037412: API Change request

DescriptionChange PriceDifferenceProcess.processPriceDifference method to add an extra parameter.

An extra parameter is needed to be able to filter the results by Legal Organization.

If this is not done, Cost Adjustments can be created mixing Organizations that belong to different Legal Entities.

Without this parameter, the calculations are not correct.

API checks failure: https://ci.openbravo.com//job/try-api/5508/ [^]
Steps To ReproduceChange PriceDifferenceProcess.processPriceDifference method to add an extra parameter.

An extra parameter is needed to be able to filter the results by Legal Organization.

If this is not done, Cost Adjustments can be created mixing Organizations that belong to different Legal Entities.

Without this parameter, the calculations are not correct.

API checks failure: https://ci.openbravo.com//job/try-api/5508/ [^]
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0037302 closednonofrancisco Process Price Difference Correction fails with n.p.e. or create wrong Cost Adjustment Documents when it works 

-  Notes
(0100823)
hgbot (developer)
2017-11-30 09:13

Repository: erp/devel/api-checks
Changeset: 69cf83fbda54917a194fb013afb44ab4db100d81
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Thu Nov 30 09:12:29 2017 +0100
URL: http://code.openbravo.com/erp/devel/api-checks/rev/69cf83fbda54917a194fb013afb44ab4db100d81 [^]

Fixes Issue 37412. API Change due to fixing Issue 37302

---
M java/reference/java.japi.gz
---
(0100824)
dmiguelez (developer)
2017-11-30 09:21

Code Review + Testing Ok
(0101290)
hgbot (developer)
2017-12-29 13:46

Repository: erp/devel/api-checks
Changeset: d9d9285d3022fbec70f87812cde98e507a50c063
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Thu Nov 30 09:12:29 2017 +0100
URL: http://code.openbravo.com/erp/devel/api-checks/rev/d9d9285d3022fbec70f87812cde98e507a50c063 [^]

Fixes Issue 37412. API Change due to fixing Issue 37302

---
M java/reference/java.japi.gz
---
(0101292)
vmromanos (developer)
2017-12-29 13:48

Closed again due to repush to api-check

- Issue History
Date Modified Username Field Change
2017-11-28 17:00 dmiguelez New Issue
2017-11-28 17:00 dmiguelez Assigned To => Triage Finance
2017-11-28 17:00 dmiguelez Modules => Core
2017-11-28 17:00 dmiguelez Triggers an Emergency Pack => No
2017-11-28 17:00 dmiguelez Assigned To Triage Finance => dmitry_mezentsev
2017-11-29 12:46 dmitry_mezentsev Tag Attached: Approved
2017-11-29 12:46 dmitry_mezentsev Assigned To dmitry_mezentsev => dmiguelez
2017-11-30 09:13 hgbot Checkin
2017-11-30 09:13 hgbot Note Added: 0100823
2017-11-30 09:13 hgbot Status new => resolved
2017-11-30 09:13 hgbot Resolution open => fixed
2017-11-30 09:13 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/api-checks/rev/69cf83fbda54917a194fb013afb44ab4db100d81 [^]
2017-11-30 09:21 dmiguelez Review Assigned To => dmiguelez
2017-11-30 09:21 dmiguelez Note Added: 0100824
2017-11-30 09:21 dmiguelez Status resolved => closed
2017-11-30 09:21 dmiguelez Fixed in Version => 3.0PR18Q1
2017-12-29 09:47 ngarcia Relationship added related to 0037302
2017-12-29 13:46 hgbot Checkin
2017-12-29 13:46 hgbot Note Added: 0101290
2017-12-29 13:46 hgbot Status closed => resolved
2017-12-29 13:46 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/api-checks/rev/69cf83fbda54917a194fb013afb44ab4db100d81 [^] => http://code.openbravo.com/erp/devel/api-checks/rev/d9d9285d3022fbec70f87812cde98e507a50c063 [^]
2017-12-29 13:48 vmromanos Note Added: 0101292
2017-12-29 13:48 vmromanos Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker