Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037400
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformminoralways2017-11-27 18:232017-12-01 10:07
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityimmediateResolutionfixedFixed in Version3.0PR17Q3.2
StatusclosedFix in branchFixed in SCM revision33b3ef3b9c50
ProjectionnoneETAnoneTarget Version3.0PR17Q3.2
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2017-03-30
Regression introduced in release3.0PR17Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/1f63d7f9e0618c52fa8f9b4fae7d1350782d22d9 [^]
Triggers an Emergency PackNo
Summary

0037400: Duplicated DS Request to the tree datasource having the tree view displayed in a sub-tab

DescriptionDuplicated DS Request to the tree datasource having the tree view displayed in a sub-tab
Steps To Reproduce1) Go to the [Account Tree] window
2) Select a record in the header and move to the "Element Value" sub-tab
3) Switch to the tree view mode
4) Go back to the header and select another record -> Notice that a double call is done for the tree DS (see attached image)
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0037399 closedcaristu Duplicated DS Request to the tree datasource having the tree view displayed in a sub-tab 

-  Notes
(0100747)
hgbot (developer)
2017-11-27 19:23

Repository: erp/backports/3.0PR17Q3.2
Changeset: 33b3ef3b9c50d3d109202b33e560afebfaec8a7d
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Mon Nov 27 19:16:22 2017 +0100
URL: http://code.openbravo.com/erp/backports/3.0PR17Q3.2/rev/33b3ef3b9c50d3d109202b33e560afebfaec8a7d [^]

fixes bug 37400: Duplicated DS calls having the tree view shown in a sub-tab

  Fix for issue 0035545 was intended to force a datasource call when the fetchData does not perform it. This function has a mechanism that avoids DS calls when the grid criteria i not being changed.

  But when the criteria indeed changes two DS request was being fired: the one that we are forcing and the other one fired by the fetchData function. To avoid this problem we are forcing the DS call just when the grid criteria has not changed.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-standard-view.js
---
(0100879)
alostale (developer)
2017-12-01 10:07

reviewed + tested

- Issue History
Date Modified Username Field Change
2017-11-27 18:28 caristu Type defect => backport
2017-11-27 18:28 caristu Target Version => 3.0PR17Q3.2
2017-11-27 19:23 hgbot Checkin
2017-11-27 19:23 hgbot Note Added: 0100747
2017-11-27 19:23 hgbot Status scheduled => resolved
2017-11-27 19:23 hgbot Resolution open => fixed
2017-11-27 19:23 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/backports/3.0PR17Q3.2/rev/33b3ef3b9c50d3d109202b33e560afebfaec8a7d [^]
2017-11-27 19:23 caristu Review Assigned To => alostale
2017-12-01 10:07 alostale Note Added: 0100879
2017-12-01 10:07 alostale Status resolved => closed
2017-12-01 10:07 alostale Fixed in Version => 3.0PR17Q3.2


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker