Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037383
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Z. Othersmajorhave not tried2017-11-24 13:552017-12-29 13:47
ReportervmromanosView Statuspublic 
Assigned Tovmromanos 
PriorityimmediateResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revision1f9a49057800
ProjectionnoneETAnoneTarget Version3.0PR18Q1
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tovmromanos
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037383: API Change request

DescriptionRelated to 0036466

As part of the Copy from Order refactor, we are deleting the old stuff that is not going to be used anymore. This includes: java code, xsql, xml and html.

We have verified that it is not being used by external modules, so the cleanup should be risk-less.
Steps To Reproducehttps://ci.openbravo.com//job/try-api/5520/ [^]

 [checkAPI] 10807 ERROR - +++++++++++++++++++++++++++++++++++++++++++++++++++
 [checkAPI] 10809 ERROR - Errors in API data validation
 [checkAPI] 10812 ERROR - +++++++++++++++++++++++++++++++++++++++++++++++++++
 [checkAPI] 10815 ERROR - Removed row from table AD_MODEL_OBJECT - ID: 801387
 [checkAPI] 10818 ERROR - Removed row from table AD_MODEL_OBJECT_MAPPING - ID: 802082
 [checkAPI] 10820 ERROR - Removed row from table AD_PROCESS - ID: 800165


org.openbravo.erpCommon.ad_actionButton:
Missing
class org.openbravo.erpCommon.ad_actionButton.CopyFromPOOrder: missing in /srv/ci/workspace/try-full-pgsql/SANDBOX/api-checks/output/java
TagsApproved
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks design defect 0036466 closedmarkmm82 "Copy from order" process not compatible with high volumes 

-  Notes
(0100780)
hgbot (developer)
2017-11-28 11:43

Repository: erp/devel/api-checks
Changeset: 8d2fd9fde3e22636b32da21a89812d808615ff51
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Tue Nov 28 11:26:21 2017 +0100
URL: http://code.openbravo.com/erp/devel/api-checks/rev/8d2fd9fde3e22636b32da21a89812d808615ff51 [^]

Fixed 37383: API Change Copy From Orders refactor

Deleted old stuff related to Copy From Order not used anymore:
 class org.openbravo.erpCommon.ad_actionButton.CopyFromPOOrder
 Removed row from table AD_MODEL_OBJECT - ID: 801387
 Removed row from table AD_MODEL_OBJECT_MAPPING - ID: 802082
 Removed row from table AD_PROCESS - ID: 800165

---
M java/reference/java.japi.gz
M model/src-db/database/sourcedata/AD_MODEL_OBJECT.xml
M model/src-db/database/sourcedata/AD_MODEL_OBJECT_MAPPING.xml
M model/src-db/database/sourcedata/AD_PROCESS.xml
---
(0100783)
hgbot (developer)
2017-11-28 12:24

Repository: erp/devel/api-checks
Changeset: 275120831829fa2db551c1a55f7c3b2535436bb0
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Tue Nov 28 12:23:38 2017 +0100
URL: http://code.openbravo.com/erp/devel/api-checks/rev/275120831829fa2db551c1a55f7c3b2535436bb0 [^]

Related to issue 37383: commit right java.japi.gz file

---
M java/reference/java.japi.gz
---
(0100790)
vmromanos (developer)
2017-11-28 16:49

CI successfully passed http://ci.openbravo.com/job/int-api/3183/ [^]
(0101287)
hgbot (developer)
2017-12-29 13:46

Repository: erp/devel/api-checks
Changeset: 1f9a49057800a9692bfa095af0b33d7cdb667d1f
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Tue Nov 28 11:26:21 2017 +0100
URL: http://code.openbravo.com/erp/devel/api-checks/rev/1f9a49057800a9692bfa095af0b33d7cdb667d1f [^]

Fixed 37383: API Change Copy From Orders refactor

Deleted old stuff related to Copy From Order not used anymore:
 class org.openbravo.erpCommon.ad_actionButton.CopyFromPOOrder
 Removed row from table AD_MODEL_OBJECT - ID: 801387
 Removed row from table AD_MODEL_OBJECT_MAPPING - ID: 802082
 Removed row from table AD_PROCESS - ID: 800165

---
M java/reference/java.japi.gz
M model/src-db/database/sourcedata/AD_MODEL_OBJECT.xml
M model/src-db/database/sourcedata/AD_MODEL_OBJECT_MAPPING.xml
M model/src-db/database/sourcedata/AD_PROCESS.xml
---
(0101288)
hgbot (developer)
2017-12-29 13:46

Repository: erp/devel/api-checks
Changeset: 30b5085741343f43fe02565bcf1ecc9782d79ee3
Author: Víctor Martínez Romanos <victor.martinez <at> openbravo.com>
Date: Tue Nov 28 12:23:38 2017 +0100
URL: http://code.openbravo.com/erp/devel/api-checks/rev/30b5085741343f43fe02565bcf1ecc9782d79ee3 [^]

Related to issue 37383: commit right java.japi.gz file

---
M java/reference/java.japi.gz
---
(0101291)
vmromanos (developer)
2017-12-29 13:47

Closed again due to repush to api-check

- Issue History
Date Modified Username Field Change
2017-11-24 13:55 vmromanos New Issue
2017-11-24 13:55 vmromanos Assigned To => dmitry_mezentsev
2017-11-24 13:55 vmromanos Modules => Core
2017-11-24 13:55 vmromanos Triggers an Emergency Pack => No
2017-11-24 13:55 vmromanos Issue generated from 0036362
2017-11-24 13:56 vmromanos Relationship added blocks 0036466
2017-11-24 14:20 dmitry_mezentsev Tag Attached: Approved
2017-11-24 14:20 dmitry_mezentsev Assigned To dmitry_mezentsev => vmromanos
2017-11-28 11:24 vmromanos Status new => scheduled
2017-11-28 11:43 hgbot Checkin
2017-11-28 11:43 hgbot Note Added: 0100780
2017-11-28 11:43 hgbot Status scheduled => resolved
2017-11-28 11:43 hgbot Resolution open => fixed
2017-11-28 11:43 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/api-checks/rev/8d2fd9fde3e22636b32da21a89812d808615ff51 [^]
2017-11-28 12:24 hgbot Checkin
2017-11-28 12:24 hgbot Note Added: 0100783
2017-11-28 16:49 vmromanos Review Assigned To => vmromanos
2017-11-28 16:49 vmromanos Note Added: 0100790
2017-11-28 16:49 vmromanos Status resolved => closed
2017-11-28 16:49 vmromanos Fixed in Version => 3.0PR18Q1
2017-12-29 13:46 hgbot Checkin
2017-12-29 13:46 hgbot Note Added: 0101287
2017-12-29 13:46 hgbot Status closed => resolved
2017-12-29 13:46 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/api-checks/rev/8d2fd9fde3e22636b32da21a89812d808615ff51 [^] => http://code.openbravo.com/erp/devel/api-checks/rev/1f9a49057800a9692bfa095af0b33d7cdb667d1f [^]
2017-12-29 13:46 hgbot Checkin
2017-12-29 13:46 hgbot Note Added: 0101288
2017-12-29 13:47 vmromanos Note Added: 0101291
2017-12-29 13:47 vmromanos Status resolved => closed


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker