Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037269
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2017-11-09 12:542018-01-03 12:38
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revisionec01f8d026a7
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037269: The title of the tab showing the HTML output of a Process Definition report is not translated

DescriptionThe title of the tab showing the HTML output of a Process Definition report is not translated
Steps To Reproduce1) Install any translation pack
2) Switch to the language of the translation pack
3) Open the [Purchase Order Report]
4) Click on the "View" button in order to generate the HTML report
5) Notice that the tab where the report result is shown is not translated to the context language (see attached image)
TagsNo tags attached.
Attached Filespng file icon tabTitleNotTranslated.png [^] (33,115 bytes) 2017-11-09 12:55

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0028947 closednonofrancisco Add HTML output to Process Definition reports 

-  Notes
(0100381)
hgbot (developer)
2017-11-09 13:13

Repository: erp/devel/pi
Changeset: e8bfaf3a4bfab1f2723e47783c688dc59cd3fad0
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Nov 09 13:02:25 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/e8bfaf3a4bfab1f2723e47783c688dc59cd3fad0 [^]

related to issue 37269: removed unused variable

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/utilities/ob-utilities-action-def.js
---
(0100382)
hgbot (developer)
2017-11-09 13:13

Repository: erp/devel/pi
Changeset: ec01f8d026a7f4e10038ac1253ff12e2c8f2a515
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Nov 09 13:05:49 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/ec01f8d026a7f4e10038ac1253ff12e2c8f2a515 [^]

fixes issue 37269: Ability of translating the title of the report result tab

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/report/BaseReportActionHandler.java
---
(0100383)
hgbot (developer)
2017-11-09 13:27

Repository: erp/devel/pi
Changeset: 1a030604a4ffdf39e1e74c04646c765088b0e3f4
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Thu Nov 09 13:27:01 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/1a030604a4ffdf39e1e74c04646c765088b0e3f4 [^]

related to issue 37269: Do not need to limit the query results

  Is not necessary to limit the query results because the obuiapp_process_trl has a unique constraint based in the obuiapp_process_id and ad_language columns

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/report/BaseReportActionHandler.java
---
(0100446)
hgbot (developer)
2017-11-10 14:33

Repository: erp/devel/pi
Changeset: 0b295f9266835639195e0538f1b9dff861dd63e6
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Nov 10 14:32:10 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/0b295f9266835639195e0538f1b9dff861dd63e6 [^]

related to issue 37269: use BaseOBObject API to retrieve the translated name

---
M modules/org.openbravo.client.application/src/org/openbravo/client/application/report/BaseReportActionHandler.java
---
(0100540)
alostale (developer)
2017-11-16 08:51

reviewed + tested
(0101392)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test
(0101393)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test
(0101394)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test
(0101411)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-11-09 12:54 caristu New Issue
2017-11-09 12:54 caristu Assigned To => platform
2017-11-09 12:54 caristu File Added: tabTitleNotTranslated.png
2017-11-09 12:54 caristu Modules => Core
2017-11-09 12:54 caristu Triggers an Emergency Pack => No
2017-11-09 12:54 caristu File Deleted: tabTitleNotTranslated.png
2017-11-09 12:55 caristu File Added: tabTitleNotTranslated.png
2017-11-09 12:55 caristu Relationship added related to 0028947
2017-11-09 12:59 caristu Assigned To platform => caristu
2017-11-09 13:13 hgbot Checkin
2017-11-09 13:13 hgbot Note Added: 0100381
2017-11-09 13:13 hgbot Checkin
2017-11-09 13:13 hgbot Note Added: 0100382
2017-11-09 13:13 hgbot Status new => resolved
2017-11-09 13:13 hgbot Resolution open => fixed
2017-11-09 13:13 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/ec01f8d026a7f4e10038ac1253ff12e2c8f2a515 [^]
2017-11-09 13:27 hgbot Checkin
2017-11-09 13:27 hgbot Note Added: 0100383
2017-11-09 13:49 caristu Review Assigned To => alostale
2017-11-10 14:33 hgbot Checkin
2017-11-10 14:33 hgbot Note Added: 0100446
2017-11-16 08:51 alostale Note Added: 0100540
2017-11-16 08:51 alostale Status resolved => closed
2017-11-16 08:51 alostale Fixed in Version => 3.0PR18Q1
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101392
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101393
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101394
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101411


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker