Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037255
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminoralways2017-11-08 08:452018-01-03 12:38
ReportercaristuView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revision7f4ca5834b80
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037255: Wrong behavior when filtering in tree grid view of a child tab and pressing 'Enter' key to confirm the filter

DescriptionThe record disappears on the grid tree view of a child tab when applying a filter in a drop down and pressing the 'Enter' key to confirm.
Steps To Reproduce1) Open [Product Characteristic] window
2) Create a record in the header
3) Move to the [Value] subtab
  3a) Create a summary level value
  3b) Create a non summary level value
4) Switch to 'tree grid view' (press the button on the toolbar)
5) Drag and drop the non-summary level value as child of the summary level value
6) Filter by 'Name' to show the child value. Then press 'Enter' key (do not press any other key). Note that the tree is collapsed.
Proposed SolutionThe problem is that fix for issue 0037181 does not cover the case of trees displayed in subtabs because of the fact that the filtering criteria in those cases includes the id of the parent record.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0037181 closedcaristu Wrong behavior when filtering in tree grid view and pressing 'Enter' key to confirm the filter 

-  Notes
(0100330)
hgbot (developer)
2017-11-08 09:14

Repository: erp/devel/pi
Changeset: 7f4ca5834b80791b3e668feb4a94c887d41daeaf
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Nov 08 08:52:55 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/7f4ca5834b80791b3e668feb4a94c887d41daeaf [^]

fixes bug 37255: Tree in subtab is closed after pressing 'Enter' key to filter

Being on a child tab, the fix for issue 0037181 was not complete because it was comparing the entered criteria without including the criterion with the parent record id. Thus when comparing the current criteria and the entered criteria they were always different.

Now we are completing the fix by converting the entered criteria in order to include the filtering criterion by parent id.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-tree-grid.js
---
(0100331)
hgbot (developer)
2017-11-08 09:26

Repository: erp/devel/pi
Changeset: 8cb4ac05194f9dd9c2f914cc6dea814353d7ea1c
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Wed Nov 08 09:24:36 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/8cb4ac05194f9dd9c2f914cc6dea814353d7ea1c [^]

related to issue 37255: Do not call convertCriteria twice

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/grid/ob-tree-grid.js
---
(0100444)
alostale (developer)
2017-11-10 13:33

reviewed + tested
(0101379)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test
(0101380)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-11-08 08:45 caristu New Issue
2017-11-08 08:45 caristu Assigned To => caristu
2017-11-08 08:45 caristu Modules => Core
2017-11-08 08:45 caristu Triggers an Emergency Pack => No
2017-11-08 08:45 caristu Issue generated from 0037181
2017-11-08 08:45 caristu Description Updated View Revisions
2017-11-08 08:47 caristu Proposed Solution updated
2017-11-08 08:47 caristu Relationship added related to 0037181
2017-11-08 09:14 hgbot Checkin
2017-11-08 09:14 hgbot Note Added: 0100330
2017-11-08 09:14 hgbot Status new => resolved
2017-11-08 09:14 hgbot Resolution open => fixed
2017-11-08 09:14 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/7f4ca5834b80791b3e668feb4a94c887d41daeaf [^]
2017-11-08 09:26 hgbot Checkin
2017-11-08 09:26 hgbot Note Added: 0100331
2017-11-08 16:14 caristu Review Assigned To => alostale
2017-11-10 13:33 alostale Note Added: 0100444
2017-11-10 13:33 alostale Status resolved => closed
2017-11-10 13:33 alostale Fixed in Version => 3.0PR18Q1
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101379
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101380


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker