Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037153
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 02. Master data managementminoralways2017-10-24 11:452018-01-03 12:38
ReporterAtulOpenbravoView Statuspublic 
Assigned Tocaristu 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revisionc0e3b9890211
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037153: Characteristics Configuration tab display logic does not work properly

DescriptionCharacteristics Configuration tab appears before selecting any of the product. in the product window. After selecting product, tab name disappears but the tab still exists user can select the tab and enter the characteristics configuration.
Steps To Reproduce- Navigate to "Product" window.
- Without selecting any product from the list click on "Characteristics" tab and verify that "Characteristic Configuration" tab appears below.
- This is Ok.
- Select product "Cerveza Ale 0,5L" from the "Product" tab list.
- Realize that "Characteristic Configuration" tab disappears below.
- Realize that Generic flag is set as No.
- Navigate to Characteristics Tab. Double click on this tab.
- Realize that only the "Characteristic Configuration" name is not seen on the tab. But the tab exists.
- Double click on below tab without name.
- Realize that Characteristic configuration grid view appears.

This is not correct. It seems that display logic on the tab only hides the tab name instead of entire tab.

Attached screen shots for reference.
TagsNo tags attached.
Attached Filespng file icon Issue37153_1.png [^] (77,013 bytes) 2017-10-26 10:45


png file icon Issue37153_2.png [^] (62,925 bytes) 2017-10-26 10:46

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0037137 closedAtulOpenbravo Modules Intrastat breaks Products window 
related to feature request 00052023.0MP19 closedAugustoMauch Openbravo ERP Implement display logic for tabs [No new BOM creation possible] 

-  Notes
(0100089)
hgbot (developer)
2017-10-27 08:32

Repository: erp/devel/pi
Changeset: c0e3b98902110b79be7f7588240f986e0beecace
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Fri Oct 27 08:26:19 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/c0e3b98902110b79be7f7588240f986e0beecace [^]

fixes bug 37153: Do not show tab sets when they have all of its tabs hidden

When double-clicking on a tab, its child tab set was always being shown. In case all the tabs in the child tab set were hidden (because of their respective display logics), then the child tab set was being displayed empty.

To prevent this error, now in that case, the child tab set is displayed when any of its tabs should be visible. Otherwise, the child tab set will not be displayed.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-tab.js
---
(0100095)
hgbot (developer)
2017-10-27 10:27

Repository: erp/devel/pi
Changeset: e84582858b866a30c32e717a3dcdf9b837f0fe1f
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Fri Oct 27 10:26:59 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/e84582858b866a30c32e717a3dcdf9b837f0fe1f [^]

related to bug 37153: removed unneded if nesting

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/main/ob-tab.js
---
(0100096)
alostale (developer)
2017-10-27 10:28

reviewed

tested from grid and form views
(0101349)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test
(0101350)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-10-24 11:45 AtulOpenbravo New Issue
2017-10-24 11:45 AtulOpenbravo Assigned To => Triage Finance
2017-10-24 11:45 AtulOpenbravo Modules => Core
2017-10-24 11:45 AtulOpenbravo Triggers an Emergency Pack => No
2017-10-24 11:45 AtulOpenbravo Relationship added related to 0037137
2017-10-24 12:07 AtulOpenbravo Summary Characteristics Configuration tab disappears after selecting product in the product window => Characteristics Configuration tab display logic does not work properly
2017-10-24 12:07 AtulOpenbravo Description Updated View Revisions
2017-10-24 12:07 AtulOpenbravo Steps to Reproduce Updated View Revisions
2017-10-24 12:09 AtulOpenbravo Steps to Reproduce Updated View Revisions
2017-10-24 13:50 rbianchini Issue Monitored: szapata
2017-10-26 10:45 AtulOpenbravo Assigned To Triage Finance => platform
2017-10-26 10:45 AtulOpenbravo Steps to Reproduce Updated View Revisions
2017-10-26 10:45 AtulOpenbravo File Added: Issue37153_1.png
2017-10-26 10:46 AtulOpenbravo File Added: Issue37153_2.png
2017-10-26 17:47 caristu Assigned To platform => caristu
2017-10-26 17:47 caristu Status new => acknowledged
2017-10-26 17:47 caristu Status acknowledged => scheduled
2017-10-27 08:32 hgbot Checkin
2017-10-27 08:32 hgbot Note Added: 0100089
2017-10-27 08:32 hgbot Status scheduled => resolved
2017-10-27 08:32 hgbot Resolution open => fixed
2017-10-27 08:32 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/c0e3b98902110b79be7f7588240f986e0beecace [^]
2017-10-27 08:32 caristu Review Assigned To => alostale
2017-10-27 10:21 alostale Relationship added related to 0005202
2017-10-27 10:27 hgbot Checkin
2017-10-27 10:27 hgbot Note Added: 0100095
2017-10-27 10:28 alostale Note Added: 0100096
2017-10-27 10:28 alostale Status resolved => closed
2017-10-27 10:28 alostale Fixed in Version => 3.0PR18Q1
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101349
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101350


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker