Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037119
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] 03. Procurement managementmajoralways2017-10-19 17:092018-01-08 18:21
ReportermaiteView Statuspublic 
Assigned Tononofrancisco 
PriorityimmediateResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revision34517e931d71
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Todmiguelez
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2016-10-13
Regression introduced in release3.0PR17Q1
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/9ec41af386ae [^]
Triggers an Emergency PackNo
Summary

0037119: "Copy Lines" process not properly copying "organization" dimension when defined at invoice line level

Description"Copy lines" process is properly copying another accounting dimensions defined at line level, such as Cost Center, but it nos properly copying Organization accounting dimension
Steps To Reproduce0. Access "Client" window and set "Organization" as "Show in lines" and "Cost Center" as "Show in lines"
1. Access Dimensions tab, filter by "AR Invoice" and "AP Invoice" and set "Organization" as "Show in lines"
2. Access Cost Center window and define 2 records: cc1 and cc2
3. Define Conversion rate between EUR and USD for toda's date
4. Logout and login again
5. Create new Purchase Invoice for "España" organization and today's date
6. Add line for any product, set Organization dimension "España norte" and Cost Center "a"
7. Add line for any other product, set Organization dimension "España sur" and Cost Center "b". Process invoice
8. Create new Purchase Invoice for "España" organization and today's date. Run "Copy lines" and select previous invoice

Realize that Cost Center information has been correctly copied but NOT Organization information
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00371203.0PR17Q4 closednonofrancisco "Copy Lines" process not properly copying "organization" dimension when defined at invoice line level 
depends on backport 00371213.0PR17Q3.1 closednonofrancisco "Copy Lines" process not properly copying "organization" dimension when defined at invoice line level 
depends on backport 00371223.0PR17Q2.4 closednonofrancisco "Copy Lines" process not properly copying "organization" dimension when defined at invoice line level 
caused by defect 0034195 closedmarkmm82 Error using copy lines in sales invoice 

-  Notes
(0099972)
nonofrancisco (developer)
2017-10-19 21:51

Test Plan

0. Access "Client" window and set "Organization" as "Show in lines" and "Cost Center" as "Show in lines"
1. Access Dimensions tab, filter by "AR Invoice" and "AP Invoice" and set "Organization" as "Show in lines"
2. Access Cost Center window and define 2 records: cc1 and cc2
3. Define Conversion rate between EUR and USD for toda's date
4. Logout and login again
5. Create new Purchase Invoice for "España" organization and today's date, for Bebidas Alegres S.L
6. Add line for Cerveza Ale, set Organization dimension "España norte" and Cost Center "cc1"
7. Add line for Vino Tinto , set Organization dimension "España sur" and Cost Center "cc2". Process invoice
8. Create new Purchase Invoice for "España" organization and today's date. Run "Copy lines" and select previous invoice

Realize that Line for Cerveza Ale has Organization dimension set to "España norte" and Cost Center "cc1"
Realize that Line for Vino Tinto has Organization dimension set to "España sur" and Cost Center "cc2"
(0100035)
hgbot (developer)
2017-10-24 16:21

Repository: erp/devel/pi
Changeset: 34517e931d716616241929f25b708370b290e55c
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Tue Oct 24 10:15:35 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/34517e931d716616241929f25b708370b290e55c [^]

Fixes Issue 37119. Sets correct Organization in new Invoice line

* If the organization of the original invoice line belongs to the child
  tree of the organization of the document header of the new line,
  use the organization of the original invoice line
* If not, use the organization of the document header of the new line

---
M src/org/openbravo/erpCommon/ad_actionButton/CopyFromInvoice.java
---
(0100042)
dmiguelez (developer)
2017-10-24 16:24

Code Review + Testing Ok
(0101344)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-10-19 17:09 maite New Issue
2017-10-19 17:09 maite Assigned To => Triage Finance
2017-10-19 17:09 maite Modules => Core
2017-10-19 17:09 maite Triggers an Emergency Pack => No
2017-10-19 17:09 maite Issue Monitored: networkb
2017-10-19 17:35 nonofrancisco Assigned To Triage Finance => nonofrancisco
2017-10-19 17:36 nonofrancisco Status new => scheduled
2017-10-19 21:51 nonofrancisco Note Added: 0099972
2017-10-19 23:41 aferraz Relationship added caused by 0034195
2017-10-24 10:04 dmiguelez Regression level => Production - Confirmed Stable
2017-10-24 10:04 dmiguelez Regression date => 2016-10-13
2017-10-24 10:04 dmiguelez Regression introduced in release => 3.0PR17Q1
2017-10-24 10:04 dmiguelez Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/9ec41af386ae [^]
2017-10-24 16:21 hgbot Checkin
2017-10-24 16:21 hgbot Note Added: 0100035
2017-10-24 16:21 hgbot Status scheduled => resolved
2017-10-24 16:21 hgbot Resolution open => fixed
2017-10-24 16:21 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/34517e931d716616241929f25b708370b290e55c [^]
2017-10-24 16:24 dmiguelez Review Assigned To => dmiguelez
2017-10-24 16:24 dmiguelez Note Added: 0100042
2017-10-24 16:24 dmiguelez Status resolved => closed
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101344
2018-01-08 18:21 dmiguelez Fixed in Version => 3.0PR18Q1


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker