Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037103
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Y. DBSourceManagerminorhave not tried2017-10-18 12:562018-01-24 09:07
ReporterAugustoMauchView Statuspublic 
Assigned ToAugustoMauch 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revisionb29eb5be4cfe
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - QA Approved
Regression date2017-04-26
Regression introduced in release3.0PR17Q3
Regression introduced by commithttps://code.openbravo.com/erp/devel/dbsm-main/rev/c6fa7da9db9bca6babcdb7e1f95accfb73ed1da8 [^]
Triggers an Emergency PackNo
Summary

0037103: Import.sample.data does not immediately stop when a file cannot be imported

DescriptionWhen import.sample.data is not able to import a particular file, the process should stop immediately stop, and the task should fail (see attached file properImportSampleData.log).

That was the behaviour before this changeset [1] was introduced. After that changeset was applied, an error is shown but the process keeps going, and will only fail if a foreign key cannot be satisfied (see attached file wrongImportSampleData.log).

[1] https://code.openbravo.com/erp/devel/dbsm-main/rev/c6fa7da9db9bca6babcdb7e1f95accfb73ed1da8 [^]
Steps To Reproduce- Break the XML syntax of referencedata/sampledata/F_B_International_Group/AD_TREENODE.xml by removing a </AD_TREENODE> tag
- Run install.source. The process should stop the moment the import of AD_TREENODE fails, but instead it keeps going and it ends with a build successful message.
TagsNo tags attached.
Attached Fileslog file icon properImportSampleData.log [^] (10,546 bytes) 2017-10-18 12:57
log file icon wrongImportSampleData.log [^] (9,758 bytes) 2017-10-18 12:57

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00371073.0PR17Q4 closedAugustoMauch Import.sample.data does not immediately stop when a file cannot be imported 
depends on backport 00371083.0PR17Q3.1 closedAugustoMauch Import.sample.data does not immediately stop when a file cannot be imported 
caused by feature request 0035832 closedAugustoMauch Support using several threads to import and export the sample data 

-  Notes
(0099946)
hgbot (developer)
2017-10-18 18:56

Repository: erp/devel/dbsm-main
Changeset: b29eb5be4cfe743c2c6021cf4c66e97698fe08bd
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Oct 18 15:58:11 2017 +0200
URL: http://code.openbravo.com/erp/devel/dbsm-main/rev/b29eb5be4cfe743c2c6021cf4c66e97698fe08bd [^]

Fixes issue 37103: import.sample.data fails if a file cannot be imported

If a file cannot be imported the import.sample.data process will stop immediately and will show log describing the problem.

To be able to catch the exceptions thrown in another thread, now the logic to import files is wrapped in a Callable instead of a Runnable.

---
M .classpath
M src/org/apache/ddlutils/platform/postgresql/PostgreSqlDatabaseDataIO.java
M src/org/openbravo/ddlutils/task/ImportSampledata.java
---
(0099947)
hgbot (developer)
2017-10-18 18:56

Repository: erp/devel/pi
Changeset: b2d14bbc54372b9bcece476d8e3871b117e3d00f
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Oct 18 18:43:04 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/b2d14bbc54372b9bcece476d8e3871b117e3d00f [^]

Fixes issue 37103: import.sample.data fails if a file cannot be imported

If a file cannot be imported the import.sample.data process will stop immediately and will show log describing the problem.

To be able to catch the exceptions thrown in another thread, now the logic to import files is wrapped in a Callable instead of a Runnable.

---
M src-db/database/lib/dbsourcemanager.jar
---
(0099948)
hgbot (developer)
2017-10-18 19:02

Repository: erp/devel/dbsm-main
Changeset: 7c34d0f9910175614ce9040ccc3288be28683a58
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Oct 18 18:48:57 2017 +0200
URL: http://code.openbravo.com/erp/devel/dbsm-main/rev/7c34d0f9910175614ce9040ccc3288be28683a58 [^]

Related with issue 37103: Unneeded change is backed out

The change done in .classpath was not meant to be pushed.

---
M .classpath
---
(0099949)
hgbot (developer)
2017-10-18 19:02

Repository: erp/devel/pi
Changeset: c77412df1f7e134dae3ed3ef3f4f9496d1d789f5
Author: Augusto Mauch <augusto.mauch <at> openbravo.com>
Date: Wed Oct 18 18:49:31 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/c77412df1f7e134dae3ed3ef3f4f9496d1d789f5 [^]

Related with issue 37103: Unneeded change is backed out

The change done in .classpath was not meant to be pushed.

---
M src-db/database/lib/dbsourcemanager.jar
---
(0100020)
alostale (developer)
2017-10-24 12:39

reviewed + tested
(0101336)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test
(0101337)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-10-18 12:56 AugustoMauch New Issue
2017-10-18 12:56 AugustoMauch Assigned To => AugustoMauch
2017-10-18 12:56 AugustoMauch Modules => Core
2017-10-18 12:56 AugustoMauch Regression level => Production - QA Approved
2017-10-18 12:56 AugustoMauch Regression date => 2017-04-26
2017-10-18 12:56 AugustoMauch Regression introduced in release => 3.0PR17Q3
2017-10-18 12:56 AugustoMauch Regression introduced by commit => https://code.openbravo.com/erp/devel/dbsm-main/rev/c6fa7da9db9bca6babcdb7e1f95accfb73ed1da8 [^]
2017-10-18 12:56 AugustoMauch Triggers an Emergency Pack => No
2017-10-18 12:57 AugustoMauch File Added: properImportSampleData.log
2017-10-18 12:57 AugustoMauch File Added: wrongImportSampleData.log
2017-10-18 12:58 AugustoMauch Description Updated View Revisions
2017-10-18 18:43 AugustoMauch Status new => scheduled
2017-10-18 18:56 hgbot Checkin
2017-10-18 18:56 hgbot Note Added: 0099946
2017-10-18 18:56 hgbot Status scheduled => resolved
2017-10-18 18:56 hgbot Resolution open => fixed
2017-10-18 18:56 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/dbsm-main/rev/b29eb5be4cfe743c2c6021cf4c66e97698fe08bd [^]
2017-10-18 18:56 hgbot Checkin
2017-10-18 18:56 hgbot Note Added: 0099947
2017-10-18 18:56 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/dbsm-main/rev/b29eb5be4cfe743c2c6021cf4c66e97698fe08bd [^] => http://code.openbravo.com/erp/devel/pi/rev/b2d14bbc54372b9bcece476d8e3871b117e3d00f [^]
2017-10-18 18:57 AugustoMauch Review Assigned To => alostale
2017-10-18 18:57 AugustoMauch Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/b2d14bbc54372b9bcece476d8e3871b117e3d00f [^] => http://code.openbravo.com/erp/devel/dbsm-main/rev/b29eb5be4cfe743c2c6021cf4c66e97698fe08bd [^]
2017-10-18 19:02 hgbot Checkin
2017-10-18 19:02 hgbot Note Added: 0099948
2017-10-18 19:02 hgbot Checkin
2017-10-18 19:02 hgbot Note Added: 0099949
2017-10-24 12:39 alostale Note Added: 0100020
2017-10-24 12:39 alostale Status resolved => closed
2017-10-24 12:39 alostale Fixed in Version => 3.0PR18Q1
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101336
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101337
2018-01-24 09:07 alostale Relationship added caused by 0035832


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker