Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0037083
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] A. PlatformmajorN/A2017-10-17 10:162018-04-13 08:23
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PrioritynormalResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revisionde01ec0bdf46
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0037083: support JDK 9

DescriptionSupport Openbravo to be deployed with Java 9.

See: http://wiki.openbravo.com/wiki/Projects:Java_9_Support [^]
Steps To Reproduce-
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to feature request 0031708 closedalostale Openbravo ERP support for JDK 8 
related to feature request 0038130 closedcaristu Openbravo ERP support JDK 11 
related to defect 0038357 closedcaristu Openbravo ERP Unused connection pool created on module installation 
depends on defect 0037959 closedshuehner Openbravo ERP JDK 9: remove [dep-ann] warnings by adding the missing @Deprecated annotation (functional team code) 
depends on defect 00379643.0PR18Q2 closedTriage Finance Openbravo ERP JDK 9: fix new BigDecimal related deprecation warnigns 
depends on defect 0037965 closedTriage Finance Openbravo ERP JDK9: Fix new deprecation warnings related to: new Long, new Integer, new Boolean... 
depends on defect 0037966 closedshuehner Retail Modules JDK 9: fix new BigDecimal related deprecation warnigns 
depends on defect 0037967 closedshuehner Retail Modules JDK9: Fix new deprecation warnings related to: new Long, new Integer, new Boolean... 
depends on defect 0038344 closedcaristu Openbravo ERP Restart tomcat 8.0 not working after installing a module through MMC using JDK9 
related to defect 0037230 closedshuehner Openbravo ERP JDK9: compilation warnings - Platform Team 
related to defect 0037232 newRetail Openbravo ERP JDK9: compilation warnings - Platform Team 
related to defect 0037231 closedcollazoandy4 Openbravo ERP JDK9: compilation warnings - Functional Team 
related to design defect 0037233 closedplatform Openbravo ERP JDK 9: remove dependency on deprecated modules 
related to defect 0037825 closedshuehner Openbravo ERP Fix new javadoc warnings active by default in JDK 9 
related to defect 0037941 closedshuehner Openbravo ERP JDK 9: remove [dep-ann] warnings by adding the missing @Deprecated annotation (platform code) 
related to defect 0037942 closedjarmendariz Openbravo ERP JDK 9: remove [dep-ann] warnings by removing deprecated elements 
related to defect 0037943 closedjarmendariz Openbravo ERP JDK 9: remove [deprecation] newInstance() in Class warnings 
related to defect 0038091 closedjarmendariz Retail Modules JDK 9: Remove [dep-ann] warnings removing deprecated elements 
related to defect 0038115 closedjarmendariz Retail Modules JDK 9: Remove newInstance() deprecation warnings 
related to defect 0038131 closedjarmendariz Openbravo ERP Remove deprecated message for AccessibleObject.isAccesible 
related to design defect 0038132 acknowledgedplatform Openbravo ERP Replace deprecated isAccesible() with canAccess() introduced in JDK9 
related to design defect 0038152 newplatform Openbravo ERP Fix more javadoc warnings active by default in JDK 9 
related to feature request 0038196 closedplatform Openbravo ERP support for JDK 10 
related to defect 0038229 closedmarvintm Modules JDK9: Fix new deprecation warnings related to: new Long, new Integer, new Boolean in Analytics 
related to defect 0038225 closedmarvintm Retail Modules There are several warnings when using Java 9 in some retail modules 
related to defect 0038335 closedAugustoMauch Openbravo ERP Fix Java 9 warnings in org.openbravo.utility.multiplebpselector module 
related to defect 0038436 closedaferraz Modules JDK 9: Remove newInstance() deprecation warnings 
related to design defect 0039031 newplatform Openbravo ERP Tracking issue: Remove illegal access warnings shown since java9 by updating affected jar libraries 
related to defect 0039576 closedalostale Openbravo ERP JDK 9+: cannot send email 

-  Notes
(0100350)
hgbot (developer)
2017-11-08 14:13

Repository: erp/devel/pi
Changeset: de01ec0bdf46b20934bf9a309055755a0f7662b9
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Wed Nov 08 14:11:15 2017 +0100
URL: http://code.openbravo.com/erp/devel/pi/rev/de01ec0bdf46b20934bf9a309055755a0f7662b9 [^]

fixed 37083: support JDK 9

---
M build.xml
M src-core/build.xml
M src-test/src/org/openbravo/test/AllAntTaskTests.java
M src/build.xml
A src-test/src/org/openbravo/test/reporting/AllJrxmlCompilation.java
---
(0100415)
caristu (developer)
2017-11-10 09:49
edited on: 2017-11-10 09:51

Code reviewed and tested as part of the project[1].

[1] https://docs.google.com/spreadsheets/d/1ZpJgp_0tkYSw8rQJ_z_HeJMYhG8PJeIJTcx0qWTYVnI [^]


- Issue History
Date Modified Username Field Change
2017-10-17 10:16 alostale New Issue
2017-10-17 10:16 alostale Assigned To => platform
2017-10-17 10:16 alostale Modules => Core
2017-10-17 10:16 alostale Triggers an Emergency Pack => No
2017-10-17 10:17 alostale Relationship added related to 0031708
2017-11-06 12:57 alostale Relationship added related to 0037230
2017-11-06 13:05 alostale Relationship added related to 0037232
2017-11-06 13:06 alostale Relationship added related to 0037231
2017-11-06 13:10 alostale Relationship added has duplicate 0037233
2017-11-06 13:11 alostale Assigned To platform => alostale
2017-11-06 13:11 alostale Review Assigned To => caristu
2017-11-06 13:11 alostale Status new => scheduled
2017-11-08 14:13 hgbot Checkin
2017-11-08 14:13 hgbot Note Added: 0100350
2017-11-08 14:13 hgbot Status scheduled => resolved
2017-11-08 14:13 hgbot Resolution open => fixed
2017-11-08 14:13 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/de01ec0bdf46b20934bf9a309055755a0f7662b9 [^]
2017-11-10 09:48 caristu Description Updated View Revisions
2017-11-10 09:49 caristu Note Added: 0100415
2017-11-10 09:49 caristu Status resolved => closed
2017-11-10 09:49 caristu Fixed in Version => 3.0PR18Q1
2017-11-10 09:51 caristu Note Edited: 0100415 View Revisions
2018-02-04 15:52 shuehner Relationship added related to 0037825
2018-02-15 18:43 caristu Relationship added related to 0037941
2018-02-15 18:45 caristu Relationship added related to 0037942
2018-02-15 18:55 caristu Relationship added related to 0037943
2018-02-16 12:15 shuehner Relationship added depends on 0037959
2018-02-18 19:12 shuehner Relationship added depends on 0037964
2018-02-19 11:34 shuehner Relationship added depends on 0037965
2018-02-19 11:39 shuehner Relationship added depends on 0037966
2018-02-19 11:59 shuehner Relationship added depends on 0037967
2018-03-13 16:31 caristu Relationship added related to 0038091
2018-03-13 16:31 caristu Relationship added related to 0038115
2018-03-14 11:03 caristu Issue cloned 0038130
2018-03-14 11:14 jarmendariz Relationship added related to 0038131
2018-03-14 11:37 caristu Relationship added related to 0038130
2018-03-14 19:49 caristu Relationship added related to 0038132
2018-03-21 09:33 caristu Relationship added related to 0038152
2018-03-22 12:18 caristu Relationship added related to 0038196
2018-03-26 17:30 marvintm Relationship added related to 0038229
2018-03-26 17:50 marvintm Relationship added related to 0038225
2018-04-11 18:29 AugustoMauch Relationship added related to 0038335
2018-04-12 14:16 caristu Relationship added depends on 0038344
2018-04-13 08:23 alostale Relationship added related to 0038357
2018-04-24 14:22 aferraz Relationship added related to 0038436
2018-04-25 14:00 alostale Relationship replaced related to 0037233
2018-07-24 17:05 shuehner Relationship added related to 0039031
2018-11-01 12:22 alostale Relationship added related to 0039576


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker