Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036950
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] Y. DBSourceManagermajorhave not tried2017-09-26 10:022017-09-28 10:15
ReporterinigosanchezView Statuspublic 
Assigned Toinigosanchez 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revision5e375c7475da
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned ToAugustoMauch
Web browser
ModulesCore
Regression levelCoding ( Testing )
Regression date2017-09-14
Regression introduced in releasepi
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/d936b7f0882f [^]
Triggers an Emergency PackNo
Summary

0036950: CheckAPIDistribution task is not working as expected

DescriptionCheckAPIDistribution task is not working as expected since this issue 0036137 was introduced into the distribution. Before the issue was introduce this log[1] is shown:
...................................
 [checkAPI] 10672 INFO - Loading and applying configuration scripts
 [checkAPI] 10677 INFO - Applying data part of configuration script: org.openbravo.retail.pack
 [checkAPI] 10679 INFO - Loading configuration script: /srv/ci/workspace/ret-api/SANDBOX/api-checks/model/modules/org.openbravo.retail.pack/src-db/database/configScript.xml
 [checkAPI] Warning: old value in row not equal to expected one. Table:[AD_TAB] PK[: 800222] Old Value found: Y Old value expected N
 [checkAPI] Warning: old value in row not equal to expected one. Table:[AD_TAB] PK[: 800223] Old Value found: Y Old value expected N
...................................

After the issue was introduce, the warnings are disappeared. See log [2]. The reason is that DBSMOBUtil.loadDataStructures method is not executed DBSMOBUtil.applyConfigScripts anymore.



[1].- http://ci.openbravo.com/view/retail/job/ret-api/732/console [^]
[2].- http://ci.openbravo.com/view/retail/job/ret-api/733/console [^]
Steps To Reproduce-
Proposed SolutionIt should be checked (and fixed) all the places in where loadDataStructures is executed, especially:
-ExportDatabase
-ExportSampledata
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
caused by defect 0036137 closedinigosanchez [SER-QA 2918] Config script removeCheckChange are not applied on install.source 
related to defect 0036956 acknowledgedplatform Some warnings appear (when it shouldn't) in "ret-api" job is executed. 

-  Notes
(0099596)
hgbot (developer)
2017-09-26 15:55

Repository: erp/devel/dbsm-main
Changeset: 9fec4f365d344c16e492eddcb0faf2cbdc5c7bfa
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Tue Sep 26 15:08:36 2017 +0200
URL: http://code.openbravo.com/erp/devel/dbsm-main/rev/9fec4f365d344c16e492eddcb0faf2cbdc5c7bfa [^]

Fixed issue 36950: CheckAPIDistribution task is not working as expected

The problem was introduced in these improvements of DBSM sources (0036137). The problem
was that CheckAPIDistribution task are not applied configScript files as expected and
for this reason, some warnings dissappear from the log in ret-api. Now the problem has
been fixed by applying the configScript files properly.

Besides it are reviewed the following tasks that used loadDataStructures method:
- ExportDatabase
- ExportConfigScript

---
M src/org/openbravo/ddlutils/task/CheckAPIDistribution.java
---
(0099597)
hgbot (developer)
2017-09-26 15:59

Repository: erp/devel/pi
Changeset: 5e375c7475dac5207e2c6a3bbefc332402ac24e1
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Tue Sep 26 15:41:01 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/5e375c7475dac5207e2c6a3bbefc332402ac24e1 [^]

Fixed issue 36950: CheckAPIDistribution task is not working as expected

The problem was introduced in these improvements of DBSM sources (0036137). The problem
was that CheckAPIDistribution task are not applied configScript files as expected and
for this reason, some warnings dissappear from the log in ret-api. Now the problem has
been fixed by applying the configScript files properly.

Besides it are reviewed the following tasks that used loadDataStructures method:
- ExportDatabase
- ExportConfigScript

---
M src-db/database/lib/dbsourcemanager.jar
---
(0099598)
inigosanchez (developer)
2017-09-26 16:02

Tests:
- Execute DBSM suite -> All is green!
- Execute ret-api job manually: ant run.api.test.model -DstableDBdir=. -Dmodules=org.openbravo.retail.pack,org.openbravo.retail.config,org.openbravo.retail.posterminal,org.openbravo.retail.poshwmanager,org.openbravo.retail.discounts,org.openbravo.mobile.core,org.openbravo.retail.sampledata,org.openbravo.retail.returns -> Warnings are appeared again!
(0099612)
hudsonbot (developer)
2017-09-27 00:09

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/f8aef32786fd [^]
Maturity status: Test
(0099644)
AugustoMauch (developer)
2017-09-28 10:15

Code reviewed and verified

- Issue History
Date Modified Username Field Change
2017-09-26 10:02 inigosanchez New Issue
2017-09-26 10:02 inigosanchez Assigned To => platform
2017-09-26 10:02 inigosanchez Modules => Core
2017-09-26 10:02 inigosanchez Triggers an Emergency Pack => No
2017-09-26 10:04 inigosanchez Status new => scheduled
2017-09-26 10:04 inigosanchez Assigned To platform => inigosanchez
2017-09-26 10:05 inigosanchez Regression level => Coding ( Testing )
2017-09-26 10:05 inigosanchez Regression date => 2017-09-14
2017-09-26 10:05 inigosanchez Regression introduced in release => pi
2017-09-26 10:05 inigosanchez Regression introduced by commit => https://code.openbravo.com/erp/devel/pi/rev/d936b7f0882f [^]
2017-09-26 10:08 inigosanchez Relationship added caused by 0036137
2017-09-26 15:53 inigosanchez Description Updated View Revisions
2017-09-26 15:54 inigosanchez Relationship added related to 0036956
2017-09-26 15:55 hgbot Checkin
2017-09-26 15:55 hgbot Note Added: 0099596
2017-09-26 15:55 hgbot Status scheduled => resolved
2017-09-26 15:55 hgbot Resolution open => fixed
2017-09-26 15:55 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/dbsm-main/rev/9fec4f365d344c16e492eddcb0faf2cbdc5c7bfa [^]
2017-09-26 15:59 hgbot Checkin
2017-09-26 15:59 hgbot Note Added: 0099597
2017-09-26 15:59 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/dbsm-main/rev/9fec4f365d344c16e492eddcb0faf2cbdc5c7bfa [^] => http://code.openbravo.com/erp/devel/pi/rev/5e375c7475dac5207e2c6a3bbefc332402ac24e1 [^]
2017-09-26 16:02 inigosanchez Review Assigned To => AugustoMauch
2017-09-26 16:02 inigosanchez Note Added: 0099598
2017-09-27 00:09 hudsonbot Checkin
2017-09-27 00:09 hudsonbot Note Added: 0099612
2017-09-28 10:14 AugustoMauch Status resolved => closed
2017-09-28 10:14 AugustoMauch Fixed in Version => 3.0PR17Q4
2017-09-28 10:15 AugustoMauch Note Added: 0099644


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker