Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036857
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2017-09-14 13:092017-09-15 11:35
ReporteralostaleView Statuspublic 
Assigned Toalostale 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revision756e6fab2ecf
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Tocaristu
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036857: having \u2028 or \u2029 characters in recent documents title makes UI to fail

DescriptionWhen there is a document that includes on its identifier \u2028 or \u2029 characters, Openbravo fails to load.
Steps To Reproduce1. Follow steps in 0036788 creating BP with name and search key with those charactres
2. Log out
3. Log in
  -> ERROR: Openbravo is no loaded because the generated JavaScript is not valid
Proposed SolutionThe problem is caused because even the JavaScript is generated using js_string in freemarker, current version (2.3.16) doesn't escape reported ones properly. This issue is fixed since 2.3.20 [1][2].

A temporary fix will be implemented until freemarked library is updated.

--
[1] https://sourceforge.net/p/freemarker/bugs/390/ [^]
[2] https://github.com/apache/incubator-freemarker/commit/e6daec6e63b967faea9579f63bfad333bb22e9ad [^]
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 0036788 closedalostale adding a \u2028 (line separator) character to any field makes UI to fail 
related to feature request 0036858 acknowledgedplatform update freemarker 

-  Notes
(0099040)
hgbot (developer)
2017-09-14 13:26

Repository: erp/devel/pi
Changeset: 756e6fab2ecf9db6c03b93fb5e7b250a8be4bb23
Author: Asier Lostalé <asier.lostale <at> openbravo.com>
Date: Thu Sep 14 13:25:35 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/756e6fab2ecf9db6c03b93fb5e7b250a8be4bb23 [^]

fixed 36857: invalid js generated if \u2028 or \u2029 chars are in recent docs

  Implemented temporary fix until freemarker gets updated. Dynamic js resources
  now escape those special characters.

---
M modules/org.openbravo.client.kernel/src/org/openbravo/client/kernel/SessionDynamicResourceComponent.java
---
(0099064)
caristu (developer)
2017-09-15 11:35

Code reviewed + testing OK.

- Issue History
Date Modified Username Field Change
2017-09-14 13:09 alostale New Issue
2017-09-14 13:09 alostale Assigned To => platform
2017-09-14 13:09 alostale Modules => Core
2017-09-14 13:09 alostale Triggers an Emergency Pack => No
2017-09-14 13:09 alostale Relationship added related to 0036788
2017-09-14 13:09 alostale Review Assigned To => caristu
2017-09-14 13:09 alostale Assigned To platform => alostale
2017-09-14 13:13 alostale Relationship added related to 0036858
2017-09-14 13:26 hgbot Checkin
2017-09-14 13:26 hgbot Note Added: 0099040
2017-09-14 13:26 hgbot Status new => resolved
2017-09-14 13:26 hgbot Resolution open => fixed
2017-09-14 13:26 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/756e6fab2ecf9db6c03b93fb5e7b250a8be4bb23 [^]
2017-09-15 11:35 caristu Note Added: 0099064
2017-09-15 11:35 caristu Status resolved => closed
2017-09-15 11:35 caristu Fixed in Version => 3.0PR17Q4


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker