Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036838
TypeCategorySeverityReproducibilityDate SubmittedLast Update
defect[Openbravo ERP] A. Platformminorhave not tried2017-09-12 11:462018-01-03 12:38
ReporteralostaleView Statuspublic 
Assigned Toinigosanchez 
PriorityhighResolutionfixedFixed in Version3.0PR18Q1
StatusclosedFix in branchFixed in SCM revision94f7f5352304
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036838: multiple requests to load product image when a refresh is done previously

DescriptionWhen a product has an image associated, multiple requests are performed when it is displayed in form view. (refresh should be done after open the record in form view)
Steps To Reproduce1. Open any product in form view and associate it an image and close the form view.
2. Reopen it again in form view (1 request is done: FIC) and refresh it by clicking in the refresh button (2 request are done: FETCH + FIC). Close the form view.
3. Reopen the previous product in form view (2 request are done: target_request_to_remove + FIC).
  -> Check requests:
    * 2 x ImagesActionHandler GETSIZE
    * 2 x ShowImage
TagsPerformance
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
related to defect 00230543.0MP22 closedshankarb Impossible to add change client image 
related to defect 0037095 closedinigosanchez A request to load product image is performed when return from FormView to the GridView 

-  Notes
(0099939)
hgbot (developer)
2017-10-18 16:11

Repository: erp/devel/pi
Changeset: 94f7f53523045d4609d5c38bc412585ec1a3527b
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Wed Oct 18 15:55:58 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/94f7f53523045d4609d5c38bc412585ec1a3527b [^]

Fixed issue 36838: multiple requests to load product image are performed

The problem was that multiple requests were performed when it shouldn't. When a product had an image, multiple
requests were being performed when the product was beeing displayed in form view and a refresh was being done.
Another problem discovered in the research of the issue was that a request was being performed when return from
FormView to the GridView. This request should not be performed because images are not showed in the grid view.

Both problems have been fixed by take into account when a request should be performed to retrieve an image. When
the image is loaded previously, the setValue of the ob-formitem-image avoids to performed an unnecessary request
to the server.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-image.js
---
(0100024)
alostale (developer)
2017-10-24 13:08

reopened: still duplicates to showImage
(0100128)
hgbot (developer)
2017-10-28 13:28

Repository: erp/devel/pi
Changeset: 82a3e88a20e8998b5bdb476a81b066f6121bb1b1
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Sat Oct 28 13:27:49 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/82a3e88a20e8998b5bdb476a81b066f6121bb1b1 [^]

Related with issue 36838: multiple requests to load product image are performed

The problem was that multiple ShowImage requests were performed when it shouldn't.

Now, the problem is fixed by take into account when the image has been loaded previously. In this case,
the setValue of the ob-formitem-image avoids to performed an unnecessary request to the server.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-image.js
---
(0100129)
hgbot (developer)
2017-10-29 02:45

Repository: erp/devel/pi
Changeset: 82a3e88a20e8998b5bdb476a81b066f6121bb1b1
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Sat Oct 28 13:27:49 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/82a3e88a20e8998b5bdb476a81b066f6121bb1b1 [^]

Related with issue 36838: multiple requests to load product image are performed

The problem was that multiple ShowImage requests were performed when it shouldn't.

Now, the problem is fixed by take into account when the image has been loaded previously. In this case,
the setValue of the ob-formitem-image avoids to performed an unnecessary request to the server.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-image.js
---
(0100130)
hgbot (developer)
2017-10-29 02:48

Repository: erp/devel/pi
Changeset: 82a3e88a20e8998b5bdb476a81b066f6121bb1b1
Author: Inigo Sanchez <inigo.sanchez <at> openbravo.com>
Date: Sat Oct 28 13:27:49 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/82a3e88a20e8998b5bdb476a81b066f6121bb1b1 [^]

Related with issue 36838: multiple requests to load product image are performed

The problem was that multiple ShowImage requests were performed when it shouldn't.

Now, the problem is fixed by take into account when the image has been loaded previously. In this case,
the setValue of the ob-formitem-image avoids to performed an unnecessary request to the server.

---
M modules/org.openbravo.client.application/web/org.openbravo.client.application/js/form/formitem/ob-formitem-image.js
---
(0100238)
alostale (developer)
2017-11-03 09:11

reviewed + tested
(0101335)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test
(0101352)
hudsonbot (developer)
2018-01-03 12:38

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/c81e0d3cbab5 [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-09-12 11:46 alostale New Issue
2017-09-12 11:46 alostale Assigned To => platform
2017-09-12 11:46 alostale Modules => Core
2017-09-12 11:46 alostale Triggers an Emergency Pack => No
2017-09-12 11:46 alostale Tag Attached: Performance
2017-09-12 11:46 alostale Priority normal => high
2017-09-12 11:46 alostale Status new => acknowledged
2017-10-16 17:06 inigosanchez Status acknowledged => scheduled
2017-10-16 17:06 inigosanchez Assigned To platform => inigosanchez
2017-10-17 11:31 inigosanchez Summary multiple requests to load product image => multiple requests to load product image when a refresh is done previously
2017-10-17 11:31 inigosanchez Description Updated View Revisions
2017-10-17 11:31 inigosanchez Steps to Reproduce Updated View Revisions
2017-10-18 10:02 inigosanchez Relationship added related to 0023054
2017-10-18 10:27 inigosanchez Relationship added related to 0037095
2017-10-18 16:11 hgbot Checkin
2017-10-18 16:11 hgbot Note Added: 0099939
2017-10-18 16:11 hgbot Status scheduled => resolved
2017-10-18 16:11 hgbot Resolution open => fixed
2017-10-18 16:11 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/94f7f53523045d4609d5c38bc412585ec1a3527b [^]
2017-10-18 16:12 inigosanchez Review Assigned To => alostale
2017-10-24 13:08 alostale Note Added: 0100024
2017-10-24 13:08 alostale Status resolved => new
2017-10-24 13:08 alostale Resolution fixed => open
2017-10-28 13:28 hgbot Checkin
2017-10-28 13:28 hgbot Note Added: 0100128
2017-10-28 13:28 inigosanchez Status new => scheduled
2017-10-28 13:29 inigosanchez Status scheduled => resolved
2017-10-28 13:29 inigosanchez Fixed in Version => 3.0PR18Q1
2017-10-28 13:29 inigosanchez Resolution open => fixed
2017-10-29 02:45 hgbot Checkin
2017-10-29 02:45 hgbot Note Added: 0100129
2017-10-29 02:48 hgbot Checkin
2017-10-29 02:48 hgbot Note Added: 0100130
2017-11-03 09:11 alostale Note Added: 0100238
2017-11-03 09:11 alostale Status resolved => closed
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101335
2018-01-03 12:38 hudsonbot Checkin
2018-01-03 12:38 hudsonbot Note Added: 0101352


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker