Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036813
TypeCategorySeverityReproducibilityDate SubmittedLast Update
feature request[Openbravo ERP] 04. Warehouse managementminoralways2017-09-08 12:282017-09-21 16:49
ReporterdmiguelezView Statuspublic 
Assigned Todmiguelez 
PrioritynormalResolutionfixedFixed in Version3.0PR17Q4
StatusclosedFix in branchFixed in SCM revision44c43a10b62a
ProjectionnoneETAnoneTarget Version
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toaferraz
Web browser
ModulesCore
Regression level
Regression date
Regression introduced in release
Regression introduced by commit
Triggers an Emergency PackNo
Summary

0036813: Change API for Virtual Bins (as of now, only used by Advanced Warehouse Operations Module)

DescriptionChange API for Virtual Bins (as of now, only used by Advanced Warehouse Operations Module)
Steps To ReproduceChanged API for retrieving number of Virtual Bins created in the System.
As of now, this is only used by Advanced Warehouse Operations Module.
TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
depends on backport 00368233.0PR17Q3 closeddmiguelez Change API for Virtual Bins (as of now, only used by Advanced Warehouse Operations Module) 

-  Notes
(0098931)
hgbot (developer)
2017-09-11 11:03

Repository: erp/devel/pi
Changeset: 44c43a10b62a5660963ece123192899175d5a92d
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Fri Sep 08 12:30:00 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/44c43a10b62a5660963ece123192899175d5a92d [^]

Fixes Issue 36813. Changed API

* Added new boolean parameter to funciton
* Created two new functions to call the original one without the boolean
  parameter
* Changed save by a flush to avoid problems when the Hibernate session
  is cleared

---
M src/org/openbravo/erpCommon/utility/InventoryStatusUtils.java
---
(0098942)
hgbot (developer)
2017-09-11 13:43

Repository: erp/devel/pi
Changeset: 4e8bc828c14b0264680567002fa41e265212bfff
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Mon Sep 11 13:05:23 2017 +0200
URL: http://code.openbravo.com/erp/devel/pi/rev/4e8bc828c14b0264680567002fa41e265212bfff [^]

Related to issue 36813. Changed visibility of method to private
since it should be called from getNumberOfTotalVirutalBins and
getNumberOfActiveVirtualBins public methods instead.

---
M src/org/openbravo/erpCommon/utility/InventoryStatusUtils.java
---
(0098943)
hgbot (developer)
2017-09-11 13:43

Repository: erp/devel/api-checks
Changeset: 85ff1553922a292b498c9d1b395fc20632a24aa0
Author: David Miguelez <david.miguelez <at> openbravo.com>
Date: Mon Sep 11 13:42:35 2017 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/85ff1553922a292b498c9d1b395fc20632a24aa0 [^]

Related to Issue 36813. False api change.
This method has not been included in a published release yet.

---
M java/reference/java.japi.gz
---
(0098955)
aferraz (developer)
2017-09-11 17:56

Code review OK
(0098978)
hgbot (developer)
2017-09-12 11:03

Repository: erp/devel/api-checks
Changeset: 3810d5900d7281e3599a94080290102d57ed196e
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Sep 12 11:03:08 2017 +0200
URL: http://code.openbravo.com/erp/devel/api-checks/rev/3810d5900d7281e3599a94080290102d57ed196e [^]

related to issue 36813: re-pushed false api change

---
M java/reference/java.japi.gz
---
(0099372)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test
(0099374)
hudsonbot (developer)
2017-09-21 16:49

A changeset related to this issue has been promoted main and to the
Central Repository, after passing a series of tests.

Promotion changeset: https://code.openbravo.com/erp/devel/main/rev/9750b78d3e5c [^]
Maturity status: Test

- Issue History
Date Modified Username Field Change
2017-09-08 12:28 dmiguelez New Issue
2017-09-08 12:28 dmiguelez Assigned To => Triage Finance
2017-09-08 12:28 dmiguelez Modules => Core
2017-09-08 12:28 dmiguelez Triggers an Emergency Pack => No
2017-09-11 11:01 dmiguelez Status new => scheduled
2017-09-11 11:01 dmiguelez Assigned To Triage Finance => dmiguelez
2017-09-11 11:03 hgbot Checkin
2017-09-11 11:03 hgbot Note Added: 0098931
2017-09-11 11:03 hgbot Status scheduled => resolved
2017-09-11 11:03 hgbot Resolution open => fixed
2017-09-11 11:03 hgbot Fixed in SCM revision => http://code.openbravo.com/erp/devel/pi/rev/44c43a10b62a5660963ece123192899175d5a92d [^]
2017-09-11 13:43 hgbot Checkin
2017-09-11 13:43 hgbot Note Added: 0098942
2017-09-11 13:43 hgbot Checkin
2017-09-11 13:43 hgbot Note Added: 0098943
2017-09-11 17:56 aferraz Review Assigned To => aferraz
2017-09-11 17:56 aferraz Note Added: 0098955
2017-09-11 17:56 aferraz Status resolved => closed
2017-09-11 17:56 aferraz Fixed in Version => 3.0PR17Q4
2017-09-12 11:03 hgbot Checkin
2017-09-12 11:03 hgbot Note Added: 0098978
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099372
2017-09-21 16:49 hudsonbot Checkin
2017-09-21 16:49 hudsonbot Note Added: 0099374


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker