Anonymous | Login
Project:
RSS
  
News | My View | View Issues | Roadmap | Summary

View Issue DetailsJump to Notes ] Issue History ] Print ]
ID
0036739
TypeCategorySeverityReproducibilityDate SubmittedLast Update
backport[Openbravo ERP] A. Platformmajoralways2017-08-28 14:552017-08-30 10:40
ReporterJONHMView Statuspublic 
Assigned Tocaristu 
PriorityhighResolutionfixedFixed in Version3.0PR17Q2.3
StatusclosedFix in branchFixed in SCM revision8fdd44373f60
ProjectionnoneETAnoneTarget Version3.0PR17Q2.3
OSAnyDatabaseAnyJava version
OS VersionDatabase versionAnt version
Product VersionSCM revision 
Review Assigned Toalostale
Web browser
ModulesCore
Regression levelProduction - Confirmed Stable
Regression date2017-06-21
Regression introduced in release
Regression introduced by commithttps://code.openbravo.com/erp/devel/pi/rev/bdca94625dbf67b7e9dbf54f7535f6f22b499b14 [^]
Triggers an Emergency PackNo
Summary

0036739: Error displaying in selector picklist a field based in a non-primitive derived property

DescriptionAn error is thrown when using a selector that is configured to display a field in the picklist which is based in a non-primitive derived property, i.e., a property resolved through property navigation which points to a reference.
Steps To Reproduce- As System Administrator
1) Open window "Reference" and select 'Product (by Price and Warehouse)'
2) Switch to [Defined Selector] tab and then to [Defined Selector Field] subtab
3) Create a new record:
  Name: Product2
  Property: productPrice.product
  Show in picklist: YES

- As F&B International Group Admin
4) Open "Sales Order" window and create a new record from 'Alimentos y Supermercados, S.A' bussiness partner
5) Create a new line and open the 'Product' selector picklist

--> It shows the following error in the log:
ERROR org.openbravo.service.json.DefaultJsonDataService - java.lang.NullPointerException
    at org.openbravo.service.json.DataToJsonConverter.toJsonObject(DataToJsonConverter.java:219)
    at org.openbravo.service.json.DataToJsonConverter.toJsonObjects(DataToJsonConverter.java:144)
    at org.openbravo.service.json.DefaultJsonDataService.fetch(DefaultJsonDataService.java:301)
    at org.openbravo.service.datasource.DefaultDataSourceService.fetch(DefaultDataSourceService.java:85)
    at org.openbravo.service.datasource.DefaultDataSourceService.fetch(DefaultDataSourceService.java:78)
    at org.openbravo.service.datasource.DataSourceServlet.doFetch(DataSourceServlet.java:285)
    at org.openbravo.service.datasource.DataSourceServlet.doPost(DataSourceServlet.java:843)
    at javax.servlet.http.HttpServlet.service(HttpServlet.java:650)
        ...

TagsNo tags attached.
Attached Files

- Relationships Relation Graph ] Dependency Graph ]
blocks defect 0036728 closedcaristu Error displaying in selector picklist a field based in a non-primitive derived property 

-  Notes
(0098701)
hgbot (developer)
2017-08-29 13:50

Repository: erp/backports/3.0PR17Q2.3
Changeset: 8fdd44373f60c6c6653caae025fb2d808224684f
Author: Carlos Aristu <carlos.aristu <at> openbravo.com>
Date: Tue Aug 29 13:25:09 2017 +0200
URL: http://code.openbravo.com/erp/backports/3.0PR17Q2.3/rev/8fdd44373f60c6c6653caae025fb2d808224684f [^]

fixes bug 36739: Can't use fields based on some properties in selector picklist

With the fix for issue 0036268 the selector fields based on derived properties that are shown in the picklist are sent as 'extra properties' in order to calculate them properly.

The problem is that the fix was not complete when the derived properties were not primitive. In that case the DataToJsonConverter class was not calculating properly the referenced property.

Now that kind of properties are calculated properly.

---
M modules/org.openbravo.service.json/src/org/openbravo/service/json/DataToJsonConverter.java
---
(0098726)
alostale (developer)
2017-08-30 10:40

reviewed + tested

- Issue History
Date Modified Username Field Change
2017-08-29 13:12 caristu Type defect => backport
2017-08-29 13:12 caristu Target Version => 3.0PR17Q2.3
2017-08-29 13:50 hgbot Checkin
2017-08-29 13:50 hgbot Note Added: 0098701
2017-08-29 13:50 hgbot Status scheduled => resolved
2017-08-29 13:50 hgbot Resolution open => fixed
2017-08-29 13:50 hgbot Fixed in SCM revision http://code.openbravo.com/erp/devel/pi/rev/2174cbb90a5a77d9ee8d3d0140a14bbda8093223 [^] => http://code.openbravo.com/erp/backports/3.0PR17Q2.3/rev/8fdd44373f60c6c6653caae025fb2d808224684f [^]
2017-08-29 13:50 caristu Review Assigned To => alostale
2017-08-29 13:50 caristu Summary Error displaying in selector picklist a field based a non-primitive derived property => Error displaying in selector picklist a field based in a non-primitive derived property
2017-08-29 13:51 caristu Regression level Packaging and release => Production - Confirmed Stable
2017-08-29 14:36 caristu Description Updated View Revisions
2017-08-29 14:36 caristu Steps to Reproduce Updated View Revisions
2017-08-30 10:40 alostale Note Added: 0098726
2017-08-30 10:40 alostale Status resolved => closed
2017-08-30 10:40 alostale Fixed in Version => 3.0PR17Q2.3


Copyright © 2000 - 2009 MantisBT Group
Powered by Mantis Bugtracker